5322A C# API Manual: File List

5322A C# API Manual Generated 2026-05-28 from CHM/5322A/C#
  • Main Page
  • Packages
  • Classes
  • Files
  • File List
File List
Here is a list of all files with brief descriptions:
 JY5322AAITask.cs
JY5322ACITask.cs
JY5322ACOTask.cs
JY5322ADITask.cs
JY5322ADOTask.cs
Generated by doxygen 1.15.0


5322A C# API Manual: JY5322AAITask.cs File Reference

  • Classes
  • Files
  • File List
Classes | Namespaces | Enumerations
JY5322AAITask.cs File Reference

Classes

class | JY5322A.JY5322AAITask
JY5322AA Analog Input Task. More...
class | JY5322A.AIChannel
AI Channel parameter class. More...
class | JY5322A.ScalingCoefficients
将原始Raw数据转换为工程单位（电压值）的换算因子。 More...
class | JY5322A.AISampleClock
Sample clock configuration class. More...
class | JY5322A.AIExternalSampleClock
External Sample Clock Configuration Class. More...
class | JY5322A.AITrigger
AI Trigger class. More...
class | JY5322A.AIAnalogHysteresisComparator
AI Analog Hysteresis Comparator. More...
class | JY5322A.AIAnalogWindowComparator
AI Analog Window Comparator. More...
class | JY5322A.AIAnalogEdgeComparator
AI Analog Edge Comparator. More...
class | JY5322A.AIAnalogTrigger
AI Analog Trigger. More...
class | JY5322A.AIAnalogMultichannelComparator
AI Analog Multichannel Trigger/Comparator. More...
class | JY5322A.AIAnalogMultichannelHysteresisComparator
AI Analog Multichannel Hysteresis Comparator. More...
class | JY5322A.AIAnalogMultichannelHysteresisComparatorSource
AI Analog Multichannel Hysteresis Comparator Source. More...
class | JY5322A.AIAnalogMultichannelWindowComparator
AI Analog Multichannel Window Comparator. More...
class | JY5322A.AIAnalogMultichannelWindowComparatorSource
AI Analog Multichannel Window Comparator Source. More...
class | JY5322A.AIAnalogMultichannelEdgeComparator
AI Analog Multichannel Edge Comparator. More...
class | JY5322A.AIAnalogMultichannelEdgeComparatorSource
AI Analog Multichannel Edge Comparator Source. More...
class | JY5322A.AIDigitalTrigger
AI Digital Trigger. More...
class | JY5322A.AIRecord
AI Record class. More...
class | JY5322A.AIAdvanced
AI Advance parameter. More...
class | JY5322A.AISamplingInfo
AI Sampling information. More...
class | JY5322A.DSMode
DS Mode Class Paraments. More...
class | JY5322A.AISignalExport
Signal Export Class. More...

Namespaces

namespace JY5322A

Enumerations

enum | JY5322A.AITerminalBoard { JY5322A.Normal = JY5322AImport.JY5322A_Normal , JY5322A.TB_5301A = JY5322AImport.JY5322A_TB_5301A }
AI Terminal Board. More...
enum | JY5322A.AIBandWidth { JY5322A._25KHz = JY5322AImport.JY5322A_AI_BandWidth_25K , JY5322A._220KHz = JY5322AImport.JY5322A_AI_BandWidth_220K }
AI BandWidth. More...
enum JY5322A.AITriggerType {
JY5322A.Immediate = JY5322AImport.JY5322A_TriggerType_Immediately , JY5322A.Digital = JY5322AImport.JY5322A_TriggerType_Digital , JY5322A.Analog = JY5322AImport.JY5322A_TriggerType_Analog , JY5322A.Soft = JY5322AImport.JY5322A_TriggerType_Soft ,
JY5322A.MultichannelAnalog = 4
}
Trigger Type: Digital/Analog/Immediate. More...
enum | JY5322A.AIMode { JY5322A.Single = JY5322AImport.JY5322A_AI_Single , JY5322A.Finite = JY5322AImport.JY5322A_AI_Finite , JY5322A.Continuous = JY5322AImport.JY5322A_AI_Continuous , JY5322A.Record = 0x3 }
AIMode. More...
enum | JY5322A.AISampleClockSource { JY5322A.Internal = JY5322AImport.JY5322A_AI_InternalClock , JY5322A.External = JY5322AImport.JY5322A_AI_ExternalClock }
AIClockSource Type. More...
enum JY5322A.ClockTerminal {
JY5322A.PFI0 = JY5322AImport.JY5322A_Clock_PFI_0 , JY5322A.PFI1 = JY5322AImport.JY5322A_Clock_PFI_1 , JY5322A.PFI2 = JY5322AImport.JY5322A_Clock_PFI_2 , JY5322A.PFI3 = JY5322AImport.JY5322A_Clock_PFI_3 ,
JY5322A.PFI4 = JY5322AImport.JY5322A_Clock_PFI_4 , JY5322A.PFI5 = JY5322AImport.JY5322A_Clock_PFI_5 , JY5322A.PFI6 = JY5322AImport.JY5322A_Clock_PFI_6 , JY5322A.PFI7 = JY5322AImport.JY5322A_Clock_PFI_7 ,
JY5322A.PFI8 = JY5322AImport.JY5322A_Clock_PFI_8 , JY5322A.PFI9 = JY5322AImport.JY5322A_Clock_PFI_9 , JY5322A.PFI10 = JY5322AImport.JY5322A_Clock_PFI_10 , JY5322A.PFI11 = JY5322AImport.JY5322A_Clock_PFI_11 ,
JY5322A.PFI12 = JY5322AImport.JY5322A_Clock_PFI_12 , JY5322A.PFI13 = JY5322AImport.JY5322A_Clock_PFI_13 , JY5322A.PFI14 = JY5322AImport.JY5322A_Clock_PFI_14 , JY5322A.PFI15 = JY5322AImport.JY5322A_Clock_PFI_15 ,
JY5322A.PXI_Trig0 = JY5322AImport.JY5322A_SampleClock_PXI_Trig_0 , JY5322A.PXI_Trig1 = JY5322AImport.JY5322A_Clock_PXI_Trig_1 , JY5322A.PXI_Trig2 = JY5322AImport.JY5322A_Clock_PXI_Trig_2 , JY5322A.PXI_Trig3 = JY5322AImport.JY5322A_Clock_PXI_Trig_3 ,
JY5322A.PXI_Trig4 = JY5322AImport.JY5322A_Clock_PXI_Trig_4 , JY5322A.PXI_Trig5 = JY5322AImport.JY5322A_Clock_PXI_Trig_5 , JY5322A.PXI_Trig6 = JY5322AImport.JY5322A_Clock_PXI_Trig_6 , JY5322A.PXI_Trig7 = JY5322AImport.JY5322A_Clock_PXI_Trig_7 ,
JY5322A.AI_SampleClock = JY5322AImport.JY5322A_Inter_AI_SampleClock , JY5322A.CI0_SampleClock = JY5322AImport.JY5322A_Inter_CI_0_SampleClock , JY5322A.CO0_Output = JY5322AImport.JY5322A_Inter_CO_0_Output , JY5322A.DI_SampleClock = JY5322AImport.JY5322A_Clock_DI_SampleClock ,
JY5322A.DO_SampleClock = JY5322AImport.JY5322A_Clock_DO_SampleClock
}
External Sample Clock Terminal. More...
enum | JY5322A.AITriggerMode { JY5322A.Start = JY5322AImport.JY5322A_StartTrigger , JY5322A.Reference = JY5322AImport.JY5322A_ReferenceTrigger }
AI Trigger Mode. More...
enum JY5322A.AIAnalogTriggerSource {
JY5322A.Channel_0 , JY5322A.Channel_1 , JY5322A.Channel_2 , JY5322A.Channel_3 ,
JY5322A.Channel_4 , JY5322A.Channel_5 , JY5322A.Channel_6 , JY5322A.Channel_7 ,
JY5322A.Channel_8 , JY5322A.Channel_9 , JY5322A.Channel_10 , JY5322A.Channel_11 ,
JY5322A.Channel_12 , JY5322A.Channel_13 , JY5322A.Channel_14 , JY5322A.Channel_15 ,
JY5322A.Channel_16 , JY5322A.Channel_17 , JY5322A.Channel_18 , JY5322A.Channel_19 ,
JY5322A.Channel_20 , JY5322A.Channel_21 , JY5322A.Channel_22 , JY5322A.Channel_23 ,
JY5322A.Channel_24 , JY5322A.Channel_25 , JY5322A.Channel_26 , JY5322A.Channel_27 ,
JY5322A.Channel_28 , JY5322A.Channel_29 , JY5322A.Channel_30 , JY5322A.Channel_31
}
AI Analog Trigger Source. More...
enum | JY5322A.AIAnalogTriggerEdge { JY5322A.Rising = JY5322AImport.JY5322A_AnalogTriggerEdge_RisingSlope , JY5322A.Falling = JY5322AImport.JY5322A_AnalogTriggerEdge_FallingSlope }
AI Analog Trigger Edge. More...
enum | JY5322A.AIAnalogWindowCondition { JY5322A.Entering = JY5322AImport.JY5322A_AnalogTriggerCondition_EnteringWindow , JY5322A.Leaving = JY5322AImport.JY5322A_AnaloglTriggerCondition_LeavingWindow }
AI Analog Window Trigger Condition. More...
enum | JY5322A.AIAnalogTriggerComparator { JY5322A.Edge , JY5322A.Hysteresis , JY5322A.Window }
AI Analog Trigger Comparator. More...
enum | JY5322A.AIAnalogComparatorLogic { JY5322A.Or = JY5322AImport.Or , JY5322A.And = JY5322AImport.And }
Multichannel composition logic. More...
enum JY5322A.AIDigitalTriggerSource {
JY5322A.PFI0 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_0 , JY5322A.PFI1 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_1 , JY5322A.PFI2 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_2 , JY5322A.PFI3 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_3 ,
JY5322A.PFI4 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_4 , JY5322A.PFI5 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_5 , JY5322A.PFI6 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_6 , JY5322A.PFI7 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_7 ,
JY5322A.PFI8 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_8 , JY5322A.PFI9 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_9 , JY5322A.PFI10 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_10 , JY5322A.PFI11 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_11 ,
JY5322A.PFI12 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_12 , JY5322A.PFI13 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_13 , JY5322A.PFI14 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_14 , JY5322A.PFI15 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_15 ,
JY5322A.PXI_Trig0 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_0 , JY5322A.PXI_Trig1 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_1 , JY5322A.PXI_Trig2 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_2 , JY5322A.PXI_Trig3 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_3 ,
JY5322A.PXI_Trig4 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_4 , JY5322A.PXI_Trig5 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_5 , JY5322A.PXI_Trig6 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_6 , JY5322A.PXI_Trig7 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_7 ,
JY5322A.Inter_AI_StartTrig = JY5322AImport.JY5322A_DigitalTriggerSource_Inter_AI_StartTrig , JY5322A.Inter_AI_ReferenceTrig = JY5322AImport.JY5322A_DigitalTriggerSource_Inter_AI_ReferenceTrig , JY5322A.Inter_CIO_0_StartTrig = JY5322AImport.JY5322A_DigitalTriggerSource_Inter_CIO_0_StartTrig , JY5322A.Inter_Counter_0_Output = JY5322AImport.JY5322A_DigitalTriggerSource_Inter_Counter_0_Output ,
JY5322A.Inter_DI_StartTrig = JY5322AImport.JY5322A_DigitalTriggerSource_Inter_DI_StartTrig , JY5322A.Inter_DI_ReferenceTrig = JY5322AImport.JY5322A_DigitalTriggerSource_Inter_DI_ReferenceTrig , JY5322A.Inter_DO_StartTrig = JY5322AImport.JY5322A_DigitalTriggerSource_Inter_DO_StartTrig
}
AI Digital Trigger Source. More...
enum | JY5322A.AIDigitalTriggerEdge { JY5322A.Rising = JY5322AImport.JY5322A_DigitalTriggerEdge_Rising , JY5322A.Falling = JY5322AImport.JY5322A_DigitalTriggerEdge_Falling }
AI Digital Trigger Edge. More...
enum | JY5322A.FileFormat { JY5322A.Bin }
Streaming file format. More...
enum | JY5322A.RecordMode { JY5322A.Finite , JY5322A.Infinite }
Two stream mode from enum Finite/Infinite. More...
enum | JY5322A.AIRawDataWidth { JY5322A.Auto = JY5322AImport.JY5322A_AI_RawDataWidth_Auto , JY5322A._16Bits = JY5322AImport.JY5322A_AI_RawDataWidth_16Bits , JY5322A._32Bits = JY5322AImport.JY5322A_AI_RawDataWidth_32Bits }
AI Raw Data Width. More...
enum | JY5322A.AISignalExportSource { JY5322A.StartTrig = JY5322AImport.JY5322A_AI_StartTrig , JY5322A.ReferenceTrig = JY5322AImport.JY5322A_AI_ReferenceTrig , JY5322A.SampleClock = JY5322AImport.JY5322A_AI_SampleClock , JY5322A.ChannelComparatorOut = JY5322AImport.JY5322A_AI_AnalogTrigger }
AI Signal Export Source. More...
enum JY5322A.SignalExportDestination {
JY5322A.PFI0 = JY5322AImport.JY5322A_PFI0_OUT , JY5322A.PFI1 = JY5322AImport.JY5322A_PFI1_OUT , JY5322A.PFI2 = JY5322AImport.JY5322A_PFI2_OUT , JY5322A.PFI3 = JY5322AImport.JY5322A_PFI3_OUT ,
JY5322A.PFI4 = JY5322AImport.JY5322A_PFI4_OUT , JY5322A.PFI5 = JY5322AImport.JY5322A_PFI5_OUT , JY5322A.PFI6 = JY5322AImport.JY5322A_PFI6_OUT , JY5322A.PFI7 = JY5322AImport.JY5322A_PFI7_OUT ,
JY5322A.PFI8 = JY5322AImport.JY5322A_PFI8_OUT , JY5322A.PFI9 = JY5322AImport.JY5322A_PFI9_OUT , JY5322A.PFI10 = JY5322AImport.JY5322A_PFI10_OUT , JY5322A.PFI11 = JY5322AImport.JY5322A_PFI11_OUT ,
JY5322A.PFI12 = JY5322AImport.JY5322A_PFI12_OUT , JY5322A.PFI13 = JY5322AImport.JY5322A_PFI13_OUT , JY5322A.PFI14 = JY5322AImport.JY5322A_PFI14_OUT , JY5322A.PFI15 = JY5322AImport.JY5322A_PFI15_OUT ,
JY5322A.PXI_Trig0 = JY5322AImport.JY5322A_PXITrig0_OUT , JY5322A.PXI_Trig1 = JY5322AImport.JY5322A_PXITrig1_OUT , JY5322A.PXI_Trig2 = JY5322AImport.JY5322A_PXITrig2_OUT , JY5322A.PXI_Trig3 = JY5322AImport.JY5322A_PXITrig3_OUT ,
JY5322A.PXI_Trig4 = JY5322AImport.JY5322A_PXITrig4_OUT , JY5322A.PXI_Trig5 = JY5322AImport.JY5322A_PXITrig5_OUT , JY5322A.PXI_Trig6 = JY5322AImport.JY5322A_PXITrig6_OUT , JY5322A.PXI_Trig7 = JY5322AImport.JY5322A_PXITrig7_OUT ,
JY5322A.None = JY5322AImport.JY5322A_None
}
Output DestinationTerminal. More...
enum | JY5322A.SignalExportOutputType { JY5322A.Logic = 0 , JY5322A.OCGate = 1 }
Signal Export Output Type. More...


5322A C# API Manual: JY5322A.JY5322AAITask Class Reference

  • Class List
  • Class Index
  • Class Members
  • JY5322A
  • JY5322AAITask
Public Member Functions | Properties | List of all members
JY5322A.JY5322AAITask Class Referencesealed

JY5322AA Analog Input Task. More...

Public Member Functions

JY5322AAITask (int slotNumber)
Constructor. Used to create an AI task by a slot number.
JY5322AAITask (string boardName)
Constructor. Used to create an AI task by a board name.
void | AddChannel (int chnId, double rangeLow=-10, double rangeHigh=10, AIBandWidth bandWidth=AIBandWidth._220KHz)
Add one channel.
void | AddChannel (int[] chnsId, double rangeLow=-10, double rangeHigh=10, AIBandWidth bandWidth=AIBandWidth._220KHz)
Add a group of channels.
void | AddChannel (int[] chnsId, double[] rangeLow, double[] rangeHigh, AIBandWidth[] bandWidth)
Add a group of channels, each channel range can be set differently.
void | RemoveChannel (int chnId)
Delete the channel with the specified channel number. chnId=- 1, all channels will be deleted.
AISamplingInfo GetSamplingInfo ()
GetSamplingInfo,获取所有已添加通道的群延迟，相对于当前采样率的sample个数
void | ReadData (IntPtr buf, int samplesPerChannel, int timeout=10000)
Read one or multi-channel data by columns and store it in a data buffer. The buffer is pointed by C# data type IntPtr.
void | ReadData (ref double[,] buf, int samplesPerChannel, int timeout=10000)
Read the multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data.
void | ReadData (ref double[,] buf, int timeout=10000)
Read the multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data.
void | ReadData (ref double[] buf, int samplesPerChannel, int timeout=10000)
Read the one channel data and store it in a data buffer.
void | ReadData (ref double[] buf, int timeout=10000)
Read the one channel data and store it in a data buffer.
void | ReadRawData (IntPtr buf, int samplesPerChannel, int timeout=10000)
Read one or multi-channel raw data by columns and store it in a data buffer. The buffer is pointed by C# data type IntPtr.
void | ReadRawData (ref short[,] buf, int samplesPerChannel, int timeout=10000)
Read the multi-channel raw data by columns and store it in a data buffer,Each channel is represented by one column of data.
void | ReadRawData (ref short[,] buf, int timeout=10000)
Read the multi-channel raw data by columns and store it in a data buffer,Each channel is represented by one column of data.
void | ReadRawData (ref short[] buf, int samplesPerChannel, int timeout=10000)
Read the one channel raw data and store it in a data buffer.
void | ReadRawData (ref short[] buf, int timeout=10000)
Read the one channel raw data and store it in a data buffer.
void | ReadRawData (ref int[,] buf, int samplesPerChannel, int timeout=10000)
Read the multi-channel raw data by columns and store it in a data buffer,Each channel is represented by one column of data.
void | ReadRawData (ref int[,] buf, int timeout=10000)
Read the multi-channel raw data by columns and store it in a data buffer,Each channel is represented by one column of data.
void | ReadRawData (ref int[] buf, int samplesPerChannel, int timeout=10000)
Read the one channel raw data and store it in a data buffer.
void | ReadRawData (ref int[] buf, int timeout=10000)
Read the one channel raw data and store it in a data buffer.
void | ReadSinglePoint (ref double readValue, int channel)
Read one sample for specified channel in register. Available when Mode is AIMode.Single.
void | ReadSinglePoint (ref double[] readValues)
Read one sample for all channels in register . Available when Mode is AIMode.Single.
void | ReadRawSinglePoint (ref int[] readValues)
Read one raw sample for all channels in register . Available when Mode is AIMode.Single.
void | ReadRawSinglePoint (ref int readValue, int channel)
Read one raw sample for all channels in register . Available when Mode is AIMode.Single.
void | GetRecordPreviewData (ref double[,] buf, int samplesPerChannel, int timeout=1000)
Preview multi-channel data when streaming is in progress. Each column represents one channel.
void | GetRecordPreviewData (ref double[,] buf, int timeout=1000)
Preview multi-channel data when streaming is in progress. Each column represents one channel.
void | GetRecordPreviewData (ref double[] buf, int samplesPerChannel, int timeout=1000)
Preview one channel data when streaming is in progress.
void | GetRecordPreviewData (ref double[] buf, int timeout=1000)
Preview one channel data when streaming is in progress.
void | GetRecordStatus (out double recordedLength, out bool recordDone)
Get the streaming status.
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.
void | Start ()
Start AITask.
ScalingCoefficients[] GetScalingCoefficients ()
在Commit()或Start()之后调用，获取当前任务已添加通道的电压换算因子，用于将Raw数据转换为电压值。
void | SendSoftwareTrigger ()
Generate a software trigger signal generate a software trigger signal.
void | Stop ()
Stop AI Task.

Properties

JY5322ADevice | Device [get]
Device Handle.
List< AIChannel > | Channels [get, set]
List of AI channels,support 32 or 16 Different.
AITerminalBoard | TerminalBoard [get, set]
AI Terminal Board.
AIMode | Mode [get, set]
AI acquisition mode，support Finite/Continuous/Record.
double | SampleRate [get, set]
Sample rate per channel. Maximum sample rate is 1M for 5322 5322，Maximum sample rate is 200K for 5323 5314 The defalut sample rate = 100k You can read this property to obtain the sample rate that will actually take effect in the current configuration.
int | SamplesToAcquire [get, set]
Number of samples to be read per channel. default: 1000. Only valid when Mode is AIMode.Finite.
int | BufLenInSamples [get]
Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.
ulong | AvailableSamples [get]
Number of samples per channel that can be read in the buffer.
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer (per channel).
AISampleClock | SampleClock [get, set]
AI Sample Clock Configuration.
AITrigger | Trigger [get, set]
时钟沿。仅在外部时钟时有效。
AIRecord | Record [get]
Data streaming Configuration.
AISignalExport | SignalExport [get, set]
Export AI Signal Configuration.
AIAdvanced | Advanced [get, set]
AI Advanced Configuration.

Detailed Description

JY5322AA Analog Input Task.

Constructor & Destructor Documentation

◆ JY5322AAITask() [1/2]

JY5322A.JY5322AAITask.JY5322AAITask ( int slotNumber )

Constructor. Used to create an AI task by a slot number.

Parameters
slotNumber Card slot number.

◆ JY5322AAITask() [2/2]

JY5322A.JY5322AAITask.JY5322AAITask ( string boardName )

Constructor. Used to create an AI task by a board name.

Parameters
boardName Board name(device alias), set by device manager

Member Function Documentation

◆ AddChannel() [1/3]

void JY5322A.JY5322AAITask.AddChannel | ( | int | chnId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10,
 |  | AIBandWidth | bandWidth = AIBandWidth::_220KHz )

Add one channel.

Parameters
chnId | channel's physical number ，chnId=-1, add all channels,if 5322 5323 channel is 0 - 31. if 5322 5324 channel is 0 -15
rangeLow | lower range limit for the channel，-60V,-30V,-10V,-5V,-2V，-1V, -0.5V, -0.25V,default -10
rangeHigh | higher range limit for the channel,60V,30V,10V,5V,2V，1V, 0.5V, 0.25V,default 10
bandWidth | AI Bandwidth ,default 25KHz

◆ AddChannel() [2/3]

void JY5322A.JY5322AAITask.AddChannel | ( | int[] | chnsId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10,
 |  | AIBandWidth | bandWidth = AIBandWidth::_220KHz )

Add a group of channels.

Parameters
chnsId | a group of channel physical numbers,if 5322 5323 channel is 0 - 31. if 5322 5324 channel is 0 -15
rangeLow | lower range limit for the channel，-60V,-30V,-10V,-5V,-2V，-1V, -0.5V, -0.25V,default -10
rangeHigh | higher range limit for the channel,60V,30V,10V,5V,2V，1V, 0.5V, 0.25V,default 10
bandWidth | AI Bandwidth ,default 25KHz

◆ AddChannel() [3/3]

void JY5322A.JY5322AAITask.AddChannel | ( | int[] | chnsId,
 |  | double[] | rangeLow,
 |  | double[] | rangeHigh,
 |  | AIBandWidth[] | bandWidth )

Add a group of channels, each channel range can be set differently.

Parameters
chnsId | a group of channel physical numbers,,if 5322 5323 channel is 0 - 31. if 5322 5324 channel is 0 -15
rangeLow | lower range limit for the channel，-60V,-30V,-10V,-5V,-2V，-1V, -0.5V, -0.25V,default -10
rangeHigh | higher range limit for the channel,60V,30V,10V,5V,2V，1V, 0.5V, 0.25V,default 10
bandWidth | AI Bandwidth ,default 25KHz

◆ GetRecordPreviewData() [1/4]

void JY5322A.JY5322AAITask.GetRecordPreviewData | ( | ref double | buf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout = 1000 )

Preview multi-channel data when streaming is in progress. Each column represents one channel.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ GetRecordPreviewData() [2/4]

void JY5322A.JY5322AAITask.GetRecordPreviewData | ( | ref double | buf[,],
 |  | int | timeout = 1000 )

Preview multi-channel data when streaming is in progress. Each column represents one channel.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms

◆ GetRecordPreviewData() [3/4]

void JY5322A.JY5322AAITask.GetRecordPreviewData | ( | ref double[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 1000 )

Preview one channel data when streaming is in progress.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ GetRecordPreviewData() [4/4]

void JY5322A.JY5322AAITask.GetRecordPreviewData | ( | ref double[] | buf,
 |  | int | timeout = 1000 )

Preview one channel data when streaming is in progress.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms

◆ GetRecordStatus()

void JY5322A.JY5322AAITask.GetRecordStatus | ( | out double | recordedLength,
 |  | out bool | recordDone )

Get the streaming status.

Parameters
recordedLength | Length of the streamed, unit s
recordDone | recordDone = false :streaming is not over.recordDone = true :streaming is over

◆ GetSamplingInfo()

AISamplingInfo JY5322A.JY5322AAITask.GetSamplingInfo ( )

GetSamplingInfo,获取所有已添加通道的群延迟，相对于当前采样率的sample个数

◆ GetScalingCoefficients()

ScalingCoefficients[] JY5322A.JY5322AAITask.GetScalingCoefficients ( )

在Commit()或Start()之后调用，获取当前任务已添加通道的电压换算因子，用于将Raw数据转换为电压值。

Returns

◆ ReadData() [1/5]

void JY5322A.JY5322AAITask.ReadData | ( | IntPtr | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Read one or multi-channel data by columns and store it in a data buffer. The buffer is pointed by C# data type IntPtr.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish

◆ ReadData() [2/5]

void JY5322A.JY5322AAITask.ReadData | ( | ref double | buf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Read the multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish

◆ ReadData() [3/5]

void JY5322A.JY5322AAITask.ReadData | ( | ref double | buf[,],
 |  | int | timeout = 10000 )

Read the multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish

◆ ReadData() [4/5]

void JY5322A.JY5322AAITask.ReadData | ( | ref double[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Read the one channel data and store it in a data buffer.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ ReadData() [5/5]

void JY5322A.JY5322AAITask.ReadData | ( | ref double[] | buf,
 |  | int | timeout = 10000 )

Read the one channel data and store it in a data buffer.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms

◆ ReadRawData() [1/9]

void JY5322A.JY5322AAITask.ReadRawData | ( | IntPtr | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Read one or multi-channel raw data by columns and store it in a data buffer. The buffer is pointed by C# data type IntPtr.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ ReadRawData() [2/9]

void JY5322A.JY5322AAITask.ReadRawData | ( | ref int | buf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Read the multi-channel raw data by columns and store it in a data buffer,Each channel is represented by one column of data.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ ReadRawData() [3/9]

void JY5322A.JY5322AAITask.ReadRawData | ( | ref int | buf[,],
 |  | int | timeout = 10000 )

Read the multi-channel raw data by columns and store it in a data buffer,Each channel is represented by one column of data.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms

◆ ReadRawData() [4/9]

void JY5322A.JY5322AAITask.ReadRawData | ( | ref int[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Read the one channel raw data and store it in a data buffer.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ ReadRawData() [5/9]

void JY5322A.JY5322AAITask.ReadRawData | ( | ref int[] | buf,
 |  | int | timeout = 10000 )

Read the one channel raw data and store it in a data buffer.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms

◆ ReadRawData() [6/9]

void JY5322A.JY5322AAITask.ReadRawData | ( | ref short | buf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Read the multi-channel raw data by columns and store it in a data buffer,Each channel is represented by one column of data.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ ReadRawData() [7/9]

void JY5322A.JY5322AAITask.ReadRawData | ( | ref short | buf[,],
 |  | int | timeout = 10000 )

Read the multi-channel raw data by columns and store it in a data buffer,Each channel is represented by one column of data.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms

◆ ReadRawData() [8/9]

void JY5322A.JY5322AAITask.ReadRawData | ( | ref short[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Read the one channel raw data and store it in a data buffer.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ ReadRawData() [9/9]

void JY5322A.JY5322AAITask.ReadRawData | ( | ref short[] | buf,
 |  | int | timeout = 10000 )

Read the one channel raw data and store it in a data buffer.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms

◆ ReadRawSinglePoint() [1/2]

void JY5322A.JY5322AAITask.ReadRawSinglePoint | ( | ref int | readValue,
 |  | int | channel )

Read one raw sample for all channels in register . Available when Mode is AIMode.Single.

Parameters
readValue | Values read
channel | Specified channel numbers.
Exceptions
JYDriverException

◆ ReadRawSinglePoint() [2/2]

void JY5322A.JY5322AAITask.ReadRawSinglePoint ( ref int[] readValues )

Read one raw sample for all channels in register . Available when Mode is AIMode.Single.

Parameters
readValues Values read. Array length >= Channels.Count.

◆ ReadSinglePoint() [1/2]

void JY5322A.JY5322AAITask.ReadSinglePoint | ( | ref double | readValue,
 |  | int | channel )

Read one sample for specified channel in register. Available when Mode is AIMode.Single.

Parameters
readValue | value read
channel | Specified channel numbers.

◆ ReadSinglePoint() [2/2]

void JY5322A.JY5322AAITask.ReadSinglePoint ( ref double[] readValues )

Read one sample for all channels in register . Available when Mode is AIMode.Single.

Parameters
readValues Values read. Array length >= Channels.Count.

◆ RemoveChannel()

void JY5322A.JY5322AAITask.RemoveChannel ( int chnId )

Delete the channel with the specified channel number. chnId=- 1, all channels will be deleted.

Parameters
chnId Channel number of the channel to be deleted

◆ SendSoftwareTrigger()

void JY5322A.JY5322AAITask.SendSoftwareTrigger ( )

Generate a software trigger signal generate a software trigger signal.

◆ Start()

void JY5322A.JY5322AAITask.Start ( )

Start AITask.

◆ Stop()

void JY5322A.JY5322AAITask.Stop ( )

Stop AI Task.

◆ WaitUntilDone()

bool JY5322A.JY5322AAITask.WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate
Returns
True: task end, false: timeout

Property Documentation

◆ Advanced

AIAdvanced JY5322A.JY5322AAITask.Advanced
getset

AI Advanced Configuration.

◆ AvailableSamples

ulong JY5322A.JY5322AAITask.AvailableSamples
get

Number of samples per channel that can be read in the buffer.

◆ BufLenInSamples

int JY5322A.JY5322AAITask.BufLenInSamples
get

Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.

◆ Channels

List<AIChannel> JY5322A.JY5322AAITask.Channels
getset

List of AI channels,support 32 or 16 Different.

◆ Device

JY5322ADevice JY5322A.JY5322AAITask.Device
get

Device Handle.

◆ Mode

AIMode JY5322A.JY5322AAITask.Mode
getset

AI acquisition mode，support Finite/Continuous/Record.

◆ Record

AIRecord JY5322A.JY5322AAITask.Record
get

Data streaming Configuration.

◆ SampleClock

AISampleClock JY5322A.JY5322AAITask.SampleClock
getset

AI Sample Clock Configuration.

◆ SampleRate

double JY5322A.JY5322AAITask.SampleRate
getset

Sample rate per channel. Maximum sample rate is 1M for 5322 5322，Maximum sample rate is 200K for 5323 5314 The defalut sample rate = 100k You can read this property to obtain the sample rate that will actually take effect in the current configuration.

◆ SamplesToAcquire

int JY5322A.JY5322AAITask.SamplesToAcquire
getset

Number of samples to be read per channel. default: 1000. Only valid when Mode is AIMode.Finite.

◆ SignalExport

AISignalExport JY5322A.JY5322AAITask.SignalExport
getset

Export AI Signal Configuration.

◆ TerminalBoard

AITerminalBoard JY5322A.JY5322AAITask.TerminalBoard
getset

AI Terminal Board.

◆ TransferedSamples

ulong JY5322A.JY5322AAITask.TransferedSamples
get

The number of samples that have been transfered from the local buffer (per channel).

◆ Trigger

AITrigger JY5322A.JY5322AAITask.Trigger
getset

时钟沿。仅在外部时钟时有效。

public AIClockEdge ClockEdge { get; set; }

AI Trigger Configuration

The documentation for this class was generated from the following file:
  • JY5322AAITask.cs


5322A C# API Manual: JY5322A.AIChannel Class Reference

  • Class Index
  • Class Members
  • JY5322A
  • AIChannel
Public Member Functions | Properties | List of all members
JY5322A.AIChannel Class Referencesealed

AI Channel parameter class. More...

Public Member Functions

AIChannel (int channelId, double rangeLow, double rangeHigh, AIBandWidth bandWidth)
Constructor to create an AIChnParam task object.

Properties

int | ChannelID [get]
AI channel ID.
double | RangeLow [get, set]
Low range limit an AI channel，-10V,-5V,-2.5V，-1V, -0.5V, -0.25V.
double | RangeHigh [get, set]
High range limit an AI channel，10V,5V,2.5V，1V, 0.5V, 0.25V.
AIBandWidth | BandWidth [get, set]
AI BandWidth,default 50KHz.

Detailed Description

AI Channel parameter class.

Constructor & Destructor Documentation

◆ AIChannel()

JY5322A.AIChannel.AIChannel | ( | int | channelId,
 |  | double | rangeLow,
 |  | double | rangeHigh,
 |  | AIBandWidth | bandWidth )

Constructor to create an AIChnParam task object.

Parameters
channelId | AI channel ID.
rangeLow | Low range limit an AI channel.
rangeHigh | High range limit an AI channel.
bandWidth | AI BandWidth.

Property Documentation

◆ BandWidth

AIBandWidth JY5322A.AIChannel.BandWidth
getset

AI BandWidth,default 50KHz.

◆ ChannelID

int JY5322A.AIChannel.ChannelID
get

AI channel ID.

◆ RangeHigh

double JY5322A.AIChannel.RangeHigh
getset

High range limit an AI channel，10V,5V,2.5V，1V, 0.5V, 0.25V.

◆ RangeLow

double JY5322A.AIChannel.RangeLow
getset

Low range limit an AI channel，-10V,-5V,-2.5V，-1V, -0.5V, -0.25V.

The documentation for this class was generated from the following file:
  • JY5322AAITask.cs


5322A C# API Manual: JY5322A.ScalingCoefficients Class Reference

  • ScalingCoefficients
Public Member Functions | Properties | List of all members
JY5322A.ScalingCoefficients Class Reference

将原始Raw数据转换为工程单位（电压值）的换算因子。 More...

Public Member Functions

ScalingCoefficients ()
构造函数。
ScalingCoefficients (double offset, double gain)
构造函数。

Properties

double | Offset [get, set]
0阶系数
double | Gain [get, set]
1阶系数
double | Reserved1 [get, set]
保留
double | Reserved2 [get, set]
保留

Detailed Description

将原始Raw数据转换为工程单位（电压值）的换算因子。

Constructor & Destructor Documentation

◆ ScalingCoefficients() [1/2]

JY5322A.ScalingCoefficients.ScalingCoefficients ( )

构造函数。

◆ ScalingCoefficients() [2/2]

JY5322A.ScalingCoefficients.ScalingCoefficients | ( | double | offset,
 |  | double | gain )

构造函数。

Parameters
offset
gain

Property Documentation

◆ Gain

double JY5322A.ScalingCoefficients.Gain
getset

1阶系数

◆ Offset

double JY5322A.ScalingCoefficients.Offset
getset

0阶系数

◆ Reserved1

double JY5322A.ScalingCoefficients.Reserved1
getset

保留

◆ Reserved2

double JY5322A.ScalingCoefficients.Reserved2
getset

保留

The documentation for this class was generated from the following file:
  • JY5322AAITask.cs


5322A C# API Manual: JY5322A.AISampleClock Class Reference

  • AISampleClock
Properties | List of all members
JY5322A.AISampleClock Class Reference

Sample clock configuration class. More...

Properties

AISampleClockSource | Source [get, set]
Clock Source. enum Internal/External,The default value is AISampleClockSource.Internal.
AIExternalSampleClock | External [get, set]
External Sample Clock， Valid when Source is AISampleClockSource.External.

Detailed Description

Sample clock configuration class.

Property Documentation

◆ External

AIExternalSampleClock JY5322A.AISampleClock.External
getset

External Sample Clock， Valid when Source is AISampleClockSource.External.

◆ Source

AISampleClockSource JY5322A.AISampleClock.Source
getset

Clock Source. enum Internal/External,The default value is AISampleClockSource.Internal.

The documentation for this class was generated from the following file:
  • JY5322AAITask.cs


5322A C# API Manual: JY5322A.AIExternalSampleClock Class Reference

  • AIExternalSampleClock
Properties | List of all members
JY5322A.AIExternalSampleClock Class Reference

External Sample Clock Configuration Class. More...

Properties

ClockTerminal | Terminal [get, set]
External Sample Clock Input Terminal.
double | ExpectedRate [get, set]
Expected External Sample Clock Rate.

Detailed Description

External Sample Clock Configuration Class.

Property Documentation

◆ ExpectedRate

double JY5322A.AIExternalSampleClock.ExpectedRate
getset

Expected External Sample Clock Rate.

◆ Terminal

ClockTerminal JY5322A.AIExternalSampleClock.Terminal
getset

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • JY5322AAITask.cs


5322A C# API Manual: JY5322A.AITrigger Class Reference

  • AITrigger
Properties | List of all members
JY5322A.AITrigger Class Referencesealed

AI Trigger class. More...

Properties

AITriggerType | Type [get, set]
AI Trigger Type,enum Analog/Digital/Immediate/Soft. The default value is AITriggerType.Immediate.
AITriggerMode | Mode [get, set]
AI Trigger Mode. enum Start/Reference. The default value is AITriggerMode.Start.
AIDigitalTrigger | Digital [get, set]
Digital Trigger Congfiguration. Valid when Type is AITriggerType.Digital.
AIAnalogTrigger | Analog [get, set]
AI Analog Trigger. Valid when Type is AITriggerType.Analog.
AIAnalogMultichannelComparator | Multichannel [get, set]
AI Analog Trigger. Valid when Type is AITriggerType.MultichannelAnalog.
int | ReTriggerCount [get, set]
Number of repeat triggers. When 0 or 1 only trigger once, When -1 continuous retrigger until stop.
uint | PreTriggerSamples [get, set]
AI pretrigger samples, must be less than or equal to JY5322AAITask.SamplesToAcquire. Valid when Mode is AITriggerMode.Reference.

Detailed Description

AI Trigger class.

Property Documentation

◆ Analog

AIAnalogTrigger JY5322A.AITrigger.Analog
getset

AI Analog Trigger. Valid when Type is AITriggerType.Analog.

◆ Digital

AIDigitalTrigger JY5322A.AITrigger.Digital
getset

Digital Trigger Congfiguration. Valid when Type is AITriggerType.Digital.

◆ Mode

AITriggerMode JY5322A.AITrigger.Mode
getset

AI Trigger Mode. enum Start/Reference. The default value is AITriggerMode.Start.

◆ Multichannel

AIAnalogMultichannelComparator JY5322A.AITrigger.Multichannel
getset

AI Analog Trigger. Valid when Type is AITriggerType.MultichannelAnalog.

◆ PreTriggerSamples

uint JY5322A.AITrigger.PreTriggerSamples
getset

AI pretrigger samples, must be less than or equal to JY5322AAITask.SamplesToAcquire. Valid when Mode is AITriggerMode.Reference.

◆ ReTriggerCount

int JY5322A.AITrigger.ReTriggerCount
getset

Number of repeat triggers. When 0 or 1 only trigger once, When -1 continuous retrigger until stop.

◆ Type

AITriggerType JY5322A.AITrigger.Type
getset

AI Trigger Type,enum Analog/Digital/Immediate/Soft. The default value is AITriggerType.Immediate.

The documentation for this class was generated from the following file:
  • JY5322AAITask.cs


5322A C# API Manual: JY5322A.AIAnalogHysteresisComparator Class Reference

  • AIAnalogHysteresisComparator
Properties | List of all members
JY5322A.AIAnalogHysteresisComparator Class Reference

AI Analog Hysteresis Comparator. More...

Properties

AIAnalogTriggerEdge | Slope [get, set]
AI Analog Trigger Edge.
double | HighThreshold [get, set]
High Threshold.
double | LowThreshold [get, set]
Low Threshold.

Detailed Description

AI Analog Hysteresis Comparator.

Property Documentation

◆ HighThreshold

double JY5322A.AIAnalogHysteresisComparator.HighThreshold
getset

High Threshold.

◆ LowThreshold

double JY5322A.AIAnalogHysteresisComparator.LowThreshold
getset

Low Threshold.

◆ Slope

AIAnalogTriggerEdge JY5322A.AIAnalogHysteresisComparator.Slope
getset

AI Analog Trigger Edge.

The documentation for this class was generated from the following file:
  • JY5322AAITask.cs


5322A C# API Manual: JY5322A.AIAnalogWindowComparator Class Reference

  • AIAnalogWindowComparator
Properties | List of all members
JY5322A.AIAnalogWindowComparator Class Reference

AI Analog Window Comparator. More...

Properties

AIAnalogWindowCondition | Condition [get, set]
AI Analog Window Condition.
double | HighThreshold [get, set]
High Threshold.
double | LowThreshold [get, set]
Low Threshold.

Detailed Description

AI Analog Window Comparator.

Property Documentation

◆ Condition

AIAnalogWindowCondition JY5322A.AIAnalogWindowComparator.Condition
getset

AI Analog Window Condition.

◆ HighThreshold

double JY5322A.AIAnalogWindowComparator.HighThreshold
getset

High Threshold.

◆ LowThreshold

double JY5322A.AIAnalogWindowComparator.LowThreshold
getset

Low Threshold.

The documentation for this class was generated from the following file:
  • JY5322AAITask.cs


5322A C# API Manual: JY5322A.AIAnalogEdgeComparator Class Reference

  • AIAnalogEdgeComparator
Properties | List of all members
JY5322A.AIAnalogEdgeComparator Class Reference

AI Analog Edge Comparator. More...

Properties

AIAnalogTriggerEdge | Slope [get, set]
AI Analog Trigger Edge.
double | Threshold [get, set]
Threshold.

Detailed Description

AI Analog Edge Comparator.

Property Documentation

◆ Slope

AIAnalogTriggerEdge JY5322A.AIAnalogEdgeComparator.Slope
getset

AI Analog Trigger Edge.

◆ Threshold

double JY5322A.AIAnalogEdgeComparator.Threshold
getset

Threshold.

The documentation for this class was generated from the following file:
  • JY5322AAITask.cs


5322A C# API Manual: JY5322A.AIAnalogTrigger Class Reference

  • AIAnalogTrigger
Public Member Functions | Properties | List of all members
JY5322A.AIAnalogTrigger Class Referencesealed

AI Analog Trigger. More...

Public Member Functions

AIAnalogTrigger ()
Default simulation trigger parameters: Trigger source - external trigger channel Trigger condition – above high threshold Threshold value – -0.1v.

Properties

AIAnalogTriggerSource | Source [get, set]
Analog Trigger source.
AIAnalogTriggerComparator | Comparator [get, set]
AI Analog Trigger Comparator.
AIAnalogEdgeComparator | Edge [get, set]
AI Analog Edge Comparator.
AIAnalogHysteresisComparator | Hysteresis [get, set]
AI Analog Hysteresis Comparatorr.
AIAnalogWindowComparator | Window [get, set]
AI Analog Window Comparatorr.

Detailed Description

AI Analog Trigger.

Constructor & Destructor Documentation

◆ AIAnalogTrigger()

JY5322A.AIAnalogTrigger.AIAnalogTrigger ( )

Default simulation trigger parameters: Trigger source - external trigger channel Trigger condition – above high threshold Threshold value – -0.1v.

Property Documentation

◆ Comparator

AIAnalogTriggerComparator JY5322A.AIAnalogTrigger.Comparator
getset

AI Analog Trigger Comparator.

◆ Edge

AIAnalogEdgeComparator JY5322A.AIAnalogTrigger.Edge
getset

AI Analog Edge Comparator.

◆ Hysteresis

AIAnalogHysteresisComparator JY5322A.AIAnalogTrigger.Hysteresis
getset

AI Analog Hysteresis Comparatorr.

◆ Source

AIAnalogTriggerSource JY5322A.AIAnalogTrigger.Source
getset

Analog Trigger source.

◆ Window

AIAnalogWindowComparator JY5322A.AIAnalogTrigger.Window
getset

AI Analog Window Comparatorr.

The documentation for this class was generated from the following file:
  • JY5322AAITask.cs


5322A C# API Manual: JY5322A.AIAnalogMultichannelComparator Class Reference

  • AIAnalogMultichannelComparator
Public Member Functions | Properties | List of all members
JY5322A.AIAnalogMultichannelComparator Class Referencesealed

AI Analog Multichannel Trigger/Comparator. More...

Public Member Functions

AIAnalogMultichannelComparator ()
Default simulation trigger parameters: Trigger source - external trigger channel Trigger condition – above high threshold Threshold value – -0.1v.

Properties

AIAnalogComparatorLogic | Logic [get, set]
Multichannel composition logic, and / or. defalut or.
AIAnalogTriggerComparator | Comparator [get, set]
AI Analog Trigger Comparator.
AIAnalogMultichannelHysteresisComparator | Hysteresis [get, set]
Analog Trigger Config.
AIAnalogMultichannelEdgeComparator | Edge [get, set]
Analog Trigger Config.
AIAnalogMultichannelWindowComparator | Window [get, set]
Analog Trigger Config.

Detailed Description

AI Analog Multichannel Trigger/Comparator.

Constructor & Destructor Documentation

◆ AIAnalogMultichannelComparator()

JY5322A.AIAnalogMultichannelComparator.AIAnalogMultichannelComparator ( )

Default simulation trigger parameters: Trigger source - external trigger channel Trigger condition – above high threshold Threshold value – -0.1v.

Property Documentation

◆ Comparator

AIAnalogTriggerComparator JY5322A.AIAnalogMultichannelComparator.Comparator
getset

AI Analog Trigger Comparator.

◆ Edge

AIAnalogMultichannelEdgeComparator JY5322A.AIAnalogMultichannelComparator.Edge
getset

Analog Trigger Config.

◆ Hysteresis

AIAnalogMultichannelHysteresisComparator JY5322A.AIAnalogMultichannelComparator.Hysteresis
getset

Analog Trigger Config.

◆ Logic

AIAnalogComparatorLogic JY5322A.AIAnalogMultichannelComparator.Logic
getset

Multichannel composition logic, and / or. defalut or.

◆ Window

AIAnalogMultichannelWindowComparator JY5322A.AIAnalogMultichannelComparator.Window
getset

Analog Trigger Config.

The documentation for this class was generated from the following file:
  • JY5322AAITask.cs


5322A C# API Manual: JY5322A.AIAnalogMultichannelHysteresisComparator Class Reference

  • AIAnalogMultichannelHysteresisComparator
Public Member Functions | Properties | List of all members
JY5322A.AIAnalogMultichannelHysteresisComparator Class Reference

AI Analog Multichannel Hysteresis Comparator. More...

Public Member Functions

void | Add (AIAnalogTriggerSource source, AIAnalogTriggerEdge slope, double highThreshold, double lowThreshold)
Add source.
void | Clear ()
Clear sources.
AIAnalogMultichannelHysteresisComparator ()

Properties

List< AIAnalogMultichannelHysteresisComparatorSource > Sources [get, set]
Sources of AI Analog Multichannel Hysteresis Comparator.

Detailed Description

AI Analog Multichannel Hysteresis Comparator.

Constructor & Destructor Documentation

◆ AIAnalogMultichannelHysteresisComparator()

JY5322A.AIAnalogMultichannelHysteresisComparator.AIAnalogMultichannelHysteresisComparator ( )

Member Function Documentation

◆ Add()

void JY5322A.AIAnalogMultichannelHysteresisComparator.Add | ( | AIAnalogTriggerSource | source,
 |  | AIAnalogTriggerEdge | slope,
 |  | double | highThreshold,
 |  | double | lowThreshold )

Add source.

Parameters
source | Analog Trigger source
slope | AI Analog Trigger Edge
highThreshold | High Threshold
lowThreshold | Low Threshold

◆ Clear()

void JY5322A.AIAnalogMultichannelHysteresisComparator.Clear ( )

Clear sources.

Property Documentation

◆ Sources

List<AIAnalogMultichannelHysteresisComparatorSource> JY5322A.AIAnalogMultichannelHysteresisComparator.Sources
getset

Sources of AI Analog Multichannel Hysteresis Comparator.

The documentation for this class was generated from the following file:
  • JY5322AAITask.cs


5322A C# API Manual: JY5322A.AIAnalogMultichannelHysteresisComparatorSource Class Reference

  • AIAnalogMultichannelHysteresisComparatorSource
Public Member Functions | Properties | List of all members
JY5322A.AIAnalogMultichannelHysteresisComparatorSource Class Reference

AI Analog Multichannel Hysteresis Comparator Source. More...

Public Member Functions

AIAnalogMultichannelHysteresisComparatorSource ()
AI Analog Multichannel Hysteresis Comparator Source.
AIAnalogMultichannelHysteresisComparatorSource (AIAnalogTriggerSource source, AIAnalogTriggerEdge slope, double highThreshold, double lowThreshold)
AI Analog Multichannel Hysteresis Comparator Source.

Properties

AIAnalogTriggerSource | Source [get, set]
Analog Trigger source.
AIAnalogTriggerEdge | Slope [get, set]
AI Analog Trigger Edge.
double | HighThreshold [get, set]
High Threshold.
double | LowThreshold [get, set]
Low Threshold.

Detailed Description

AI Analog Multichannel Hysteresis Comparator Source.

Constructor & Destructor Documentation

◆ AIAnalogMultichannelHysteresisComparatorSource() [1/2]

JY5322A.AIAnalogMultichannelHysteresisComparatorSource.AIAnalogMultichannelHysteresisComparatorSource ( )

AI Analog Multichannel Hysteresis Comparator Source.

◆ AIAnalogMultichannelHysteresisComparatorSource() [2/2]

JY5322A.AIAnalogMultichannelHysteresisComparatorSource.AIAnalogMultichannelHysteresisComparatorSource | ( | AIAnalogTriggerSource | source,
 |  | AIAnalogTriggerEdge | slope,
 |  | double | highThreshold,
 |  | double | lowThreshold )

AI Analog Multichannel Hysteresis Comparator Source.

Property Documentation

◆ HighThreshold

double JY5322A.AIAnalogMultichannelHysteresisComparatorSource.HighThreshold
getset

High Threshold.

◆ LowThreshold

double JY5322A.AIAnalogMultichannelHysteresisComparatorSource.LowThreshold
getset

Low Threshold.

◆ Slope

AIAnalogTriggerEdge JY5322A.AIAnalogMultichannelHysteresisComparatorSource.Slope
getset

AI Analog Trigger Edge.

◆ Source

AIAnalogTriggerSource JY5322A.AIAnalogMultichannelHysteresisComparatorSource.Source
getset

Analog Trigger source.

The documentation for this class was generated from the following file:
  • JY5322AAITask.cs


5322A C# API Manual: JY5322A.AIAnalogMultichannelWindowComparator Class Reference

  • AIAnalogMultichannelWindowComparator
Public Member Functions | Properties | List of all members
JY5322A.AIAnalogMultichannelWindowComparator Class Reference

AI Analog Multichannel Window Comparator. More...

Public Member Functions

void | Add (AIAnalogTriggerSource source, AIAnalogWindowCondition condition, double highThreshold, double lowThreshold)
Add source.
void | Clear ()
Clear sources.
AIAnalogMultichannelWindowComparator ()

Properties

List< AIAnalogMultichannelWindowComparatorSource > Sources [get, set]
Sources of AI Analog Multichannel Window Comparator.

Detailed Description

AI Analog Multichannel Window Comparator.

Constructor & Destructor Documentation

◆ AIAnalogMultichannelWindowComparator()

JY5322A.AIAnalogMultichannelWindowComparator.AIAnalogMultichannelWindowComparator ( )

Member Function Documentation

◆ Add()

void JY5322A.AIAnalogMultichannelWindowComparator.Add | ( | AIAnalogTriggerSource | source,
 |  | AIAnalogWindowCondition | condition,
 |  | double | highThreshold,
 |  | double | lowThreshold )

Add source.

Parameters
source | Trigger source
condition | AI Analog Window Condition
highThreshold | High Threshold
lowThreshold | Low Threshold

◆ Clear()

void JY5322A.AIAnalogMultichannelWindowComparator.Clear ( )

Clear sources.

Property Documentation

◆ Sources

List<AIAnalogMultichannelWindowComparatorSource> JY5322A.AIAnalogMultichannelWindowComparator.Sources
getset

Sources of AI Analog Multichannel Window Comparator.

The documentation for this class was generated from the following file:
  • JY5322AAITask.cs


5322A C# API Manual: JY5322A.AIAnalogMultichannelWindowComparatorSource Class Reference

  • AIAnalogMultichannelWindowComparatorSource
Public Member Functions | Properties | List of all members
JY5322A.AIAnalogMultichannelWindowComparatorSource Class Reference

AI Analog Multichannel Window Comparator Source. More...

Public Member Functions

AIAnalogMultichannelWindowComparatorSource (AIAnalogTriggerSource source, AIAnalogWindowCondition condition, double highThreshold, double lowThreshold)
AI Analog Multichannel Window Comparator Source.

Properties

AIAnalogTriggerSource | Source [get, set]
Analog Trigger source.
AIAnalogWindowCondition | Condition [get, set]
AI Analog Window Condition.
double | HighThreshold [get, set]
High Threshold.
double | LowThreshold [get, set]
Low Threshold.

Detailed Description

AI Analog Multichannel Window Comparator Source.

Constructor & Destructor Documentation

◆ AIAnalogMultichannelWindowComparatorSource()

JY5322A.AIAnalogMultichannelWindowComparatorSource.AIAnalogMultichannelWindowComparatorSource | ( | AIAnalogTriggerSource | source,
 |  | AIAnalogWindowCondition | condition,
 |  | double | highThreshold,
 |  | double | lowThreshold )

AI Analog Multichannel Window Comparator Source.

Property Documentation

◆ Condition

AIAnalogWindowCondition JY5322A.AIAnalogMultichannelWindowComparatorSource.Condition
getset

AI Analog Window Condition.

◆ HighThreshold

double JY5322A.AIAnalogMultichannelWindowComparatorSource.HighThreshold
getset

High Threshold.

◆ LowThreshold

double JY5322A.AIAnalogMultichannelWindowComparatorSource.LowThreshold
getset

Low Threshold.

◆ Source

AIAnalogTriggerSource JY5322A.AIAnalogMultichannelWindowComparatorSource.Source
getset

Analog Trigger source.

The documentation for this class was generated from the following file:
  • JY5322AAITask.cs


5322A C# API Manual: JY5322A.AIAnalogMultichannelEdgeComparator Class Reference

  • AIAnalogMultichannelEdgeComparator
Public Member Functions | Properties | List of all members
JY5322A.AIAnalogMultichannelEdgeComparator Class Reference

AI Analog Multichannel Edge Comparator. More...

Public Member Functions

void | Add (AIAnalogTriggerSource source, AIAnalogTriggerEdge slope, double threshold)
Add source.
void | Clear ()
Clear sources.
AIAnalogMultichannelEdgeComparator ()

Properties

List< AIAnalogMultichannelEdgeComparatorSource > Sources [get, set]
Sources of AI Analog Multichannel Edge Comparator.

Detailed Description

AI Analog Multichannel Edge Comparator.

Constructor & Destructor Documentation

◆ AIAnalogMultichannelEdgeComparator()

JY5322A.AIAnalogMultichannelEdgeComparator.AIAnalogMultichannelEdgeComparator ( )

Member Function Documentation

◆ Add()

void JY5322A.AIAnalogMultichannelEdgeComparator.Add | ( | AIAnalogTriggerSource | source,
 |  | AIAnalogTriggerEdge | slope,
 |  | double | threshold )

Add source.

Parameters
source | Analog Trigger source
slope | AI Analog Trigger Edge
threshold | Threshold

◆ Clear()

void JY5322A.AIAnalogMultichannelEdgeComparator.Clear ( )

Clear sources.

Property Documentation

◆ Sources

List<AIAnalogMultichannelEdgeComparatorSource> JY5322A.AIAnalogMultichannelEdgeComparator.Sources
getset

Sources of AI Analog Multichannel Edge Comparator.

The documentation for this class was generated from the following file:
  • JY5322AAITask.cs


5322A C# API Manual: JY5322A.AIAnalogMultichannelEdgeComparatorSource Class Reference

  • AIAnalogMultichannelEdgeComparatorSource
Public Member Functions | Properties | List of all members
JY5322A.AIAnalogMultichannelEdgeComparatorSource Class Reference

AI Analog Multichannel Edge Comparator Source. More...

Public Member Functions

AIAnalogMultichannelEdgeComparatorSource ()
AI Analog Multichannel Edge Comparator Source.
AIAnalogMultichannelEdgeComparatorSource (AIAnalogTriggerSource source, AIAnalogTriggerEdge slope, double threshold)
AI Analog Multichannel Edge Comparator Source.

Properties

AIAnalogTriggerSource | Source [get, set]
Analog Trigger source.
AIAnalogTriggerEdge | Slope [get, set]
AI Analog Trigger Edge.
double | Threshold [get, set]
Threshold.

Detailed Description

AI Analog Multichannel Edge Comparator Source.

Constructor & Destructor Documentation

◆ AIAnalogMultichannelEdgeComparatorSource() [1/2]

JY5322A.AIAnalogMultichannelEdgeComparatorSource.AIAnalogMultichannelEdgeComparatorSource ( )

AI Analog Multichannel Edge Comparator Source.

◆ AIAnalogMultichannelEdgeComparatorSource() [2/2]

JY5322A.AIAnalogMultichannelEdgeComparatorSource.AIAnalogMultichannelEdgeComparatorSource | ( | AIAnalogTriggerSource | source,
 |  | AIAnalogTriggerEdge | slope,
 |  | double | threshold )

AI Analog Multichannel Edge Comparator Source.

Property Documentation

◆ Slope

AIAnalogTriggerEdge JY5322A.AIAnalogMultichannelEdgeComparatorSource.Slope
getset

AI Analog Trigger Edge.

◆ Source

AIAnalogTriggerSource JY5322A.AIAnalogMultichannelEdgeComparatorSource.Source
getset

Analog Trigger source.

◆ Threshold

double JY5322A.AIAnalogMultichannelEdgeComparatorSource.Threshold
getset

Threshold.

The documentation for this class was generated from the following file:
  • JY5322AAITask.cs


5322A C# API Manual: JY5322A.AIDigitalTrigger Class Reference

  • AIDigitalTrigger
Properties | List of all members
JY5322A.AIDigitalTrigger Class Referencesealed

AI Digital Trigger. More...

Properties

AIDigitalTriggerSource | Source [get, set]
AI Digital Trigger Source.
AIDigitalTriggerEdge | Edge [get, set]
AI Digital Trigger Edge，Rising/Falling.
bool | InvertInput [get, set]
Input Trigger Signal Invert,default:fasle.

Detailed Description

AI Digital Trigger.

Property Documentation

◆ Edge

AIDigitalTriggerEdge JY5322A.AIDigitalTrigger.Edge
getset

AI Digital Trigger Edge，Rising/Falling.

◆ InvertInput

bool JY5322A.AIDigitalTrigger.InvertInput
getset

Input Trigger Signal Invert,default:fasle.

◆ Source

AIDigitalTriggerSource JY5322A.AIDigitalTrigger.Source
getset

AI Digital Trigger Source.

The documentation for this class was generated from the following file:
  • JY5322AAITask.cs


5322A C# API Manual: JY5322A.AIRecord Class Reference

  • AIRecord
Properties | List of all members
JY5322A.AIRecord Class Referencesealed

AI Record class. More...

Properties

string | FilePath [get, set]
Path of streaming file,including filePath and filename.
FileFormat | FileFormat [get]
Streaming file format.
RecordMode | Mode [get, set]
Two stream mode from enum Finite/Infinite.
double | Length [get, set]
User specified stream length in second. Only valid in the Finite mode.

Detailed Description

AI Record class.

Property Documentation

◆ FileFormat

FileFormat JY5322A.AIRecord.FileFormat
get

Streaming file format.

◆ FilePath

string JY5322A.AIRecord.FilePath
getset

Path of streaming file,including filePath and filename.

◆ Length

double JY5322A.AIRecord.Length
getset

User specified stream length in second. Only valid in the Finite mode.

◆ Mode

RecordMode JY5322A.AIRecord.Mode
getset

Two stream mode from enum Finite/Infinite.

The documentation for this class was generated from the following file:
  • JY5322AAITask.cs


5322A C# API Manual: JY5322A.AIAdvanced Class Reference

  • AIAdvanced
Properties | List of all members
JY5322A.AIAdvanced Class Referencesealed

AI Advance parameter. More...

Properties

AIRawDataWidth | RawDataWidth [get, set]
Raw Data Width.
DSMode | DSMode [get, set]
DSMode Config.

Detailed Description

AI Advance parameter.

Property Documentation

◆ DSMode

DSMode JY5322A.AIAdvanced.DSMode
getset

DSMode Config.

◆ RawDataWidth

AIRawDataWidth JY5322A.AIAdvanced.RawDataWidth
getset

Raw Data Width.

The documentation for this class was generated from the following file:
  • JY5322AAITask.cs


5322A C# API Manual: JY5322A.AISamplingInfo Class Reference

  • AISamplingInfo
Properties | List of all members
JY5322A.AISamplingInfo Class Referencesealed

AI Sampling information. More...

Properties

AIRawDataWidth | RawDataWidth [get]
Raw Data Width.
double | ConvertClockRate [get]
ADC convert clock rate, in Samples/second.
double | OversamplingRatio [get]
Oversampling Ratio.
double[] | GroupDelay [get]
Group Delay in Samples.

Detailed Description

AI Sampling information.

Property Documentation

◆ ConvertClockRate

double JY5322A.AISamplingInfo.ConvertClockRate
get

ADC convert clock rate, in Samples/second.

◆ GroupDelay

double [] JY5322A.AISamplingInfo.GroupDelay
get

Group Delay in Samples.

◆ OversamplingRatio

double JY5322A.AISamplingInfo.OversamplingRatio
get

Oversampling Ratio.

◆ RawDataWidth

AIRawDataWidth JY5322A.AISamplingInfo.RawDataWidth
get

Raw Data Width.

The documentation for this class was generated from the following file:
  • JY5322AAITask.cs


5322A C# API Manual: JY5322A.DSMode Class Reference

  • DSMode
Properties | List of all members
JY5322A.DSMode Class Referencesealed

DS Mode Class Paraments. More...

Properties

bool Enable [get, set]
Enable DSMode.

Detailed Description

DS Mode Class Paraments.

Property Documentation

◆ Enable

bool JY5322A.DSMode.Enable
getset

Enable DSMode.

The documentation for this class was generated from the following file:
  • JY5322AAITask.cs


5322A C# API Manual: JY5322A.AISignalExport Class Reference

  • AISignalExport
Public Member Functions | List of all members
JY5322A.AISignalExport Class Reference

Signal Export Class. More...

Public Member Functions

void | Add (AISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (AISignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Add (AISignalExportSource source, SignalExportDestination destination, SignalExportOutputType outType, bool invertOutput)
Export one Signal to Desination.
void | Add (AISignalExportSource source, List< SignalExportDestination > destinations, SignalExportOutputType outType, bool invertOutput)
Export one Signal to Mutil Desination.
void | Add (AIAnalogMultichannelComparator analogTrigComparatorParam, SignalExportDestination destination, SignalExportOutputType outType, bool invertOutput)
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.
void | Arm ()
arm All Signal Export

Detailed Description

Signal Export Class.

Member Function Documentation

◆ Add() [1/5]

void JY5322A.AISignalExport.Add | ( | AIAnalogMultichannelComparator | analogTrigComparatorParam,
 |  | SignalExportDestination | destination,
 |  | SignalExportOutputType | outType,
 |  | bool | invertOutput )
Parameters
analogTrigComparatorParam
destination
outType Output Type
invertOutput

◆ Add() [2/5]

void JY5322A.AISignalExport.Add | ( | AISignalExportSource | source,
 |  | List< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | AI Signal Source
destinations | Mutil Export Desinations

◆ Add() [3/5]

void JY5322A.AISignalExport.Add | ( | AISignalExportSource | source,
 |  | List< SignalExportDestination > | destinations,
 |  | SignalExportOutputType | outType,
 |  | bool | invertOutput )

Export one Signal to Mutil Desination.

Parameters
source | AI Signal Source
destinations | Mutil Export Desinations
outType | Output Type
invertOutput | Whether exported sianal is inverted.

◆ Add() [4/5]

void JY5322A.AISignalExport.Add | ( | AISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | AI Signal Source
destination | Export Desination

◆ Add() [5/5]

void JY5322A.AISignalExport.Add | ( | AISignalExportSource | source,
 |  | SignalExportDestination | destination,
 |  | SignalExportOutputType | outType,
 |  | bool | invertOutput )

Export one Signal to Desination.

Parameters
source | AI Signal Source
destination | Export Desination
outType | Output Type
invertOutput | Whether exported sianal is inverted.

◆ Arm()

void JY5322A.AISignalExport.Arm ( )

arm All Signal Export

◆ Clear()

void JY5322A.AISignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY5322A.AISignalExport.ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • JY5322AAITask.cs


5322A C# API Manual: JY5322A Namespace Reference

  • Package List
  • Package Members
Classes | Enumerations
JY5322A Namespace Reference

Classes

class | JY5322AAITask
JY5322AA Analog Input Task. More...
class | AIChannel
AI Channel parameter class. More...
class | ScalingCoefficients
将原始Raw数据转换为工程单位（电压值）的换算因子。 More...
class | AISampleClock
Sample clock configuration class. More...
class | AIExternalSampleClock
External Sample Clock Configuration Class. More...
class | AITrigger
AI Trigger class. More...
class | AIAnalogHysteresisComparator
AI Analog Hysteresis Comparator. More...
class | AIAnalogWindowComparator
AI Analog Window Comparator. More...
class | AIAnalogEdgeComparator
AI Analog Edge Comparator. More...
class | AIAnalogTrigger
AI Analog Trigger. More...
class | AIAnalogMultichannelComparator
AI Analog Multichannel Trigger/Comparator. More...
class | AIAnalogMultichannelHysteresisComparator
AI Analog Multichannel Hysteresis Comparator. More...
class | AIAnalogMultichannelHysteresisComparatorSource
AI Analog Multichannel Hysteresis Comparator Source. More...
class | AIAnalogMultichannelWindowComparator
AI Analog Multichannel Window Comparator. More...
class | AIAnalogMultichannelWindowComparatorSource
AI Analog Multichannel Window Comparator Source. More...
class | AIAnalogMultichannelEdgeComparator
AI Analog Multichannel Edge Comparator. More...
class | AIAnalogMultichannelEdgeComparatorSource
AI Analog Multichannel Edge Comparator Source. More...
class | AIDigitalTrigger
AI Digital Trigger. More...
class | AIRecord
AI Record class. More...
class | AIAdvanced
AI Advance parameter. More...
class | AISamplingInfo
AI Sampling information. More...
class | DSMode
DS Mode Class Paraments. More...
class | AISignalExport
Signal Export Class. More...
class | JY5322ACITask
JY5322A Counter Input Task. More...
class | CISampleClock
CI Sample Clock class. More...
class | CIInternalSampleClock
CI Internal Sample Clock Configuration Class. More...
class | CIImplicitSampleClock
CI Implicit Sample Clock class. More...
class | CIExternalSampleClock
CI Implicit Sample Clock class. More...
class | CIExternalTimebase
class | CITimebase
class | EdgeCounting
Configure CI EdgeCounting. More...
class | EdgeCountingOutEvent
Edge counting output event configuration class. More...
class | PauseTrigger
Pause trigger configuration class. More...
class | FrequencyMeas
Configure CI Measure. More...
class | PeriodMeas
Configure CI Measure. More...
class | PulseMeas
Configure CI Measure. More...
class | SemiPeriodMeas
Configure CI Measure. More...
class | TwoEdgeSeparation
Configure CI Measure. More...
class | QuadEncoder
Configure CI Measure. More...
class | TwoPulseEncoder
Configure CI Measure. More...
class | CITrigger
Constructor to create an CITrigger task object. Used to build CI Trigger. More...
class | CIDigitalTrigger
CI Digital trigger . More...
class | CISignalExport
CI Signal Export Class. More...
class | JY5322ACOTask
JY5322AA Counter Output Task. More...
class | COTrigger
Constructor to create an COTrigger task object. Used to build CO Trigger. More...
class | CODigitalTrigger
CO Digital trigger . More...
class | COPulse
Pulse Parameter. More...
class | COExternalTimebase
class | COTimebase
class | COSignalExport
CO Signal Export Class. More...
class | JY5322ADITask
JY5322AADITask Class. More...
class | DIChannel
DI Channel parameter class . More...
class | DISampleClock
Sample clock configuration class. More...
class | DIExternalSampleClock
External Sample Clock Configuration Class. More...
class | DISignalExport
DI Signal Export Class. More...
class | DITrigger
Constructor to create an DITrigger task object. Used to build DI Trigger. More...
class | DIDigitalTrigger
DI Digital trigger . More...
class | JY5322ADOTask
JY5322AA Digital Output Task. More...
class | DOChannel
DO Channel parameter class . More...
class | DOSampleClock
Sample clock configuration class. More...
class | DOExternalSampleClock
External Sample Clock Configuration Class. More...
class | DOTrigger
Constructor to create an DOTrigger task object. Used to build DO Trigger. More...
class | DODigitalTrigger
DO Digital trigger. More...
class | DOSignalExport
DO Signal Export Class. More...

Enumerations

enum | AITerminalBoard { Normal = JY5322AImport.JY5322A_Normal , TB_5301A = JY5322AImport.JY5322A_TB_5301A }
AI Terminal Board. More...
enum | AIBandWidth { _25KHz = JY5322AImport.JY5322A_AI_BandWidth_25K , _220KHz = JY5322AImport.JY5322A_AI_BandWidth_220K }
AI BandWidth. More...
enum AITriggerType {
Immediate = JY5322AImport.JY5322A_TriggerType_Immediately , Digital = JY5322AImport.JY5322A_TriggerType_Digital , Analog = JY5322AImport.JY5322A_TriggerType_Analog , Soft = JY5322AImport.JY5322A_TriggerType_Soft ,
MultichannelAnalog = 4
}
Trigger Type: Digital/Analog/Immediate. More...
enum | AIMode { Single = JY5322AImport.JY5322A_AI_Single , Finite = JY5322AImport.JY5322A_AI_Finite , Continuous = JY5322AImport.JY5322A_AI_Continuous , Record = 0x3 }
AIMode. More...
enum | AISampleClockSource { Internal = JY5322AImport.JY5322A_AI_InternalClock , External = JY5322AImport.JY5322A_AI_ExternalClock }
AIClockSource Type. More...
enum ClockTerminal {
PFI0 = JY5322AImport.JY5322A_Clock_PFI_0 , PFI1 = JY5322AImport.JY5322A_Clock_PFI_1 , PFI2 = JY5322AImport.JY5322A_Clock_PFI_2 , PFI3 = JY5322AImport.JY5322A_Clock_PFI_3 ,
PFI4 = JY5322AImport.JY5322A_Clock_PFI_4 , PFI5 = JY5322AImport.JY5322A_Clock_PFI_5 , PFI6 = JY5322AImport.JY5322A_Clock_PFI_6 , PFI7 = JY5322AImport.JY5322A_Clock_PFI_7 ,
PFI8 = JY5322AImport.JY5322A_Clock_PFI_8 , PFI9 = JY5322AImport.JY5322A_Clock_PFI_9 , PFI10 = JY5322AImport.JY5322A_Clock_PFI_10 , PFI11 = JY5322AImport.JY5322A_Clock_PFI_11 ,
PFI12 = JY5322AImport.JY5322A_Clock_PFI_12 , PFI13 = JY5322AImport.JY5322A_Clock_PFI_13 , PFI14 = JY5322AImport.JY5322A_Clock_PFI_14 , PFI15 = JY5322AImport.JY5322A_Clock_PFI_15 ,
PXI_Trig0 = JY5322AImport.JY5322A_SampleClock_PXI_Trig_0 , PXI_Trig1 = JY5322AImport.JY5322A_Clock_PXI_Trig_1 , PXI_Trig2 = JY5322AImport.JY5322A_Clock_PXI_Trig_2 , PXI_Trig3 = JY5322AImport.JY5322A_Clock_PXI_Trig_3 ,
PXI_Trig4 = JY5322AImport.JY5322A_Clock_PXI_Trig_4 , PXI_Trig5 = JY5322AImport.JY5322A_Clock_PXI_Trig_5 , PXI_Trig6 = JY5322AImport.JY5322A_Clock_PXI_Trig_6 , PXI_Trig7 = JY5322AImport.JY5322A_Clock_PXI_Trig_7 ,
AI_SampleClock = JY5322AImport.JY5322A_Inter_AI_SampleClock , CI0_SampleClock = JY5322AImport.JY5322A_Inter_CI_0_SampleClock , CO0_Output = JY5322AImport.JY5322A_Inter_CO_0_Output , DI_SampleClock = JY5322AImport.JY5322A_Clock_DI_SampleClock ,
DO_SampleClock = JY5322AImport.JY5322A_Clock_DO_SampleClock
}
External Sample Clock Terminal. More...
enum | AITriggerMode { Start = JY5322AImport.JY5322A_StartTrigger , Reference = JY5322AImport.JY5322A_ReferenceTrigger }
AI Trigger Mode. More...
enum AIAnalogTriggerSource {
Channel_0 , Channel_1 , Channel_2 , Channel_3 ,
Channel_4 , Channel_5 , Channel_6 , Channel_7 ,
Channel_8 , Channel_9 , Channel_10 , Channel_11 ,
Channel_12 , Channel_13 , Channel_14 , Channel_15 ,
Channel_16 , Channel_17 , Channel_18 , Channel_19 ,
Channel_20 , Channel_21 , Channel_22 , Channel_23 ,
Channel_24 , Channel_25 , Channel_26 , Channel_27 ,
Channel_28 , Channel_29 , Channel_30 , Channel_31
}
AI Analog Trigger Source. More...
enum | AIAnalogTriggerEdge { Rising = JY5322AImport.JY5322A_AnalogTriggerEdge_RisingSlope , Falling = JY5322AImport.JY5322A_AnalogTriggerEdge_FallingSlope }
AI Analog Trigger Edge. More...
enum | AIAnalogWindowCondition { Entering = JY5322AImport.JY5322A_AnalogTriggerCondition_EnteringWindow , Leaving = JY5322AImport.JY5322A_AnaloglTriggerCondition_LeavingWindow }
AI Analog Window Trigger Condition. More...
enum | AIAnalogTriggerComparator { Edge , Hysteresis , Window }
AI Analog Trigger Comparator. More...
enum | AIAnalogComparatorLogic { Or = JY5322AImport.Or , And = JY5322AImport.And }
Multichannel composition logic. More...
enum AIDigitalTriggerSource {
PFI0 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_0 , PFI1 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_1 , PFI2 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_2 , PFI3 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_3 ,
PFI4 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_4 , PFI5 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_5 , PFI6 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_6 , PFI7 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_7 ,
PFI8 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_8 , PFI9 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_9 , PFI10 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_10 , PFI11 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_11 ,
PFI12 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_12 , PFI13 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_13 , PFI14 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_14 , PFI15 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_15 ,
PXI_Trig0 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_0 , PXI_Trig1 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_1 , PXI_Trig2 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_2 , PXI_Trig3 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_3 ,
PXI_Trig4 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_4 , PXI_Trig5 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_5 , PXI_Trig6 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_6 , PXI_Trig7 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_7 ,
Inter_AI_StartTrig = JY5322AImport.JY5322A_DigitalTriggerSource_Inter_AI_StartTrig , Inter_AI_ReferenceTrig = JY5322AImport.JY5322A_DigitalTriggerSource_Inter_AI_ReferenceTrig , Inter_CIO_0_StartTrig = JY5322AImport.JY5322A_DigitalTriggerSource_Inter_CIO_0_StartTrig , Inter_Counter_0_Output = JY5322AImport.JY5322A_DigitalTriggerSource_Inter_Counter_0_Output ,
Inter_DI_StartTrig = JY5322AImport.JY5322A_DigitalTriggerSource_Inter_DI_StartTrig , Inter_DI_ReferenceTrig = JY5322AImport.JY5322A_DigitalTriggerSource_Inter_DI_ReferenceTrig , Inter_DO_StartTrig = JY5322AImport.JY5322A_DigitalTriggerSource_Inter_DO_StartTrig
}
AI Digital Trigger Source. More...
enum | AIDigitalTriggerEdge { Rising = JY5322AImport.JY5322A_DigitalTriggerEdge_Rising , Falling = JY5322AImport.JY5322A_DigitalTriggerEdge_Falling }
AI Digital Trigger Edge. More...
enum | FileFormat { Bin }
Streaming file format. More...
enum | RecordMode { Finite , Infinite }
Two stream mode from enum Finite/Infinite. More...
enum | AIRawDataWidth { Auto = JY5322AImport.JY5322A_AI_RawDataWidth_Auto , _16Bits = JY5322AImport.JY5322A_AI_RawDataWidth_16Bits , _32Bits = JY5322AImport.JY5322A_AI_RawDataWidth_32Bits }
AI Raw Data Width. More...
enum | AISignalExportSource { StartTrig = JY5322AImport.JY5322A_AI_StartTrig , ReferenceTrig = JY5322AImport.JY5322A_AI_ReferenceTrig , SampleClock = JY5322AImport.JY5322A_AI_SampleClock , ChannelComparatorOut = JY5322AImport.JY5322A_AI_AnalogTrigger }
AI Signal Export Source. More...
enum SignalExportDestination {
PFI0 = JY5322AImport.JY5322A_PFI0_OUT , PFI1 = JY5322AImport.JY5322A_PFI1_OUT , PFI2 = JY5322AImport.JY5322A_PFI2_OUT , PFI3 = JY5322AImport.JY5322A_PFI3_OUT ,
PFI4 = JY5322AImport.JY5322A_PFI4_OUT , PFI5 = JY5322AImport.JY5322A_PFI5_OUT , PFI6 = JY5322AImport.JY5322A_PFI6_OUT , PFI7 = JY5322AImport.JY5322A_PFI7_OUT ,
PFI8 = JY5322AImport.JY5322A_PFI8_OUT , PFI9 = JY5322AImport.JY5322A_PFI9_OUT , PFI10 = JY5322AImport.JY5322A_PFI10_OUT , PFI11 = JY5322AImport.JY5322A_PFI11_OUT ,
PFI12 = JY5322AImport.JY5322A_PFI12_OUT , PFI13 = JY5322AImport.JY5322A_PFI13_OUT , PFI14 = JY5322AImport.JY5322A_PFI14_OUT , PFI15 = JY5322AImport.JY5322A_PFI15_OUT ,
PXI_Trig0 = JY5322AImport.JY5322A_PXITrig0_OUT , PXI_Trig1 = JY5322AImport.JY5322A_PXITrig1_OUT , PXI_Trig2 = JY5322AImport.JY5322A_PXITrig2_OUT , PXI_Trig3 = JY5322AImport.JY5322A_PXITrig3_OUT ,
PXI_Trig4 = JY5322AImport.JY5322A_PXITrig4_OUT , PXI_Trig5 = JY5322AImport.JY5322A_PXITrig5_OUT , PXI_Trig6 = JY5322AImport.JY5322A_PXITrig6_OUT , PXI_Trig7 = JY5322AImport.JY5322A_PXITrig7_OUT ,
None = JY5322AImport.JY5322A_None
}
Output DestinationTerminal. More...
enum | SignalExportOutputType { Logic = 0 , OCGate = 1 }
Signal Export Output Type. More...
enum | CountDirection { Up = JY5322AImport.JY5322A_CI_Count_Up , Down = JY5322AImport.JY5322A_CI_Count_Down , External = JY5322AImport.JY5322A_CI_Count_External }
Counter direction. enum Up/Down/External. More...
enum | CIMode { Single = JY5322AImport.JY5322A_CI_Single , Finite = JY5322AImport.JY5322A_CI_Finite , Continuous = JY5322AImport.JY5322A_CI_Continuous }
CIMode. More...
enum CIType {
EdgeCounting , Period , Frequency , Pulse ,
SemiPeriod , TwoEdgeSeparation , QuadEncoder , TwoPulseEncoder
}
Counter Input Application Type. More...
enum | CISampleClockSource { Implicit = JY5322AImport.JY5322A_CI_ImplicitClock , Internal = JY5322AImport.JY5322A_CI_InternalClock , External = JY5322AImport.JY5322A_CI_ExternalClock }
CI Sample Clock Source. More...
enum | EdgeType { Rising = JY5322AImport.JY5322A_RisingEdge , Falling = JY5322AImport.JY5322A_FallingEdge , Any = JY5322AImport.JY5322A_AnyEdge }
Edge Type. More...
enum | CITimebaseSource { Internal100MHz = JY5322AImport.JY5322A_Internal_Timebase_100M , Internal5MHz = JY5322AImport.JY5322A_Internal_Timebase_5M , Internal100kHz = JY5322AImport.JY5322A_Internal_Timebase_100K , External = JY5322AImport.JY5322A_External_Timebase }
enum | EdgeCntOunEvtIdleState { LowLevel = JY5322AImport.JY5322A_CI_CounterEventSignalIdleState_Low , HighLevel = JY5322AImport.JY5322A_CI_CounterEventSignalIdleState_High }
Output idle state when the event has not occurred. More...
enum | LevelPolarity { LowLevel = 0 , HighLevel = 1 , None = 2 }
Level Polarity. More...
enum | OutputState { HoldOn = 0 , HighLevel = 1 , LowLevel = 2 }
CO output state when pause trigger valid. More...
enum | ValueReturnMode { TwoValue = JY5322AImport.JY5322A_CI_ReturnTwoValue , OneValue = JY5322AImport.JY5322A_CI_ReturnOneValue }
TwoEdgeSeparation value return mode.only for TwoEdgeSeparation type. More...
enum | QuadEncodingType { X1 , X2 , X4 }
Quadrature Encoding Type. More...
enum | CITriggerType { Immediate = JY5322AImport.JY5322A_CIO_Immediately , Digital = JY5322AImport.JY5322A_CIO_Digital , Soft = JY5322AImport.JY5322A_CIO_Soft }
TriggerType Digital/Immediate/Soft. More...
enum CIDigitalTriggerSource {
PFI0 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_0 , PFI1 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_1 , PFI2 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_2 , PFI3 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_3 ,
PFI4 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_4 , PFI5 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_5 , PFI6 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_6 , PFI7 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_7 ,
PFI8 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_8 , PFI9 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_9 , PFI10 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_10 , PFI11 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_11 ,
PFI12 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_12 , PFI13 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_13 , PFI14 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_14 , PFI15 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_15 ,
PXI_Trig0 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_0 , PXI_Trig1 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_1 , PXI_Trig2 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_2 , PXI_Trig3 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_3 ,
PXI_Trig4 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_4 , PXI_Trig5 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_5 , PXI_Trig6 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_6 , PXI_Trig7 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_7 ,
AI_StartTrig = JY5322AImport.JY5322A_DigitalTriggerSource_Inter_AI_StartTrig , AI_ReferenceTrig = JY5322AImport.JY5322A_DigitalTriggerSource_Inter_AI_ReferenceTrig , CI_0_StartTrig = JY5322AImport.JY5322A_DigitalTriggerSource_Inter_CIO_0_StartTrig , CI_0_OutPut = JY5322AImport.JY5322A_DigitalTriggerSource_Inter_Counter_0_Output
}
CI Digital trigger source. More...
enum | CIDigitalTriggerEdge { Rising }
CI Digital Trigger Edge. More...
enum InputTerminal {
PFI0 = JY5322AImport.JY5322A_IN_PFI0 , PFI1 = JY5322AImport.JY5322A_IN_PFI1 , PFI2 = JY5322AImport.JY5322A_IN_PFI2 , PFI3 = JY5322AImport.JY5322A_IN_PFI3 ,
PFI4 = JY5322AImport.JY5322A_IN_PFI4 , PFI5 = JY5322AImport.JY5322A_IN_PFI5 , PFI6 = JY5322AImport.JY5322A_IN_PFI6 , PFI7 = JY5322AImport.JY5322A_IN_PFI7 ,
PFI8 = JY5322AImport.JY5322A_IN_PFI8 , PFI9 = JY5322AImport.JY5322A_IN_PFI9 , PFI10 = JY5322AImport.JY5322A_IN_PFI10 , PFI11 = JY5322AImport.JY5322A_IN_PFI11 ,
PFI12 = JY5322AImport.JY5322A_IN_PFI12 , PFI13 = JY5322AImport.JY5322A_IN_PFI13 , PFI14 = JY5322AImport.JY5322A_IN_PFI14 , PFI15 = JY5322AImport.JY5322A_IN_PFI15 ,
PXI_Trig0 = JY5322AImport.JY5322A_IN_PXI_Trig0 , PXI_Trig1 = JY5322AImport.JY5322A_IN_PXI_Trig1 , PXI_Trig2 = JY5322AImport.JY5322A_IN_PXI_Trig2 , PXI_Trig3 = JY5322AImport.JY5322A_IN_PXI_Trig3 ,
PXI_Trig4 = JY5322AImport.JY5322A_IN_PXI_Trig4 , PXI_Trig5 = JY5322AImport.JY5322A_IN_PXI_Trig5 , PXI_Trig6 = JY5322AImport.JY5322A_IN_PXI_Trig6 , PXI_Trig7 = JY5322AImport.JY5322A_IN_PXI_Trig7 ,
AI_SampleClock = JY5322AImport.JY5322A_IN_AI_SampleClock , Timebase_100MHz = JY5322AImport.JY5322A_IN_CIO_100MHz , Timebase_5MHz = JY5322AImport.JY5322A_IN_CIO_5MHz , Timebase_100kHz = JY5322AImport.JY5322A_IN_CIO_100kHz
}
enum IOTerminal {
PFI0 = JY5322AImport.JY5322A_IN_PFI0 , PFI1 = JY5322AImport.JY5322A_IN_PFI1 , PFI2 = JY5322AImport.JY5322A_IN_PFI2 , PFI3 = JY5322AImport.JY5322A_IN_PFI3 ,
PFI4 = JY5322AImport.JY5322A_IN_PFI4 , PFI5 = JY5322AImport.JY5322A_IN_PFI5 , PFI6 = JY5322AImport.JY5322A_IN_PFI6 , PFI7 = JY5322AImport.JY5322A_IN_PFI7 ,
PFI8 = JY5322AImport.JY5322A_IN_PFI8 , PFI9 = JY5322AImport.JY5322A_IN_PFI9 , PFI10 = JY5322AImport.JY5322A_IN_PFI10 , PFI11 = JY5322AImport.JY5322A_IN_PFI11 ,
PFI12 = JY5322AImport.JY5322A_IN_PFI12 , PFI13 = JY5322AImport.JY5322A_IN_PFI13 , PFI14 = JY5322AImport.JY5322A_IN_PFI14 , PFI15 = JY5322AImport.JY5322A_IN_PFI15 ,
PXI_Trig0 = JY5322AImport.JY5322A_IN_PXI_Trig0 , PXI_Trig1 = JY5322AImport.JY5322A_IN_PXI_Trig1 , PXI_Trig2 = JY5322AImport.JY5322A_IN_PXI_Trig2 , PXI_Trig3 = JY5322AImport.JY5322A_IN_PXI_Trig3 ,
PXI_Trig4 = JY5322AImport.JY5322A_IN_PXI_Trig4 , PXI_Trig5 = JY5322AImport.JY5322A_IN_PXI_Trig5 , PXI_Trig6 = JY5322AImport.JY5322A_IN_PXI_Trig6 , PXI_Trig7 = JY5322AImport.JY5322A_IN_PXI_Trig7 ,
None = 25
}
enum | CISignalExportSource { StartTrig , SampleClock }
SourceSignal. More...
enum | COIdleState { HighLevel = JY5322AImport.JY5322A_HighLevel , LowLevel = JY5322AImport.JY5322A_LowLevel }
Idle state when pulse output before start and after stop. More...
enum | COMode { Single = JY5322AImport.JY5322A_CO_Single , Finite = JY5322AImport.JY5322A_CO_Finite , ContinuousNoWrapping = JY5322AImport.JY5322A_CO_ContinuousNoWrapping , ContinuousWrapping = JY5322AImport.JY5322A_CO_ContinuousWrapping }
CO output mode. More...
enum | COTriggerType { Immediate = JY5322AImport.JY5322A_CIO_Immediately , Digital = JY5322AImport.JY5322A_CIO_Digital , Soft = JY5322AImport.JY5322A_CIO_Soft }
TriggerType Digital/Immediate/Soft. More...
enum CODigitalTriggerSource {
PFI0 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_0 , PFI1 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_1 , PFI2 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_2 , PFI3 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_3 ,
PFI4 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_4 , PFI5 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_5 , PFI6 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_6 , PFI7 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_7 ,
PFI8 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_8 , PFI9 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_9 , PFI10 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_10 , PFI11 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_11 ,
PFI12 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_12 , PFI13 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_13 , PFI14 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_14 , PFI15 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_15 ,
PXI_Trig0 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_0 , PXI_Trig1 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_1 , PXI_Trig2 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_2 , PXI_Trig3 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_3 ,
PXI_Trig4 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_4 , PXI_Trig5 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_5 , PXI_Trig6 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_6 , PXI_Trig7 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_7 ,
AI_StartTrig = JY5322AImport.JY5322A_DigitalTriggerSource_Inter_AI_StartTrig , AI_ReferenceTrig = JY5322AImport.JY5322A_DigitalTriggerSource_Inter_AI_ReferenceTrig , CI_0_StartTrig = JY5322AImport.JY5322A_DigitalTriggerSource_Inter_CIO_0_StartTrig , CI_0_OutPut = JY5322AImport.JY5322A_DigitalTriggerSource_Inter_Counter_0_Output
}
CO Digital trigger source. More...
enum | CODigitalTriggerEdge { Rising , Falling }
CO Digital Trigger Edge. More...
enum | COPulseType { DutyCycleFrequency , HighLowTime , HighLowTick }
Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick. More...
enum | COTimebaseSource { Internal100MHz = 0 , Internal5MHz = 1 , Internal100kHz = 2 , External = 3 }
enum | COSignalExportSource { StartTrig , Output }
SourceSignal. More...
enum | DISampleClockSource { Internal , External }
DI Sample Clock Source. More...
enum | DIMode { Single = 2 , Finite = 0 , Continuous = 1 }
DIMode. More...
enum | DISignalExportSource { StartTrig = JY5322AImport.JY5322A_DI_StartTrig , ReferenceTrig = JY5322AImport.JY5322A_DI_ReferenceTrig , SampleClock = JY5322AImport.JY5322A_DI_SampleClock }
SourceSignal. More...
enum | DITriggerMode { Start , Reference }
DI Trigger Mode. More...
enum | DITriggerType { Immediate = JY5322AImport.JY5322A_TriggerType_Immediately , Digital = JY5322AImport.JY5322A_TriggerType_Digital , Soft = JY5322AImport.JY5322A_TriggerType_Soft }
TriggerType Digital/Immediate/Soft. More...
enum DIDigitalTriggerSource {
PFI0 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_0 , PFI1 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_1 , PFI2 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_2 , PFI3 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_3 ,
PFI4 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_4 , PFI5 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_5 , PFI6 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_6 , PFI7 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_7 ,
PFI8 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_8 , PFI9 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_9 , PFI10 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_10 , PFI11 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_11 ,
PFI12 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_12 , PFI13 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_13 , PFI14 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_14 , PFI15 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_15 ,
PXI_Trig0 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_0 , PXI_Trig1 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_1 , PXI_Trig2 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_2 , PXI_Trig3 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_3 ,
PXI_Trig4 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_4 , PXI_Trig5 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_5 , PXI_Trig6 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_6 , PXI_Trig7 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_7 ,
AI_StartTrig = JY5322AImport.JY5322A_AI_StartTrig , AI_ReferenceTrig = JY5322AImport.JY5322A_AI_ReferenceTrig , DO_StartTrig = JY5322AImport.JY5322A_DO_StartTrig , CIO_0_StartTrig = JY5322AImport.JY5322A_CIO_0_StartTrig ,
CO_0_Out = JY5322AImport.JY5322A_CO_0_Output
}
DI Digital trigger source. More...
enum | DIDigitalTriggerEdge { Rising , Falling }
DI Digital Trigger Edge. More...
enum | DOSampleClockSource { Internal , External }
DO Sample Clock Source. More...
enum | DOMode { Single = 3 , Finite = 0 , ContinuousWrapping = 1 , ContinuousNoWrapping = 2 }
DOMode. More...
enum | DODigitalTriggerEdge { Rising , Falling }
DO Digital Trigger Edge. More...
enum DODigitalTriggerSource {
PFI0 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_0 , PFI1 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_1 , PFI2 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_2 , PFI3 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_3 ,
PFI4 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_4 , PFI5 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_5 , PFI6 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_6 , PFI7 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_7 ,
PFI8 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_8 , PFI9 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_9 , PFI10 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_10 , PFI11 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_11 ,
PFI12 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_12 , PFI13 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_13 , PFI14 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_14 , PFI15 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_15 ,
PXI_Trig0 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_0 , PXI_Trig1 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_1 , PXI_Trig2 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_2 , PXI_Trig3 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_3 ,
PXI_Trig4 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_4 , PXI_Trig5 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_5 , PXI_Trig6 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_6 , PXI_Trig7 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_7 ,
AI_StartTrig = JY5322AImport.JY5322A_AI_StartTrig , AI_ReferenceTrig = JY5322AImport.JY5322A_AI_ReferenceTrig , DI_StartTrig = JY5322AImport.JY5322A_DI_StartTrig , DI_ReferenceTrig = JY5322AImport.JY5322A_DI_ReferenceTrig ,
CIO_0_StartTrig = JY5322AImport.JY5322A_CIO_0_StartTrig , CO_0_Out = JY5322AImport.JY5322A_Inter_CO_0_Output
}
DO Digital trigger source. More...
enum | DOTriggerType { Immediate = JY5322AImport.JY5322A_TriggerType_Immediately , Digital = JY5322AImport.JY5322A_TriggerType_Digital , Soft = JY5322AImport.JY5322A_TriggerType_Soft }
TriggerType Digital/Immediate/Soft. More...
enum | DOSignalExportSource { StartTrig = JY5322AImport.JY5322A_DO_StartTrig , SampleClock = JY5322AImport.JY5322A_DO_SampleClock }
SourceSignal. More...
enum | OutputCompleteState { Zero , Hold }
Output Complete State. More...

Enumeration Type Documentation

◆ AIAnalogComparatorLogic

enum JY5322A.AIAnalogComparatorLogic

Multichannel composition logic.

Enumerator
Or | Multichannel result take or.
And | Multichannel results take and.

◆ AIAnalogTriggerComparator

enum JY5322A.AIAnalogTriggerComparator

AI Analog Trigger Comparator.

Enumerator
Edge | Edge Comparator.
Hysteresis | Hysteresis Comparator.
Window | Window Comparator.

◆ AIAnalogTriggerEdge

enum JY5322A.AIAnalogTriggerEdge

AI Analog Trigger Edge.

Enumerator
Rising | Rising.
Falling | Falling.

◆ AIAnalogTriggerSource

enum JY5322A.AIAnalogTriggerSource

AI Analog Trigger Source.

Enumerator
Channel_0 | channel 0
Channel_1 | channel 1
Channel_2 | channel 2
Channel_3 | channel 3
Channel_4 | channel 4
Channel_5 | channel 5
Channel_6 | channel 6
Channel_7 | channel 7
Channel_8 | channel 8
Channel_9 | channel 9
Channel_10 | channel 10
Channel_11 | channel 11
Channel_12 | channel 12
Channel_13 | channel 13
Channel_14 | channel 14
Channel_15 | channel 15
Channel_16 | channel 16
Channel_17 | channel 17
Channel_18 | channel 18
Channel_19 | channel 19
Channel_20 | channel 20
Channel_21 | channel 21
Channel_22 | channel 22
Channel_23 | channel 23
Channel_24 | channel 24
Channel_25 | channel 25
Channel_26 | channel 26
Channel_27 | channel 27
Channel_28 | channel 28
Channel_29 | channel 29
Channel_30 | channel 30
Channel_31 | channel 31

◆ AIAnalogWindowCondition

enum JY5322A.AIAnalogWindowCondition

AI Analog Window Trigger Condition.

Enumerator
Entering | Rising.
Leaving | Falling.

◆ AIBandWidth

enum JY5322A.AIBandWidth

AI BandWidth.

Enumerator
_25KHz | 25KHz BandWidth
_220KHz | 220KHz BandWidth

◆ AIDigitalTriggerEdge

enum JY5322A.AIDigitalTriggerEdge

AI Digital Trigger Edge.

Enumerator
Rising | Rising.
Falling | Falling.

◆ AIDigitalTriggerSource

enum JY5322A.AIDigitalTriggerSource

AI Digital Trigger Source.

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PFI8 | PFI_8.
PFI9 | PFI_9.
PFI10 | PFI_10.
PFI11 | PFI_11.
PFI12 | PFI_12.
PFI13 | PFI_13.
PFI14 | PFI_14.
PFI15 | PFI_15.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
Inter_AI_StartTrig | Inter_AI_StartTrig.
Inter_AI_ReferenceTrig | Inter_AI_ReferenceTrig.
Inter_CIO_0_StartTrig | Inter_CIO_0_StartTrig.
Inter_Counter_0_Output | Inter_Counter_0_Output.
Inter_DI_StartTrig | Inter_DI_StartTrig.
Inter_DI_ReferenceTrig | Inter_DI_ReferenceTrig.
Inter_DO_StartTrig | Inter_DO_StartTrig.

◆ AIMode

enum JY5322A.AIMode

AIMode.

Enumerator
Single | 单点模式
Finite | Finite.
Continuous | Continuous.
Record | Record.

◆ AIRawDataWidth

enum JY5322A.AIRawDataWidth

AI Raw Data Width.

Enumerator
Auto | Auto.
_16Bits | 16-bit.
_32Bits | 32-bit.

◆ AISampleClockSource

enum JY5322A.AISampleClockSource

AIClockSource Type.

Enumerator
Internal | Internal.
External | External.

◆ AISignalExportSource

enum JY5322A.AISignalExportSource

AI Signal Export Source.

Enumerator
StartTrig | AI_StartTrig.
ReferenceTrig | AI_ReferenceTrig.
SampleClock | AI_SampleClock.
ChannelComparatorOut | AI_Analog Multichannel Comparator Output.

◆ AITerminalBoard

enum JY5322A.AITerminalBoard

AI Terminal Board.

Enumerator
Normal | Normal.
TB_5301A | TB_5301A.

◆ AITriggerMode

enum JY5322A.AITriggerMode

AI Trigger Mode.

Enumerator
Start | Start Trigger Mode.
Reference | Reference Trigger Mode，Valid when JY5322AAITask.Mode is AIMode.Finite.

◆ AITriggerType

enum JY5322A.AITriggerType

Trigger Type: Digital/Analog/Immediate.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Analog | Analog Trigger.
Soft | Soft Trigger.
MultichannelAnalog | MultiChannel Analog Trigger.

◆ CIDigitalTriggerEdge

enum JY5322A.CIDigitalTriggerEdge

CI Digital Trigger Edge.

Enumerator
Rising

RisingEdge.

◆ CIDigitalTriggerSource

enum JY5322A.CIDigitalTriggerSource

CI Digital trigger source.

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PFI8 | PFI_8.
PFI9 | PFI_9.
PFI10 | PFI_10.
PFI11 | PFI_11.
PFI12 | PFI_12.
PFI13 | PFI_13.
PFI14 | PFI_14.
PFI15 | PFI_15.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
AI_StartTrig | AI_StartTrig.
AI_ReferenceTrig | AI_ReferenceTrig.
CI_0_StartTrig | CI0_StartTrig.
CI_0_OutPut | CI0_StartTrig.

◆ CIMode

enum JY5322A.CIMode

CIMode.

Enumerator
Single | Single.
Finite | Finite.
Continuous | Continuous.

◆ CISampleClockSource

enum JY5322A.CISampleClockSource

CI Sample Clock Source.

Enumerator
Implicit | Implicit.
Internal | Internal.
External | External.

◆ CISignalExportSource

enum JY5322A.CISignalExportSource

SourceSignal.

Enumerator
StartTrig | CI_StartTrig.
SampleClock | CI_SampleClock.

◆ CITimebaseSource

enum JY5322A.CITimebaseSource

时基源

Timebase source

Enumerator
Internal100MHz | 内部100MHz时基 Internal 100MHz Timebase
Internal5MHz | 内部5MHz时基 Internal 5MHz Timebase
Internal100kHz | 内部100kHz时基 Internal 100kHz Timebase
External | 外部时基 External Timebase

◆ CITriggerType

enum JY5322A.CITriggerType

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ CIType

enum JY5322A.CIType

Counter Input Application Type.

Enumerator
EdgeCounting | Edge Counting.
Period | Period Measure.
Frequency | Frequenc Measure.
Pulse | Pulse Measure.
SemiPeriod | SemiPeriod Measure.
TwoEdgeSeparation | TwoEdgeSeparation Measure.
QuadEncoder | QuadEncoder.
TwoPulseEncoder | EncoderTwoPulse.

◆ ClockTerminal

enum JY5322A.ClockTerminal

External Sample Clock Terminal.

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PFI8 | PFI_8.
PFI9 | PFI_9.
PFI10 | PFI_10.
PFI11 | PFI_11.
PFI12 | PFI_12.
PFI13 | PFI_13.
PFI14 | PFI_14.
PFI15 | PFI_15.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
AI_SampleClock | AI_SampleClock.
CI0_SampleClock | AI_SampleClock.
CO0_Output | CO0_SampleClock.
DI_SampleClock | DI_SampleClock.
DO_SampleClock | DO_SampleClock.

◆ CODigitalTriggerEdge

enum JY5322A.CODigitalTriggerEdge

CO Digital Trigger Edge.

Enumerator
Rising | Rising Edge.
Falling | Falling Edge.

◆ CODigitalTriggerSource

enum JY5322A.CODigitalTriggerSource

CO Digital trigger source.

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PFI8 | PFI_8.
PFI9 | PFI_9.
PFI10 | PFI_10.
PFI11 | PFI_11.
PFI12 | PFI_12.
PFI13 | PFI_13.
PFI14 | PFI_14.
PFI15 | PFI_15.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
AI_StartTrig | AI_StartTrig.
AI_ReferenceTrig | AI_ReferenceTrig.
CI_0_StartTrig | CI0_StartTrig.
CI_0_OutPut | CI0_StartTrig.

◆ COIdleState

enum JY5322A.COIdleState

Idle state when pulse output before start and after stop.

Enumerator
HighLevel | Idle state is high level.
LowLevel | Idle state is low level.

◆ COMode

enum JY5322A.COMode

CO output mode.

Enumerator
Single | Single pulse output.
Finite | Finite.
ContinuousNoWrapping | ContinuousNoWrapping.
ContinuousWrapping | ContinuousWrapping.

◆ COPulseType

enum JY5322A.COPulseType

Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick.

Enumerator
DutyCycleFrequency | Configure CO output pulse according to its DutyCycle and Freqency.
HighLowTime | Configure CO output pulse according to duration of its high/low voltage levels.
HighLowTick | Configure CO output pulse according to its high/low tick level.

◆ COSignalExportSource

enum JY5322A.COSignalExportSource

SourceSignal.

Enumerator
StartTrig | CI_StartTrig.
Output | CO_Output.

◆ COTimebaseSource

enum JY5322A.COTimebaseSource

时基源

Timebase source

Enumerator
Internal100MHz | 内部100MHz时基 Internal 100MHz Timebase
Internal5MHz | 内部5MHz时基 Internal 5MHz Timebase
Internal100kHz | 内部100kHz时基 Internal 100kHz Timebase
External | 外部时基 External Timebase

◆ COTriggerType

enum JY5322A.COTriggerType

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ CountDirection

enum JY5322A.CountDirection

Counter direction. enum Up/Down/External.

Enumerator
Up | Counter increases.
Down | Counter decreases.
External | External signal control counter direction. If External signal is highlevel counter increases, or lowlevel counter decreases.

◆ DIDigitalTriggerEdge

enum JY5322A.DIDigitalTriggerEdge

DI Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ DIDigitalTriggerSource

enum JY5322A.DIDigitalTriggerSource

DI Digital trigger source.

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PFI8 | PFI_8.
PFI9 | PFI_9.
PFI10 | PFI_10.
PFI11 | PFI_11.
PFI12 | PFI_12.
PFI13 | PFI_13.
PFI14 | PFI_14.
PFI15 | PFI_15.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
AI_StartTrig | AI_StartTrig.
AI_ReferenceTrig | AI_ReferenceTrig.
DO_StartTrig | AO_StartTrig.
CIO_0_StartTrig | CI0_StartTrig.
CO_0_Out | CI0_StartTrig.

◆ DIMode

enum JY5322A.DIMode

DIMode.

Enumerator
Single | Single.
Finite | Finite.
Continuous | Continuous.

◆ DISampleClockSource

enum JY5322A.DISampleClockSource

DI Sample Clock Source.

Enumerator
Internal | Internal Clock Source.
External | External Clock Source.

◆ DISignalExportSource

enum JY5322A.DISignalExportSource

SourceSignal.

Enumerator
StartTrig | DI_StartTrig.
ReferenceTrig | DI_ReferenceTrig.
SampleClock | DI_SampleClock.

◆ DITriggerMode

enum JY5322A.DITriggerMode

DI Trigger Mode.

Enumerator
Start | Start Trigger.
Reference | Reference Trigger，only for finite acquisition mode.

◆ DITriggerType

enum JY5322A.DITriggerType

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ DODigitalTriggerEdge

enum JY5322A.DODigitalTriggerEdge

DO Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ DODigitalTriggerSource

enum JY5322A.DODigitalTriggerSource

DO Digital trigger source.

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PFI8 | PFI_8.
PFI9 | PFI_9.
PFI10 | PFI_10.
PFI11 | PFI_11.
PFI12 | PFI_12.
PFI13 | PFI_13.
PFI14 | PFI_14.
PFI15 | PFI_15.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
AI_StartTrig | AI_StartTrig.
AI_ReferenceTrig | AI_ReferenceTrig.
DI_StartTrig | DI_StartTrig.
DI_ReferenceTrig | DI_ReferenceTrig.
CIO_0_StartTrig | CI0_StartTrig.
CO_0_Out | CI0_StartTrig.

◆ DOMode

enum JY5322A.DOMode

DOMode.

Enumerator
Single | Single.
Finite | Finite.
ContinuousWrapping | ContinuousNoWrapping.
ContinuousNoWrapping | ContinuousWrapping.

◆ DOSampleClockSource

enum JY5322A.DOSampleClockSource

DO Sample Clock Source.

Enumerator
Internal | Internal Clock Source.
External | External Clock Source.

◆ DOSignalExportSource

enum JY5322A.DOSignalExportSource

SourceSignal.

Enumerator
StartTrig | DO_StartTrig.
SampleClock | DO_SampleClock.

◆ DOTriggerType

enum JY5322A.DOTriggerType

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ EdgeCntOunEvtIdleState

enum JY5322A.EdgeCntOunEvtIdleState

Output idle state when the event has not occurred.

Enumerator
LowLevel | Idle state is low level.
HighLevel | Idle state is high level.

◆ EdgeType

enum JY5322A.EdgeType

Edge Type.

Enumerator
Rising | Rising Edge.
Falling | Falling Edge.
Any | Any Edge.

◆ FileFormat

enum JY5322A.FileFormat

Streaming file format.

Enumerator
Bin

Binary file format.

◆ InputTerminal

enum JY5322A.InputTerminal
Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PFI8 | PFI_8.
PFI9 | PFI_9.
PFI10 | PFI_10.
PFI11 | PFI_11.
PFI12 | PFI_12.
PFI13 | PFI_13.
PFI14 | PFI_14.
PFI15 | PFI_15.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
AI_SampleClock | PXI Trig 7.
Timebase_100MHz | Timebase_100MHz.
Timebase_5MHz | Timebase_5MHz.
Timebase_100kHz | Timebase_100kHz.

◆ IOTerminal

enum JY5322A.IOTerminal
Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PFI8 | PFI_8.
PFI9 | PFI_9.
PFI10 | PFI_10.
PFI11 | PFI_11.
PFI12 | PFI_12.
PFI13 | PFI_13.
PFI14 | PFI_14.
PFI15 | PFI_15.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
None | None.

◆ LevelPolarity

enum JY5322A.LevelPolarity

Level Polarity.

Enumerator
LowLevel | Low level.
HighLevel | High level.
None | No active polarity.

◆ OutputCompleteState

enum JY5322A.OutputCompleteState

Output Complete State.

Enumerator
Zero | Output Complete Zero.
Hold | Output Complete Hold in The last point.

◆ OutputState

enum JY5322A.OutputState

CO output state when pause trigger valid.

Enumerator
HoldOn | output hold on
HighLevel | output HighLevel
LowLevel | output LowLevel

◆ QuadEncodingType

enum JY5322A.QuadEncodingType

Quadrature Encoding Type.

Enumerator
X1 | X1.
X2 | X2.
X4 | X4.

◆ RecordMode

enum JY5322A.RecordMode

Two stream mode from enum Finite/Infinite.

Enumerator
Finite | Finite Streaming.
Infinite | InFinite Streaming.

◆ SignalExportDestination

enum JY5322A.SignalExportDestination

Output DestinationTerminal.

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PFI8 | PFI_8.
PFI9 | PFI_9.
PFI10 | PFI_10.
PFI11 | PFI_11.
PFI12 | PFI_12.
PFI13 | PFI_13.
PFI14 | PFI_14.
PFI15 | PFI_15.
PXI_Trig0 | PXI Trig0.
PXI_Trig1 | PXI Trig1.
PXI_Trig2 | PXI Trig2.
PXI_Trig3 | PXI Trig3.
PXI_Trig4 | PXI Trig4.
PXI_Trig5 | PXI Trig5.
PXI_Trig6 | PXI Trig6.
PXI_Trig7 | PXI Trig7.
None | None.

◆ SignalExportOutputType

enum JY5322A.SignalExportOutputType

Signal Export Output Type.

Enumerator
Logic | Logic Output.
OCGate | OCGate Output.

◆ ValueReturnMode

enum JY5322A.ValueReturnMode

TwoEdgeSeparation value return mode.only for TwoEdgeSeparation type.

Enumerator
TwoValue | Return two data simultaneously. first data is gate to aux edge separation, second data is aux to gate edge separation.
OneValue | only return gate to aux edge separation


5322A C# API Manual: JY5322ACITask.cs File Reference

  • File List
Classes | Namespaces | Enumerations
JY5322ACITask.cs File Reference

Classes

class | JY5322A.JY5322ACITask
JY5322A Counter Input Task. More...
class | JY5322A.CISampleClock
CI Sample Clock class. More...
class | JY5322A.CIInternalSampleClock
CI Internal Sample Clock Configuration Class. More...
class | JY5322A.CIImplicitSampleClock
CI Implicit Sample Clock class. More...
class | JY5322A.CIExternalSampleClock
CI Implicit Sample Clock class. More...
class | JY5322A.CIExternalTimebase
class | JY5322A.CITimebase
class | JY5322A.EdgeCounting
Configure CI EdgeCounting. More...
class | JY5322A.EdgeCountingOutEvent
Edge counting output event configuration class. More...
class | JY5322A.PauseTrigger
Pause trigger configuration class. More...
class | JY5322A.FrequencyMeas
Configure CI Measure. More...
class | JY5322A.PeriodMeas
Configure CI Measure. More...
class | JY5322A.PulseMeas
Configure CI Measure. More...
class | JY5322A.SemiPeriodMeas
Configure CI Measure. More...
class | JY5322A.TwoEdgeSeparation
Configure CI Measure. More...
class | JY5322A.QuadEncoder
Configure CI Measure. More...
class | JY5322A.TwoPulseEncoder
Configure CI Measure. More...
class | JY5322A.CITrigger
Constructor to create an CITrigger task object. Used to build CI Trigger. More...
class | JY5322A.CIDigitalTrigger
CI Digital trigger . More...
class | JY5322A.CISignalExport
CI Signal Export Class. More...

Namespaces

namespace JY5322A

Enumerations

enum | JY5322A.CountDirection { JY5322A.Up = JY5322AImport.JY5322A_CI_Count_Up , JY5322A.Down = JY5322AImport.JY5322A_CI_Count_Down , JY5322A.External = JY5322AImport.JY5322A_CI_Count_External }
Counter direction. enum Up/Down/External. More...
enum | JY5322A.CIMode { JY5322A.Single = JY5322AImport.JY5322A_CI_Single , JY5322A.Finite = JY5322AImport.JY5322A_CI_Finite , JY5322A.Continuous = JY5322AImport.JY5322A_CI_Continuous }
CIMode. More...
enum JY5322A.CIType {
JY5322A.EdgeCounting , JY5322A.Period , JY5322A.Frequency , JY5322A.Pulse ,
JY5322A.SemiPeriod , JY5322A.TwoEdgeSeparation , JY5322A.QuadEncoder , JY5322A.TwoPulseEncoder
}
Counter Input Application Type. More...
enum | JY5322A.CISampleClockSource { JY5322A.Implicit = JY5322AImport.JY5322A_CI_ImplicitClock , JY5322A.Internal = JY5322AImport.JY5322A_CI_InternalClock , JY5322A.External = JY5322AImport.JY5322A_CI_ExternalClock }
CI Sample Clock Source. More...
enum | JY5322A.EdgeType { JY5322A.Rising = JY5322AImport.JY5322A_RisingEdge , JY5322A.Falling = JY5322AImport.JY5322A_FallingEdge , JY5322A.Any = JY5322AImport.JY5322A_AnyEdge }
Edge Type. More...
enum | JY5322A.CITimebaseSource { JY5322A.Internal100MHz = JY5322AImport.JY5322A_Internal_Timebase_100M , JY5322A.Internal5MHz = JY5322AImport.JY5322A_Internal_Timebase_5M , JY5322A.Internal100kHz = JY5322AImport.JY5322A_Internal_Timebase_100K , JY5322A.External = JY5322AImport.JY5322A_External_Timebase }
enum | JY5322A.EdgeCntOunEvtIdleState { JY5322A.LowLevel = JY5322AImport.JY5322A_CI_CounterEventSignalIdleState_Low , JY5322A.HighLevel = JY5322AImport.JY5322A_CI_CounterEventSignalIdleState_High }
Output idle state when the event has not occurred. More...
enum | JY5322A.LevelPolarity { JY5322A.LowLevel = 0 , JY5322A.HighLevel = 1 , JY5322A.None = 2 }
Level Polarity. More...
enum | JY5322A.OutputState { JY5322A.HoldOn = 0 , JY5322A.HighLevel = 1 , JY5322A.LowLevel = 2 }
CO output state when pause trigger valid. More...
enum | JY5322A.ValueReturnMode { JY5322A.TwoValue = JY5322AImport.JY5322A_CI_ReturnTwoValue , JY5322A.OneValue = JY5322AImport.JY5322A_CI_ReturnOneValue }
TwoEdgeSeparation value return mode.only for TwoEdgeSeparation type. More...
enum | JY5322A.QuadEncodingType { JY5322A.X1 , JY5322A.X2 , JY5322A.X4 }
Quadrature Encoding Type. More...
enum | JY5322A.CITriggerType { JY5322A.Immediate = JY5322AImport.JY5322A_CIO_Immediately , JY5322A.Digital = JY5322AImport.JY5322A_CIO_Digital , JY5322A.Soft = JY5322AImport.JY5322A_CIO_Soft }
TriggerType Digital/Immediate/Soft. More...
enum JY5322A.CIDigitalTriggerSource {
JY5322A.PFI0 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_0 , JY5322A.PFI1 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_1 , JY5322A.PFI2 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_2 , JY5322A.PFI3 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_3 ,
JY5322A.PFI4 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_4 , JY5322A.PFI5 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_5 , JY5322A.PFI6 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_6 , JY5322A.PFI7 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_7 ,
JY5322A.PFI8 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_8 , JY5322A.PFI9 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_9 , JY5322A.PFI10 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_10 , JY5322A.PFI11 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_11 ,
JY5322A.PFI12 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_12 , JY5322A.PFI13 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_13 , JY5322A.PFI14 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_14 , JY5322A.PFI15 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_15 ,
JY5322A.PXI_Trig0 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_0 , JY5322A.PXI_Trig1 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_1 , JY5322A.PXI_Trig2 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_2 , JY5322A.PXI_Trig3 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_3 ,
JY5322A.PXI_Trig4 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_4 , JY5322A.PXI_Trig5 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_5 , JY5322A.PXI_Trig6 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_6 , JY5322A.PXI_Trig7 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_7 ,
JY5322A.AI_StartTrig = JY5322AImport.JY5322A_DigitalTriggerSource_Inter_AI_StartTrig , JY5322A.AI_ReferenceTrig = JY5322AImport.JY5322A_DigitalTriggerSource_Inter_AI_ReferenceTrig , JY5322A.CI_0_StartTrig = JY5322AImport.JY5322A_DigitalTriggerSource_Inter_CIO_0_StartTrig , JY5322A.CI_0_OutPut = JY5322AImport.JY5322A_DigitalTriggerSource_Inter_Counter_0_Output
}
CI Digital trigger source. More...
enum | JY5322A.CIDigitalTriggerEdge { JY5322A.Rising }
CI Digital Trigger Edge. More...
enum JY5322A.InputTerminal {
JY5322A.PFI0 = JY5322AImport.JY5322A_IN_PFI0 , JY5322A.PFI1 = JY5322AImport.JY5322A_IN_PFI1 , JY5322A.PFI2 = JY5322AImport.JY5322A_IN_PFI2 , JY5322A.PFI3 = JY5322AImport.JY5322A_IN_PFI3 ,
JY5322A.PFI4 = JY5322AImport.JY5322A_IN_PFI4 , JY5322A.PFI5 = JY5322AImport.JY5322A_IN_PFI5 , JY5322A.PFI6 = JY5322AImport.JY5322A_IN_PFI6 , JY5322A.PFI7 = JY5322AImport.JY5322A_IN_PFI7 ,
JY5322A.PFI8 = JY5322AImport.JY5322A_IN_PFI8 , JY5322A.PFI9 = JY5322AImport.JY5322A_IN_PFI9 , JY5322A.PFI10 = JY5322AImport.JY5322A_IN_PFI10 , JY5322A.PFI11 = JY5322AImport.JY5322A_IN_PFI11 ,
JY5322A.PFI12 = JY5322AImport.JY5322A_IN_PFI12 , JY5322A.PFI13 = JY5322AImport.JY5322A_IN_PFI13 , JY5322A.PFI14 = JY5322AImport.JY5322A_IN_PFI14 , JY5322A.PFI15 = JY5322AImport.JY5322A_IN_PFI15 ,
JY5322A.PXI_Trig0 = JY5322AImport.JY5322A_IN_PXI_Trig0 , JY5322A.PXI_Trig1 = JY5322AImport.JY5322A_IN_PXI_Trig1 , JY5322A.PXI_Trig2 = JY5322AImport.JY5322A_IN_PXI_Trig2 , JY5322A.PXI_Trig3 = JY5322AImport.JY5322A_IN_PXI_Trig3 ,
JY5322A.PXI_Trig4 = JY5322AImport.JY5322A_IN_PXI_Trig4 , JY5322A.PXI_Trig5 = JY5322AImport.JY5322A_IN_PXI_Trig5 , JY5322A.PXI_Trig6 = JY5322AImport.JY5322A_IN_PXI_Trig6 , JY5322A.PXI_Trig7 = JY5322AImport.JY5322A_IN_PXI_Trig7 ,
JY5322A.AI_SampleClock = JY5322AImport.JY5322A_IN_AI_SampleClock , JY5322A.Timebase_100MHz = JY5322AImport.JY5322A_IN_CIO_100MHz , JY5322A.Timebase_5MHz = JY5322AImport.JY5322A_IN_CIO_5MHz , JY5322A.Timebase_100kHz = JY5322AImport.JY5322A_IN_CIO_100kHz
}
enum JY5322A.IOTerminal {
JY5322A.PFI0 = JY5322AImport.JY5322A_IN_PFI0 , JY5322A.PFI1 = JY5322AImport.JY5322A_IN_PFI1 , JY5322A.PFI2 = JY5322AImport.JY5322A_IN_PFI2 , JY5322A.PFI3 = JY5322AImport.JY5322A_IN_PFI3 ,
JY5322A.PFI4 = JY5322AImport.JY5322A_IN_PFI4 , JY5322A.PFI5 = JY5322AImport.JY5322A_IN_PFI5 , JY5322A.PFI6 = JY5322AImport.JY5322A_IN_PFI6 , JY5322A.PFI7 = JY5322AImport.JY5322A_IN_PFI7 ,
JY5322A.PFI8 = JY5322AImport.JY5322A_IN_PFI8 , JY5322A.PFI9 = JY5322AImport.JY5322A_IN_PFI9 , JY5322A.PFI10 = JY5322AImport.JY5322A_IN_PFI10 , JY5322A.PFI11 = JY5322AImport.JY5322A_IN_PFI11 ,
JY5322A.PFI12 = JY5322AImport.JY5322A_IN_PFI12 , JY5322A.PFI13 = JY5322AImport.JY5322A_IN_PFI13 , JY5322A.PFI14 = JY5322AImport.JY5322A_IN_PFI14 , JY5322A.PFI15 = JY5322AImport.JY5322A_IN_PFI15 ,
JY5322A.PXI_Trig0 = JY5322AImport.JY5322A_IN_PXI_Trig0 , JY5322A.PXI_Trig1 = JY5322AImport.JY5322A_IN_PXI_Trig1 , JY5322A.PXI_Trig2 = JY5322AImport.JY5322A_IN_PXI_Trig2 , JY5322A.PXI_Trig3 = JY5322AImport.JY5322A_IN_PXI_Trig3 ,
JY5322A.PXI_Trig4 = JY5322AImport.JY5322A_IN_PXI_Trig4 , JY5322A.PXI_Trig5 = JY5322AImport.JY5322A_IN_PXI_Trig5 , JY5322A.PXI_Trig6 = JY5322AImport.JY5322A_IN_PXI_Trig6 , JY5322A.PXI_Trig7 = JY5322AImport.JY5322A_IN_PXI_Trig7 ,
JY5322A.None = 25
}
enum | JY5322A.CISignalExportSource { JY5322A.StartTrig , JY5322A.SampleClock }
SourceSignal. More...


5322A C# API Manual: JY5322A.JY5322ACITask Class Reference

  • JY5322ACITask
Public Member Functions | Properties | List of all members
JY5322A.JY5322ACITask Class Referencesealed

JY5322A Counter Input Task. More...

Public Member Functions

JY5322ACITask (int slotNum, int channel)
Constructor. Used to create an CI task by a slot number.
JY5322ACITask (string boardName, int channel)
Constructor. Used to create an CI task by a board name.
void | Start ()
Start CI task .
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Stop ()
Stop CI task .
void | ReadSinglePoint (ref uint count)
Read a signle count value from register, Available when Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder.
void | ReadData (ref uint[] bufCount, int samplesToAcquire, int timeout=10000)
Read counter values from buffer. Available when JY5322ACITask.Mode is NOT CIMode.Single, and Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder.
void | ReadData (ref uint[] bufCount, int timeout=10000)
Read counter values from buffer. Available when JY5322ACITask.Mode is NOT CIMode.Single, and Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder.
void | ReadData (ref double[] bufMeasurement, int samplesToAcquire, int timeout=10000)
Read frequency value or period value from buffer. Available when JY5322ACITask.Mode is NOT CIMode.Single, and Type is CIType.Frequency or CIType.Period.
void | ReadData (ref double[] bufMeasurement, int timeout=10000)
Read frequency value or period value from buffer. Available when JY5322ACITask.Mode is NOT CIMode.Single, and Type is CIType.Frequency or CIType.Period.
void | ReadSinglePoint (ref double measurement, int timeout=10000)
Read a signle frequency value or period value from register. Valid when Type is CIType.Frequency or CIType.Period.
void | ReadSinglePoint (ref double measurement1, ref double measurement2, int timeout=10000)
Read a signle measurement of pulse's duration value, or two-edge separtion value (two results at a time) from register. Available when Type is CIType.Pulse or CIType.TwoEdgeSeparation.
void | ReadData (ref double[] bufMeasurement1, ref double[] bufMeasurement2, int samplesToAcquire, int timeout=10000)
Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.. Available when JY5322ACITask.Mode is NOT CIMode.Single, Type is CIType.Pulse or CIType.TwoEdgeSeparation.
void | ReadData (ref double[] bufMeasurement1, ref double[] bufMeasurement2, int timeout=10000)
Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.. Available when JY5322ACITask.Mode is NOT CIMode.Single, Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Properties

CIType | Type [get, set]
CI Application types.
ulong | AvailableSamples [get]
Number of points per channel that can be read in the buffer .
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer (per channel). Valid when Mode is NOT CIMode.Single.
CIMode | Mode [get, set]
CI Sampling mode，support Single/Finite/Continuous.
CISampleClock | SampleClock [get, set]
Clock Source.
uint | SamplesToAcquire [get, set]
Number of samples to be read per channel.Only valid when Mode is CIMode.Finite.
EdgeCounting | EdgeCounting [get, set]
Edge Counting Configuration.
FrequencyMeas | FrequencyMeas [get, set]
Frequency Measurement Configuration.
PeriodMeas | PeriodMeas [get, set]
Period Measurement Configuration.
SemiPeriodMeas | SemiPeriodMeas [get, set]
SemiPeriodMeas Measurement Configuration.
PulseMeas | PulseMeas [get, set]
Pulse Measurement Configuration.
TwoEdgeSeparation | TwoEdgeSeparation [get, set]
TwoEdgeSeparation.
QuadEncoder | QuadEncoder [get, set]
QuadEncoder.
TwoPulseEncoder | TwoPulseEncoder [get, set]
TwoPulseEncoder.
CITrigger | Trigger = new CITrigger() [get, set]
CI Trigger Configuration.
CISignalExport | SignalExport [get, set]
Export CI Signal Configuration.
JY5322ADevice | Device [get]
Device.

Detailed Description

JY5322A Counter Input Task.

Constructor & Destructor Documentation

◆ JY5322ACITask() [1/2]

JY5322A.JY5322ACITask.JY5322ACITask | ( | int | slotNum,
 |  | int | channel )

Constructor. Used to create an CI task by a slot number.

Parameters
slotNum | Card slot number.
channel | Counter channel（5521 5323 support0-1,5322 5324 suppor0）

◆ JY5322ACITask() [2/2]

JY5322A.JY5322ACITask.JY5322ACITask | ( | string | boardName,
 |  | int | channel )

Constructor. Used to create an CI task by a board name.

Parameters
boardName | Board name(device alias), set by device manager
channel | Counter channel （5521 5323 support0-1,5322 5324 suppor0）.

Member Function Documentation

◆ ReadData() [1/6]

void JY5322A.JY5322ACITask.ReadData | ( | ref double[] | bufMeasurement,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read frequency value or period value from buffer. Available when JY5322ACITask.Mode is NOT CIMode.Single, and Type is CIType.Frequency or CIType.Period.

Parameters
bufMeasurement | Buffer for reading data. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period in seconds when Type is CIType.Period.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [2/6]

void JY5322A.JY5322ACITask.ReadData | ( | ref double[] | bufMeasurement,
 |  | int | timeout = 10000 )

Read frequency value or period value from buffer. Available when JY5322ACITask.Mode is NOT CIMode.Single, and Type is CIType.Frequency or CIType.Period.

Parameters
bufMeasurement | Buffer for reading data. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period in seconds when Type is CIType.Period.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [3/6]

void JY5322A.JY5322ACITask.ReadData | ( | ref double[] | bufMeasurement1,
 |  | ref double[] | bufMeasurement2,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.. Available when JY5322ACITask.Mode is NOT CIMode.Single, Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
bufMeasurement1 | Buffer for reading data. Indicates high level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
bufMeasurement2 | Buffer for reading data. Indicates low level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [4/6]

void JY5322A.JY5322ACITask.ReadData | ( | ref double[] | bufMeasurement1,
 |  | ref double[] | bufMeasurement2,
 |  | int | timeout = 10000 )

Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.. Available when JY5322ACITask.Mode is NOT CIMode.Single, Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
bufMeasurement1 | Buffer for reading data. Indicates high level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
bufMeasurement2 | Buffer for reading data. Indicates low level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [5/6]

void JY5322A.JY5322ACITask.ReadData | ( | ref uint[] | bufCount,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read counter values from buffer. Available when JY5322ACITask.Mode is NOT CIMode.Single, and Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder.

Parameters
bufCount | Buffer for reading data.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [6/6]

void JY5322A.JY5322ACITask.ReadData | ( | ref uint[] | bufCount,
 |  | int | timeout = 10000 )

Read counter values from buffer. Available when JY5322ACITask.Mode is NOT CIMode.Single, and Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder.

Parameters
bufCount | Buffer for reading data.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [1/3]

void JY5322A.JY5322ACITask.ReadSinglePoint | ( | ref double | measurement,
 |  | int | timeout = 10000 )

Read a signle frequency value or period value from register. Valid when Type is CIType.Frequency or CIType.Period.

Parameters
measurement Measurement value. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period is seconds when Type is CIType.Period.
timeout
Timeout (ms). Wait until the measurement is completed or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [2/3]

void JY5322A.JY5322ACITask.ReadSinglePoint | ( | ref double | measurement1,
 |  | ref double | measurement2,
 |  | int | timeout = 10000 )

Read a signle measurement of pulse's duration value, or two-edge separtion value (two results at a time) from register. Available when Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
measurement1 | Measurement Value 1. Indicates low level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
measurement2 | Measurement Value 2. Indicates high level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
timeout
Timeout (ms). Wait until the measurement is completed or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [3/3]

void JY5322A.JY5322ACITask.ReadSinglePoint ( ref uint count )

Read a signle count value from register, Available when Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder.

Parameters
count counter value。

◆ SendSoftwareTrigger()

void JY5322A.JY5322ACITask.SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5322A.JY5322ACITask.Start ( )

Start CI task .

◆ Stop()

void JY5322A.JY5322ACITask.Stop ( )

Stop CI task .

Property Documentation

◆ AvailableSamples

ulong JY5322A.JY5322ACITask.AvailableSamples
get

Number of points per channel that can be read in the buffer .

◆ Device

JY5322ADevice JY5322A.JY5322ACITask.Device
get

Device.

◆ EdgeCounting

EdgeCounting JY5322A.JY5322ACITask.EdgeCounting
getset

Edge Counting Configuration.

◆ FrequencyMeas

FrequencyMeas JY5322A.JY5322ACITask.FrequencyMeas
getset

Frequency Measurement Configuration.

◆ Mode

CIMode JY5322A.JY5322ACITask.Mode
getset

CI Sampling mode，support Single/Finite/Continuous.

◆ PeriodMeas

PeriodMeas JY5322A.JY5322ACITask.PeriodMeas
getset

Period Measurement Configuration.

◆ PulseMeas

PulseMeas JY5322A.JY5322ACITask.PulseMeas
getset

Pulse Measurement Configuration.

◆ QuadEncoder

QuadEncoder JY5322A.JY5322ACITask.QuadEncoder
getset

QuadEncoder.

◆ SampleClock

CISampleClock JY5322A.JY5322ACITask.SampleClock
getset

Clock Source.

◆ SamplesToAcquire

uint JY5322A.JY5322ACITask.SamplesToAcquire
getset

Number of samples to be read per channel.Only valid when Mode is CIMode.Finite.

◆ SemiPeriodMeas

SemiPeriodMeas JY5322A.JY5322ACITask.SemiPeriodMeas
getset

SemiPeriodMeas Measurement Configuration.

◆ SignalExport

CISignalExport JY5322A.JY5322ACITask.SignalExport
getset

Export CI Signal Configuration.

◆ TransferedSamples

ulong JY5322A.JY5322ACITask.TransferedSamples
get

The number of samples that have been transfered from the local buffer (per channel). Valid when Mode is NOT CIMode.Single.

◆ Trigger

CITrigger JY5322A.JY5322ACITask.Trigger = new CITrigger()
getset

CI Trigger Configuration.

◆ TwoEdgeSeparation

TwoEdgeSeparation JY5322A.JY5322ACITask.TwoEdgeSeparation
getset

TwoEdgeSeparation.

◆ TwoPulseEncoder

TwoPulseEncoder JY5322A.JY5322ACITask.TwoPulseEncoder
getset

TwoPulseEncoder.

◆ Type

CIType JY5322A.JY5322ACITask.Type
getset

CI Application types.

The documentation for this class was generated from the following file:
  • JY5322ACITask.cs


5322A C# API Manual: JY5322A.CISampleClock Class Reference

  • CISampleClock
Properties | List of all members
JY5322A.CISampleClock Class Reference

CI Sample Clock class. More...

Properties

CISampleClockSource | Source [get, set]
CI Sample Clock Source.
CIExternalSampleClock | External [get, set]
CI External Sample Clock Configuration. Valid when Source is CISampleClockSource.External.
CIImplicitSampleClock | Implicit [get, set]
CI Implicit Sample Clock Configuration. Valid when Source is CISampleClockSource.Implicit.
CIInternalSampleClock | Internal [get]
Internal Sample Clock Configuration. Valid when Source is CISampleClockSource.Internal.

Detailed Description

CI Sample Clock class.

Property Documentation

◆ External

CIExternalSampleClock JY5322A.CISampleClock.External
getset

CI External Sample Clock Configuration. Valid when Source is CISampleClockSource.External.

◆ Implicit

CIImplicitSampleClock JY5322A.CISampleClock.Implicit
getset

CI Implicit Sample Clock Configuration. Valid when Source is CISampleClockSource.Implicit.

◆ Internal

CIInternalSampleClock JY5322A.CISampleClock.Internal
get

Internal Sample Clock Configuration. Valid when Source is CISampleClockSource.Internal.

◆ Source

CISampleClockSource JY5322A.CISampleClock.Source
getset

CI Sample Clock Source.

The documentation for this class was generated from the following file:
  • JY5322ACITask.cs


5322A C# API Manual: JY5322A.CIInternalSampleClock Class Reference

  • CIInternalSampleClock
Properties | List of all members
JY5322A.CIInternalSampleClock Class Reference

CI Internal Sample Clock Configuration Class. More...

Properties

double | Rate [get, set]
The rate of the internal sample clock (sample rate) which is generated by dividing the internal clock (200MHz).
bool | IgnoreFirstSampleClock [get, set]
Ignore the first sample clock data.

Detailed Description

CI Internal Sample Clock Configuration Class.

Property Documentation

◆ IgnoreFirstSampleClock

bool JY5322A.CIInternalSampleClock.IgnoreFirstSampleClock
getset

Ignore the first sample clock data.

◆ Rate

double JY5322A.CIInternalSampleClock.Rate
getset

The rate of the internal sample clock (sample rate) which is generated by dividing the internal clock (200MHz).

The documentation for this class was generated from the following file:
  • JY5322ACITask.cs


5322A C# API Manual: JY5322A.CIImplicitSampleClock Class Reference

  • CIImplicitSampleClock
Properties | List of all members
JY5322A.CIImplicitSampleClock Class Reference

CI Implicit Sample Clock class. More...

Properties

double ExpectedRate [get, set]
Expected Rate of Implicit Sample Clock. Filling this parameter accurately would helps the driver to set a proper DDR write frequency internally.

Detailed Description

CI Implicit Sample Clock class.

Property Documentation

◆ ExpectedRate

double JY5322A.CIImplicitSampleClock.ExpectedRate
getset

Expected Rate of Implicit Sample Clock. Filling this parameter accurately would helps the driver to set a proper DDR write frequency internally.

The documentation for this class was generated from the following file:
  • JY5322ACITask.cs


5322A C# API Manual: JY5322A.CIExternalSampleClock Class Reference

  • CIExternalSampleClock
Properties | List of all members
JY5322A.CIExternalSampleClock Class Reference

CI Implicit Sample Clock class. More...

Properties

ClockTerminal | Terminal [get, set]
External Sample Clock Input Terminal.
double | ExpectedRate [get, set]
Expected Rate of External Sample Clock. Filling this parameter accurately would helps the driver to set a proper DDR write frequency internally.
bool | IgnoreFirstSampleClock [get, set]
Ignore the first sample clock data.

Detailed Description

CI Implicit Sample Clock class.

Property Documentation

◆ ExpectedRate

double JY5322A.CIExternalSampleClock.ExpectedRate
getset

Expected Rate of External Sample Clock. Filling this parameter accurately would helps the driver to set a proper DDR write frequency internally.

◆ IgnoreFirstSampleClock

bool JY5322A.CIExternalSampleClock.IgnoreFirstSampleClock
getset

Ignore the first sample clock data.

◆ Terminal

ClockTerminal JY5322A.CIExternalSampleClock.Terminal
getset

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • JY5322ACITask.cs


5322A C# API Manual: JY5322A.CIExternalTimebase Class Reference

  • CIExternalTimebase
Properties | List of all members
JY5322A.CIExternalTimebase Class Referencesealed

Properties

InputTerminal | Terminal [get, set]
double | Frequency [get, set]

Detailed Description

外部时基配置类

External timebase configuration class

Property Documentation

◆ Frequency

double JY5322A.CIExternalTimebase.Frequency
getset

外部时基的频率

Frequency of The External Timebase

◆ Terminal

InputTerminal JY5322A.CIExternalTimebase.Terminal
getset

外部时基的输入端口

External Timebase Input Terminal

The documentation for this class was generated from the following file:
  • JY5322ACITask.cs


5322A C# API Manual: JY5322A.CITimebase Class Reference

  • CITimebase
Properties | List of all members
JY5322A.CITimebase Class Referencesealed

Properties

CITimebaseSource | Source [get, set]
CIExternalTimebase | External [get, set]

Detailed Description

时基配置类

Timebase configuration class

Property Documentation

◆ External

CIExternalTimebase JY5322A.CITimebase.External
getset

外部时基配置。当 CITimebase.Source 为 CITimebaseSource.External时有效。

External Timebase Configuration. Valid when CITimebase.Source is COTimebaseSource.External.

◆ Source

CITimebaseSource JY5322A.CITimebase.Source
getset

时基源。默认值为 CITimebaseSource.Internal100MHz。

Timebase Source. The default value is CITimebaseSource.Internal100MHz.

The documentation for this class was generated from the following file:
  • JY5322ACITask.cs


5322A C# API Manual: JY5322A.EdgeCounting Class Reference

  • EdgeCounting
Properties | List of all members
JY5322A.EdgeCounting Class Referencesealed

Configure CI EdgeCounting. More...

Properties

int | InitialCount [get, set]
Initial Count.
CountDirection | Direction [get, set]
Counter direction. enum Up/Down/External.
EdgeType | ActiveEdge [get, set]
The avtive edge of the input signal, the counter will count up or down on this edge.
PauseTrigger | Pause [get, set]
Pause Trigger Configuration.
EdgeCountingOutEvent | OutEvent [get, set]
Edge counting output event. A pulse will be generated when the count value reaches specified threshold.
InputTerminal | InputTerminal [get, set]
Input Terminal.
InputTerminal | DirTerminal [get, set]
Terminal of External Count Diretion Control. Valid when Direction is CountDirection.External.
bool | InputSignalReversed [get, set]
Signal Reversed,fasle not reversed. ture reversed.
bool | DirectionSignalReversed [get, set]
Signal Reversed,fasle not reversed. ture reversed.

Detailed Description

Configure CI EdgeCounting.

Property Documentation

◆ ActiveEdge

EdgeType JY5322A.EdgeCounting.ActiveEdge
getset

The avtive edge of the input signal, the counter will count up or down on this edge.

◆ Direction

CountDirection JY5322A.EdgeCounting.Direction
getset

Counter direction. enum Up/Down/External.

◆ DirectionSignalReversed

bool JY5322A.EdgeCounting.DirectionSignalReversed
getset

Signal Reversed,fasle not reversed. ture reversed.

◆ DirTerminal

InputTerminal JY5322A.EdgeCounting.DirTerminal
getset

Terminal of External Count Diretion Control. Valid when Direction is CountDirection.External.

◆ InitialCount

int JY5322A.EdgeCounting.InitialCount
getset

Initial Count.

◆ InputSignalReversed

bool JY5322A.EdgeCounting.InputSignalReversed
getset

Signal Reversed,fasle not reversed. ture reversed.

◆ InputTerminal

InputTerminal JY5322A.EdgeCounting.InputTerminal
getset

Input Terminal.

◆ OutEvent

EdgeCountingOutEvent JY5322A.EdgeCounting.OutEvent
getset

Edge counting output event. A pulse will be generated when the count value reaches specified threshold.

◆ Pause

PauseTrigger JY5322A.EdgeCounting.Pause
getset

Pause Trigger Configuration.

The documentation for this class was generated from the following file:
  • JY5322ACITask.cs


5322A C# API Manual: JY5322A.EdgeCountingOutEvent Class Reference

  • EdgeCountingOutEvent
Properties | List of all members
JY5322A.EdgeCountingOutEvent Class Reference

Edge counting output event configuration class. More...

Properties

EdgeCntOunEvtIdleState | IdleState [get, set]
Output idle state when the event has not occurred. The default value is EdgeCntOunEvtIdleState.LowLevel.
uint | Threshold [get, set]
Comparison threshold. The default value is 2^32-1.
bool | Reset [get, set]
Reset count value to initialCount if ture. if false, the counter continuous count.
IOTerminal | Terminal [get, set]
Terminal.

Detailed Description

Edge counting output event configuration class.

Property Documentation

◆ IdleState

EdgeCntOunEvtIdleState JY5322A.EdgeCountingOutEvent.IdleState
getset

Output idle state when the event has not occurred. The default value is EdgeCntOunEvtIdleState.LowLevel.

◆ Reset

bool JY5322A.EdgeCountingOutEvent.Reset
getset

Reset count value to initialCount if ture. if false, the counter continuous count.

◆ Terminal

IOTerminal JY5322A.EdgeCountingOutEvent.Terminal
getset

Terminal.

◆ Threshold

uint JY5322A.EdgeCountingOutEvent.Threshold
getset

Comparison threshold. The default value is 2^32-1.

The documentation for this class was generated from the following file:
  • JY5322ACITask.cs


5322A C# API Manual: JY5322A.PauseTrigger Class Reference

  • PauseTrigger
Properties | List of all members
JY5322A.PauseTrigger Class Referencesealed

Pause trigger configuration class. More...

Properties

LevelPolarity | ActivePolarity [get, set]
Pause trigger active polarity. The default value is LevelPolarity.None, means the pause trigger is disabled.
OutputState | OutputState [get, set]
CO output state when pause trigger valid. OutputState.HoldOn.
InputTerminal | Terminal [get, set]
Terminal.
bool | SignalReversed [get, set]
Signal Reversed,fasle not reversed. ture reversed.

Detailed Description

Pause trigger configuration class.

Property Documentation

◆ ActivePolarity

LevelPolarity JY5322A.PauseTrigger.ActivePolarity
getset

Pause trigger active polarity. The default value is LevelPolarity.None, means the pause trigger is disabled.

◆ OutputState

OutputState JY5322A.PauseTrigger.OutputState
getset

CO output state when pause trigger valid. OutputState.HoldOn.

◆ SignalReversed

bool JY5322A.PauseTrigger.SignalReversed
getset

Signal Reversed,fasle not reversed. ture reversed.

◆ Terminal

InputTerminal JY5322A.PauseTrigger.Terminal
getset

Terminal.

The documentation for this class was generated from the following file:
  • JY5322ACITask.cs


5322A C# API Manual: JY5322A.FrequencyMeas Class Reference

  • FrequencyMeas
Properties | List of all members
JY5322A.FrequencyMeas Class Referencesealed

Configure CI Measure. More...

Properties

CITimebase | Timebase [get, set]
Timebase configuration.
EdgeType | StartingEdge [get, set]
The start edge of the input signal, the counter will count up or down on this edge.
InputTerminal | InputTerminal [get, set]
Input Terminal.

Detailed Description

Configure CI Measure.

Property Documentation

◆ InputTerminal

InputTerminal JY5322A.FrequencyMeas.InputTerminal
getset

Input Terminal.

◆ StartingEdge

EdgeType JY5322A.FrequencyMeas.StartingEdge
getset

The start edge of the input signal, the counter will count up or down on this edge.

◆ Timebase

CITimebase JY5322A.FrequencyMeas.Timebase
getset

Timebase configuration.

The documentation for this class was generated from the following file:
  • JY5322ACITask.cs


5322A C# API Manual: JY5322A.PeriodMeas Class Reference

  • PeriodMeas
Properties | List of all members
JY5322A.PeriodMeas Class Referencesealed

Configure CI Measure. More...

Properties

CITimebase | Timebase [get, set]
Timebase configuration.
EdgeType | StartingEdge [get, set]
The start edge of the input signal, the counter will count up or down on this edge.
InputTerminal | InputTerminal [get, set]
Input Terminal.

Detailed Description

Configure CI Measure.

Property Documentation

◆ InputTerminal

InputTerminal JY5322A.PeriodMeas.InputTerminal
getset

Input Terminal.

◆ StartingEdge

EdgeType JY5322A.PeriodMeas.StartingEdge
getset

The start edge of the input signal, the counter will count up or down on this edge.

◆ Timebase

CITimebase JY5322A.PeriodMeas.Timebase
getset

Timebase configuration.

The documentation for this class was generated from the following file:
  • JY5322ACITask.cs


5322A C# API Manual: JY5322A.PulseMeas Class Reference

  • PulseMeas
Properties | List of all members
JY5322A.PulseMeas Class Referencesealed

Configure CI Measure. More...

Properties

CITimebase | Timebase [get, set]
Timebase configuration.
EdgeType | StartingEdge [get, set]
The start edge of the input signal, the counter will count up or down on this edge.
InputTerminal | InputTerminal [get, set]
Input Terminal.
bool | SignalReversed [get, set]
Signal Reversed,fasle not reversed. ture reversed.

Detailed Description

Configure CI Measure.

Property Documentation

◆ InputTerminal

InputTerminal JY5322A.PulseMeas.InputTerminal
getset

Input Terminal.

◆ SignalReversed

bool JY5322A.PulseMeas.SignalReversed
getset

Signal Reversed,fasle not reversed. ture reversed.

◆ StartingEdge

EdgeType JY5322A.PulseMeas.StartingEdge
getset

The start edge of the input signal, the counter will count up or down on this edge.

◆ Timebase

CITimebase JY5322A.PulseMeas.Timebase
getset

Timebase configuration.

The documentation for this class was generated from the following file:
  • JY5322ACITask.cs


5322A C# API Manual: JY5322A.SemiPeriodMeas Class Reference

  • SemiPeriodMeas
Properties | List of all members
JY5322A.SemiPeriodMeas Class Referencesealed

Configure CI Measure. More...

Properties

CITimebase | Timebase [get, set]
Timebase configuration.
EdgeType | StartingEdge [get, set]
The start edge of the input signal, the counter will count up or down on this edge.
InputTerminal | InputTerminal [get, set]
Input Terminal.
bool | SignalReversed [get, set]
Signal Reversed,fasle not reversed. ture reversed.

Detailed Description

Configure CI Measure.

Property Documentation

◆ InputTerminal

InputTerminal JY5322A.SemiPeriodMeas.InputTerminal
getset

Input Terminal.

◆ SignalReversed

bool JY5322A.SemiPeriodMeas.SignalReversed
getset

Signal Reversed,fasle not reversed. ture reversed.

◆ StartingEdge

EdgeType JY5322A.SemiPeriodMeas.StartingEdge
getset

The start edge of the input signal, the counter will count up or down on this edge.

◆ Timebase

CITimebase JY5322A.SemiPeriodMeas.Timebase
getset

Timebase configuration.

The documentation for this class was generated from the following file:
  • JY5322ACITask.cs


5322A C# API Manual: JY5322A.TwoEdgeSeparation Class Reference

  • TwoEdgeSeparation
Properties | List of all members
JY5322A.TwoEdgeSeparation Class Referencesealed

Configure CI Measure. More...

Properties

CITimebase | Timebase [get, set]
Timebase configuration.
InputTerminal | FirstInputTerminal [get, set]
Input Terminal.
InputTerminal | SecondInputTerminal [get, set]
Input Terminal.
bool | FirstSignalReversed [get, set]
Signal Reversed,fasle not reversed. ture reversed.
bool | SecondSignalReversed [get, set]
Signal Reversed,fasle not reversed. ture reversed.
ValueReturnMode | EdgeSeparationMode [get, set]

Detailed Description

Configure CI Measure.

Property Documentation

◆ EdgeSeparationMode

ValueReturnMode JY5322A.TwoEdgeSeparation.EdgeSeparationMode
getset

数据返回模式

data return mode

◆ FirstInputTerminal

InputTerminal JY5322A.TwoEdgeSeparation.FirstInputTerminal
getset

Input Terminal.

◆ FirstSignalReversed

bool JY5322A.TwoEdgeSeparation.FirstSignalReversed
getset

Signal Reversed,fasle not reversed. ture reversed.

◆ SecondInputTerminal

InputTerminal JY5322A.TwoEdgeSeparation.SecondInputTerminal
getset

Input Terminal.

◆ SecondSignalReversed

bool JY5322A.TwoEdgeSeparation.SecondSignalReversed
getset

Signal Reversed,fasle not reversed. ture reversed.

◆ Timebase

CITimebase JY5322A.TwoEdgeSeparation.Timebase
getset

Timebase configuration.

The documentation for this class was generated from the following file:
  • JY5322ACITask.cs


5322A C# API Manual: JY5322A.QuadEncoder Class Reference

  • QuadEncoder
Properties | List of all members
JY5322A.QuadEncoder Class Referencesealed

Configure CI Measure. More...

Properties

QuadEncodingType | EncodingType [get, set]
Type of Encoding.
bool | ZReloadEnabled [get, set]
In Encoder mode ,the Z signal enable.
int | InitialCount [get, set]
Initial Count.
InputTerminal | AInputTerminal [get, set]
Input Terminal.
bool | ASignalReversed [get, set]
Signal Reversed,fasle not reversed. ture reversed.
InputTerminal | BInputTerminal [get, set]
Input Terminal.
bool | BSignalReversed [get, set]
Signal Reversed,fasle not reversed. ture reversed.
InputTerminal | ZInputTerminal [get, set]
Input Terminal.
bool | ZSignalReversed [get, set]
Signal Reversed,fasle not reversed. ture reversed.

Detailed Description

Configure CI Measure.

Property Documentation

◆ AInputTerminal

InputTerminal JY5322A.QuadEncoder.AInputTerminal
getset

Input Terminal.

◆ ASignalReversed

bool JY5322A.QuadEncoder.ASignalReversed
getset

Signal Reversed,fasle not reversed. ture reversed.

◆ BInputTerminal

InputTerminal JY5322A.QuadEncoder.BInputTerminal
getset

Input Terminal.

◆ BSignalReversed

bool JY5322A.QuadEncoder.BSignalReversed
getset

Signal Reversed,fasle not reversed. ture reversed.

◆ EncodingType

QuadEncodingType JY5322A.QuadEncoder.EncodingType
getset

Type of Encoding.

◆ InitialCount

int JY5322A.QuadEncoder.InitialCount
getset

Initial Count.

◆ ZInputTerminal

InputTerminal JY5322A.QuadEncoder.ZInputTerminal
getset

Input Terminal.

◆ ZReloadEnabled

bool JY5322A.QuadEncoder.ZReloadEnabled
getset

In Encoder mode ,the Z signal enable.

◆ ZSignalReversed

bool JY5322A.QuadEncoder.ZSignalReversed
getset

Signal Reversed,fasle not reversed. ture reversed.

The documentation for this class was generated from the following file:
  • JY5322ACITask.cs


5322A C# API Manual: JY5322A.TwoPulseEncoder Class Reference

  • TwoPulseEncoder
Properties | List of all members
JY5322A.TwoPulseEncoder Class Referencesealed

Configure CI Measure. More...

Properties

int | InitialCount [get, set]
Initial Count.
InputTerminal | AInputTerminal [get, set]
Input Terminal.
bool | ASignalReversed [get, set]
Signal Reversed,fasle not reversed. ture reversed.
InputTerminal | BInputTerminal [get, set]
Input Terminal.
bool | BSignalReversed [get, set]
Signal Reversed,fasle not reversed. ture reversed.

Detailed Description

Configure CI Measure.

Property Documentation

◆ AInputTerminal

InputTerminal JY5322A.TwoPulseEncoder.AInputTerminal
getset

Input Terminal.

◆ ASignalReversed

bool JY5322A.TwoPulseEncoder.ASignalReversed
getset

Signal Reversed,fasle not reversed. ture reversed.

◆ BInputTerminal

InputTerminal JY5322A.TwoPulseEncoder.BInputTerminal
getset

Input Terminal.

◆ BSignalReversed

bool JY5322A.TwoPulseEncoder.BSignalReversed
getset

Signal Reversed,fasle not reversed. ture reversed.

◆ InitialCount

int JY5322A.TwoPulseEncoder.InitialCount
getset

Initial Count.

The documentation for this class was generated from the following file:
  • JY5322ACITask.cs


5322A C# API Manual: JY5322A.CITrigger Class Reference

  • CITrigger
Properties | List of all members
JY5322A.CITrigger Class Referencesealed

Constructor to create an CITrigger task object. Used to build CI Trigger. More...

Properties

CITriggerType | Type [get, set]
CI trigger type. enum Immediate/Digital/Soft.
CIDigitalTrigger | Digital [get, set]
CI Digital Trigger. Valid when Type is CITriggerType.Digital.

Detailed Description

Constructor to create an CITrigger task object. Used to build CI Trigger.

Property Documentation

◆ Digital

CIDigitalTrigger JY5322A.CITrigger.Digital
getset

CI Digital Trigger. Valid when Type is CITriggerType.Digital.

◆ Type

CITriggerType JY5322A.CITrigger.Type
getset

CI trigger type. enum Immediate/Digital/Soft.

The documentation for this class was generated from the following file:
  • JY5322ACITask.cs


5322A C# API Manual: JY5322A.CIDigitalTrigger Class Reference

  • CIDigitalTrigger
Properties | List of all members
JY5322A.CIDigitalTrigger Class Referencesealed

CI Digital trigger . More...

Properties

CIDigitalTriggerSource | Source [get, set]
CI Digital Trigger source.
CIDigitalTriggerEdge | Edge [get, set]
Digital Trigger edge，Rising/Falling.

Detailed Description

CI Digital trigger .

Property Documentation

◆ Edge

CIDigitalTriggerEdge JY5322A.CIDigitalTrigger.Edge
getset

Digital Trigger edge，Rising/Falling.

◆ Source

CIDigitalTriggerSource JY5322A.CIDigitalTrigger.Source
getset

CI Digital Trigger source.

The documentation for this class was generated from the following file:
  • JY5322ACITask.cs


5322A C# API Manual: JY5322A.CISignalExport Class Reference

  • CISignalExport
Public Member Functions | List of all members
JY5322A.CISignalExport Class Reference

CI Signal Export Class. More...

Public Member Functions

void | Add (CISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (CISignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

CI Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY5322A.CISignalExport.Add | ( | CISignalExportSource | source,
 |  | List< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | CI Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JY5322A.CISignalExport.Add | ( | CISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | CI Signal Source
destination | Export Desination

◆ Clear()

void JY5322A.CISignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY5322A.CISignalExport.ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • JY5322ACITask.cs


5322A C# API Manual: JY5322ACOTask.cs File Reference

  • File List
Classes | Namespaces | Enumerations
JY5322ACOTask.cs File Reference

Classes

class | JY5322A.JY5322ACOTask
JY5322AA Counter Output Task. More...
class | JY5322A.COTrigger
Constructor to create an COTrigger task object. Used to build CO Trigger. More...
class | JY5322A.CODigitalTrigger
CO Digital trigger . More...
class | JY5322A.COPulse
Pulse Parameter. More...
class | JY5322A.COExternalTimebase
class | JY5322A.COTimebase
class | JY5322A.COSignalExport
CO Signal Export Class. More...

Namespaces

namespace JY5322A

Enumerations

enum | JY5322A.COIdleState { JY5322A.HighLevel = JY5322AImport.JY5322A_HighLevel , JY5322A.LowLevel = JY5322AImport.JY5322A_LowLevel }
Idle state when pulse output before start and after stop. More...
enum | JY5322A.COMode { JY5322A.Single = JY5322AImport.JY5322A_CO_Single , JY5322A.Finite = JY5322AImport.JY5322A_CO_Finite , JY5322A.ContinuousNoWrapping = JY5322AImport.JY5322A_CO_ContinuousNoWrapping , JY5322A.ContinuousWrapping = JY5322AImport.JY5322A_CO_ContinuousWrapping }
CO output mode. More...
enum | JY5322A.COTriggerType { JY5322A.Immediate = JY5322AImport.JY5322A_CIO_Immediately , JY5322A.Digital = JY5322AImport.JY5322A_CIO_Digital , JY5322A.Soft = JY5322AImport.JY5322A_CIO_Soft }
TriggerType Digital/Immediate/Soft. More...
enum JY5322A.CODigitalTriggerSource {
JY5322A.PFI0 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_0 , JY5322A.PFI1 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_1 , JY5322A.PFI2 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_2 , JY5322A.PFI3 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_3 ,
JY5322A.PFI4 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_4 , JY5322A.PFI5 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_5 , JY5322A.PFI6 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_6 , JY5322A.PFI7 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_7 ,
JY5322A.PFI8 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_8 , JY5322A.PFI9 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_9 , JY5322A.PFI10 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_10 , JY5322A.PFI11 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_11 ,
JY5322A.PFI12 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_12 , JY5322A.PFI13 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_13 , JY5322A.PFI14 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_14 , JY5322A.PFI15 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_15 ,
JY5322A.PXI_Trig0 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_0 , JY5322A.PXI_Trig1 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_1 , JY5322A.PXI_Trig2 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_2 , JY5322A.PXI_Trig3 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_3 ,
JY5322A.PXI_Trig4 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_4 , JY5322A.PXI_Trig5 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_5 , JY5322A.PXI_Trig6 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_6 , JY5322A.PXI_Trig7 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_7 ,
JY5322A.AI_StartTrig = JY5322AImport.JY5322A_DigitalTriggerSource_Inter_AI_StartTrig , JY5322A.AI_ReferenceTrig = JY5322AImport.JY5322A_DigitalTriggerSource_Inter_AI_ReferenceTrig , JY5322A.CI_0_StartTrig = JY5322AImport.JY5322A_DigitalTriggerSource_Inter_CIO_0_StartTrig , JY5322A.CI_0_OutPut = JY5322AImport.JY5322A_DigitalTriggerSource_Inter_Counter_0_Output
}
CO Digital trigger source. More...
enum | JY5322A.CODigitalTriggerEdge { JY5322A.Rising , JY5322A.Falling }
CO Digital Trigger Edge. More...
enum | JY5322A.COPulseType { JY5322A.DutyCycleFrequency , JY5322A.HighLowTime , JY5322A.HighLowTick }
Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick. More...
enum | JY5322A.COTimebaseSource { JY5322A.Internal100MHz = 0 , JY5322A.Internal5MHz = 1 , JY5322A.Internal100kHz = 2 , JY5322A.External = 3 }
enum | JY5322A.COSignalExportSource { JY5322A.StartTrig , JY5322A.Output }
SourceSignal. More...


5322A C# API Manual: JY5322A.JY5322ACOTask Class Reference

  • JY5322ACOTask
Public Member Functions | Properties | List of all members
JY5322A.JY5322ACOTask Class Referencesealed

JY5322AA Counter Output Task. More...

Public Member Functions

JY5322ACOTask (int slotNum, int channel)
Constructor. Used to create an CO task by a slot number.
JY5322ACOTask (string boardName, int channel)
Constructor. Used to create an CO task by a board name.
void | WriteSinglePoint (COPulse pulse)
Write a single pulse parameter to the register. Valid when Mode is COMode.Single. This function is also available after starting the task when the number of pulses being sent is infinite.
void | WriteData (COPulse[] pulsesGroup, int samplesToWrite, int timeout=10000)
Write pulse parameters to be output to the buffer. Valid when Mode is NOT COMode.Single. When Mode is COMode.Finite or COMode.ContinuousWrapping, this function can only be called once before starting the task.
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Start ()
Start CO task .
void | Stop ()
Stop COtask .
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.

Properties

COMode | Mode [get, set]
CO output mode.
IOTerminal | OutputTerminal [get, set]
Pulse Output Terminal.
COTimebase | Timebase [get, set]
CO's time base.
double | InitialDelay [get, set]
Counter output initial delay in seconds. There are five ticks of the timebase fixed delay in counter internal, so the total delay(s) = InitialDelay + (5 / timebase).
COIdleState | IdleState [get, set]
Idle state when pulse output before start and after stop.
PauseTrigger | Pause [get, set]
Pause Trigger Configuration.
uint | SamplesToUpdate [get, set]
Number of output samples to write, Only valid when Mode is COMode.Finite.
uint | AvaliableLenInSamples [get]
Number of output samples per channel that can be write in buffuer.
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer (per channel). Valid when Mode is NOT COMode.Single.
uint | TransferedPulses [get]
The number of pulses transfered under the current configuration.
COTrigger | Trigger = new COTrigger() [get, set]
CO trigger property configured by CO Trigger().
JY5322ADevice | Device [get]
Device.
COSignalExport | SignalExport [get, set]
Export CO Signal Configuration.

Detailed Description

JY5322AA Counter Output Task.

Constructor & Destructor Documentation

◆ JY5322ACOTask() [1/2]

JY5322A.JY5322ACOTask.JY5322ACOTask | ( | int | slotNum,
 |  | int | channel )

Constructor. Used to create an CO task by a slot number.

Parameters
slotNum | Card slot number.
channel | Counter channel .（5521 5323 support0-1,5322 5324 suppor0）

◆ JY5322ACOTask() [2/2]

JY5322A.JY5322ACOTask.JY5322ACOTask | ( | string | boardName,
 |  | int | channel )

Constructor. Used to create an CO task by a board name.

Parameters
boardName | Board name(device alias), set by device manager
channel | Counter channel （5521 5323 support0-1,5322 5324 suppor0）.

Member Function Documentation

◆ SendSoftwareTrigger()

void JY5322A.JY5322ACOTask.SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5322A.JY5322ACOTask.Start ( )

Start CO task .

◆ Stop()

void JY5322A.JY5322ACOTask.Stop ( )

Stop COtask .

◆ WaitUntilDone()

bool JY5322A.JY5322ACOTask.WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

◆ WriteData()

void JY5322A.JY5322ACOTask.WriteData | ( | COPulse[] | pulsesGroup,
 |  | int | samplesToWrite,
 |  | int | timeout = 10000 )

Write pulse parameters to be output to the buffer. Valid when Mode is NOT COMode.Single. When Mode is COMode.Finite or COMode.ContinuousWrapping, this function can only be called once before starting the task.

Parameters
pulsesGroup | A group of pulse parameters
samplesToWrite | Number of samples to write. If Mode is COMode.ContinuousWrapping, you need to write at least 2 samples before starting the task
timeout | Timeout (ms). Wait until all data is written to buffer or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ WriteSinglePoint()

void JY5322A.JY5322ACOTask.WriteSinglePoint ( COPulse pulse )

Write a single pulse parameter to the register. Valid when Mode is COMode.Single. This function is also available after starting the task when the number of pulses being sent is infinite.

Parameters
pulse Pulse Parameter

Property Documentation

◆ AvaliableLenInSamples

uint JY5322A.JY5322ACOTask.AvaliableLenInSamples
get

Number of output samples per channel that can be write in buffuer.

◆ Device

JY5322ADevice JY5322A.JY5322ACOTask.Device
get

Device.

◆ IdleState

COIdleState JY5322A.JY5322ACOTask.IdleState
getset

Idle state when pulse output before start and after stop.

◆ InitialDelay

double JY5322A.JY5322ACOTask.InitialDelay
getset

Counter output initial delay in seconds. There are five ticks of the timebase fixed delay in counter internal, so the total delay(s) = InitialDelay + (5 / timebase).

◆ Mode

COMode JY5322A.JY5322ACOTask.Mode
getset

CO output mode.

◆ OutputTerminal

IOTerminal JY5322A.JY5322ACOTask.OutputTerminal
getset

Pulse Output Terminal.

◆ Pause

PauseTrigger JY5322A.JY5322ACOTask.Pause
getset

Pause Trigger Configuration.

◆ SamplesToUpdate

uint JY5322A.JY5322ACOTask.SamplesToUpdate
getset

Number of output samples to write, Only valid when Mode is COMode.Finite.

◆ SignalExport

COSignalExport JY5322A.JY5322ACOTask.SignalExport
getset

Export CO Signal Configuration.

◆ Timebase

COTimebase JY5322A.JY5322ACOTask.Timebase
getset

CO's time base.

◆ TransferedPulses

uint JY5322A.JY5322ACOTask.TransferedPulses
get

The number of pulses transfered under the current configuration.

◆ TransferedSamples

ulong JY5322A.JY5322ACOTask.TransferedSamples
get

The number of samples that have been transfered from the local buffer (per channel). Valid when Mode is NOT COMode.Single.

◆ Trigger

COTrigger JY5322A.JY5322ACOTask.Trigger = new COTrigger()
getset

CO trigger property configured by CO Trigger().

The documentation for this class was generated from the following file:
  • JY5322ACOTask.cs


5322A C# API Manual: JY5322A.COTrigger Class Reference

  • COTrigger
Properties | List of all members
JY5322A.COTrigger Class Referencesealed

Constructor to create an COTrigger task object. Used to build CO Trigger. More...

Properties

COTriggerType | Type [get, set]
CO trigger type. enum Immediate/Digital/Soft.
CODigitalTrigger | Digital [get, set]
CO Digital Trigger. Valid when Type is COTriggerType.Digital.

Detailed Description

Constructor to create an COTrigger task object. Used to build CO Trigger.

Property Documentation

◆ Digital

CODigitalTrigger JY5322A.COTrigger.Digital
getset

CO Digital Trigger. Valid when Type is COTriggerType.Digital.

◆ Type

COTriggerType JY5322A.COTrigger.Type
getset

CO trigger type. enum Immediate/Digital/Soft.

The documentation for this class was generated from the following file:
  • JY5322ACOTask.cs


5322A C# API Manual: JY5322A.CODigitalTrigger Class Reference

  • CODigitalTrigger
Properties | List of all members
JY5322A.CODigitalTrigger Class Referencesealed

CO Digital trigger . More...

Properties

CODigitalTriggerSource | Source [get, set]
CO Digital Trigger source.
CODigitalTriggerEdge | Edge [get, set]
Digital Trigger edge，Rising/Falling.

Detailed Description

CO Digital trigger .

Property Documentation

◆ Edge

CODigitalTriggerEdge JY5322A.CODigitalTrigger.Edge
getset

Digital Trigger edge，Rising/Falling.

◆ Source

CODigitalTriggerSource JY5322A.CODigitalTrigger.Source
getset

CO Digital Trigger source.

The documentation for this class was generated from the following file:
  • JY5322ACOTask.cs


5322A C# API Manual: JY5322A.COPulse Class Reference

  • COPulse
Public Member Functions | List of all members
JY5322A.COPulse Class Reference

Pulse Parameter. More...

Public Member Functions

COPulse (COPulseType type, double param1, double param2, int count)
Pulse Parameter.

Detailed Description

Pulse Parameter.

Constructor & Destructor Documentation

◆ COPulse()

JY5322A.COPulse.COPulse | ( | COPulseType | type,
 |  | double | param1,
 |  | double | param2,
 |  | int | count )

Pulse Parameter.

Parameters
type | The pulse type characteristics.
param1 | Parameter 1. Frequency (Hz) when constructed as COPulseType.DutyCycleFrequency; High duration in seconds when constructed as COPulseType.HighLowTime; High ticks of the clock when constructed as COPulseType.HighLowTick.
param2 | Parameter 1. Duty cycle (greater than 0 and less than 1) when constructed as COPulseType.DutyCycleFrequency; Low duration in seconds when constructed as COPulseType.HighLowTime; Low ticks of the clock when constructed as COPulseType.HighLowTick.
count | Number of pulses. When the value is -1 (indicating that the number of pulses is infinite), pulses will be continuously sent until requested to stop.
The documentation for this class was generated from the following file:
  • JY5322ACOTask.cs


5322A C# API Manual: JY5322A.COExternalTimebase Class Reference

  • COExternalTimebase
Properties | List of all members
JY5322A.COExternalTimebase Class Referencesealed

Properties

InputTerminal | Terminal [get, set]
double | Frequency [get, set]

Detailed Description

外部时基配置类

External timebase configuration class

Property Documentation

◆ Frequency

double JY5322A.COExternalTimebase.Frequency
getset

外部时基的频率

Frequency of The External Timebase

◆ Terminal

InputTerminal JY5322A.COExternalTimebase.Terminal
getset

外部时基的输入端口

External Timebase Input Terminal

The documentation for this class was generated from the following file:
  • JY5322ACOTask.cs


5322A C# API Manual: JY5322A.COTimebase Class Reference

  • COTimebase
Properties | List of all members
JY5322A.COTimebase Class Referencesealed

Properties

COTimebaseSource | Source [get, set]
COExternalTimebase | External [get, set]

Detailed Description

时基配置类

Timebase configuration class

Property Documentation

◆ External

COExternalTimebase JY5322A.COTimebase.External
getset

外部时基配置。当 COTimebase.Source 为 COTimebaseSource.External时有效。

External Timebase Configuration. Valid when COTimebase.Source is COTimebaseSource.External.

◆ Source

COTimebaseSource JY5322A.COTimebase.Source
getset

时基源。默认值为 COTimebaseSource.Internal100MHz。

Timebase Source. The default value is COTimebaseSource.Internal100MHz.

The documentation for this class was generated from the following file:
  • JY5322ACOTask.cs


5322A C# API Manual: JY5322A.COSignalExport Class Reference

  • COSignalExport
Public Member Functions | List of all members
JY5322A.COSignalExport Class Reference

CO Signal Export Class. More...

Public Member Functions

void | Add (COSignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (COSignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

CO Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY5322A.COSignalExport.Add | ( | COSignalExportSource | source,
 |  | List< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | CO Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JY5322A.COSignalExport.Add | ( | COSignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | CO Signal Source
destination | Export Desination

◆ Clear()

void JY5322A.COSignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY5322A.COSignalExport.ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • JY5322ACOTask.cs


5322A C# API Manual: JY5322ADITask.cs File Reference

  • File List
Classes | Namespaces | Enumerations
JY5322ADITask.cs File Reference

Classes

class | JY5322A.JY5322ADITask
JY5322AADITask Class. More...
class | JY5322A.DIChannel
DI Channel parameter class . More...
class | JY5322A.DISampleClock
Sample clock configuration class. More...
class | JY5322A.DIExternalSampleClock
External Sample Clock Configuration Class. More...
class | JY5322A.DISignalExport
DI Signal Export Class. More...
class | JY5322A.DITrigger
Constructor to create an DITrigger task object. Used to build DI Trigger. More...
class | JY5322A.DIDigitalTrigger
DI Digital trigger . More...

Namespaces

namespace JY5322A

Enumerations

enum | JY5322A.DISampleClockSource { JY5322A.Internal , JY5322A.External }
DI Sample Clock Source. More...
enum | JY5322A.DIMode { JY5322A.Single = 2 , JY5322A.Finite = 0 , JY5322A.Continuous = 1 }
DIMode. More...
enum | JY5322A.DISignalExportSource { JY5322A.StartTrig = JY5322AImport.JY5322A_DI_StartTrig , JY5322A.ReferenceTrig = JY5322AImport.JY5322A_DI_ReferenceTrig , JY5322A.SampleClock = JY5322AImport.JY5322A_DI_SampleClock }
SourceSignal. More...
enum | JY5322A.DITriggerMode { JY5322A.Start , JY5322A.Reference }
DI Trigger Mode. More...
enum | JY5322A.DITriggerType { JY5322A.Immediate = JY5322AImport.JY5322A_TriggerType_Immediately , JY5322A.Digital = JY5322AImport.JY5322A_TriggerType_Digital , JY5322A.Soft = JY5322AImport.JY5322A_TriggerType_Soft }
TriggerType Digital/Immediate/Soft. More...
enum JY5322A.DIDigitalTriggerSource {
JY5322A.PFI0 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_0 , JY5322A.PFI1 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_1 , JY5322A.PFI2 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_2 , JY5322A.PFI3 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_3 ,
JY5322A.PFI4 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_4 , JY5322A.PFI5 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_5 , JY5322A.PFI6 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_6 , JY5322A.PFI7 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_7 ,
JY5322A.PFI8 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_8 , JY5322A.PFI9 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_9 , JY5322A.PFI10 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_10 , JY5322A.PFI11 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_11 ,
JY5322A.PFI12 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_12 , JY5322A.PFI13 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_13 , JY5322A.PFI14 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_14 , JY5322A.PFI15 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_15 ,
JY5322A.PXI_Trig0 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_0 , JY5322A.PXI_Trig1 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_1 , JY5322A.PXI_Trig2 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_2 , JY5322A.PXI_Trig3 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_3 ,
JY5322A.PXI_Trig4 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_4 , JY5322A.PXI_Trig5 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_5 , JY5322A.PXI_Trig6 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_6 , JY5322A.PXI_Trig7 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_7 ,
JY5322A.AI_StartTrig = JY5322AImport.JY5322A_AI_StartTrig , JY5322A.AI_ReferenceTrig = JY5322AImport.JY5322A_AI_ReferenceTrig , JY5322A.DO_StartTrig = JY5322AImport.JY5322A_DO_StartTrig , JY5322A.CIO_0_StartTrig = JY5322AImport.JY5322A_CIO_0_StartTrig ,
JY5322A.CO_0_Out = JY5322AImport.JY5322A_CO_0_Output
}
DI Digital trigger source. More...
enum | JY5322A.DIDigitalTriggerEdge { JY5322A.Rising , JY5322A.Falling }
DI Digital Trigger Edge. More...


5322A C# API Manual: JY5322A.JY5322ADITask Class Reference

  • JY5322ADITask
Public Member Functions | Properties | List of all members
JY5322A.JY5322ADITask Class Referencesealed

JY5322AADITask Class. More...

Public Member Functions

JY5322ADITask (int slotNum)
Constructor. Used to create an DItask object.
JY5322ADITask (string aliasName)
Constructor. Used to create an DItask object.
void | AddChannel (int lineNum)
Add one line.
void | AddChannel (int[] linesNum)
Add a group of channel.
void | RemoveChannel (int lineNum)
Delete the specified port number .If it is -1, delete all ports.
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Start ()
Start DI task .
void | Stop ()
Stop DI task .
void | ReadSinglePoint (ref bool readValue, int line)
Read one sample for specified channel in register. Available when Mode is DIMode.Single.
void | ReadSinglePoint (ref bool[] readValues)
Read one sample for all ports in register . Available when Mode is DIMode.Single.
void | ReadData (ref ushort[] dataBuffer, uint samplesToAcquire, int timeOut=10000)
Read the short data from all line.
void | ReadData (ref byte[] dataBuffer, uint samplesToAcquire, int timeOut=10000)
Read Data.
void | ReadData (ref byte[,] dataBuffer, uint samplesToAcquire, int timeOut=10000)
Read Data.

Properties

JY5322ADevice | Device [get]
Device Handle.
List< DIChannel > | Channels [get]
List of DI channels.
DIMode | Mode [get, set]
DI acquisition mode，support Single/ Finite/Continuous.
double | SampleRate [get, set]
Sample rate per channel. Maximum sample rate is 10M The defalut sample rate = 10k You can read this property to obtain the sample rate that will actually take effect in the current configuration.
int | SamplesToAcquire [get, set]
Number of samples to be read per channel. Only valid when Mode is DIMode.Finite.
DISampleClock | SampleClock [get, set]
DI Sample Clock Configuration.
int | BufLenInSamples [get]
Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.
ulong | AvailableSamples [get]
Number of samples per channel that can be read in the buffer.
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer (per channel). Valid when Mode is NOT DIMode.Single.
DITrigger | Trigger [get, set]
DI Trigger Configuration.
DISignalExport | SignalExport [get, set]
Export DI Signal.

Detailed Description

JY5322AADITask Class.

Constructor & Destructor Documentation

◆ JY5322ADITask() [1/2]

JY5322A.JY5322ADITask.JY5322ADITask ( int slotNum )

Constructor. Used to create an DItask object.

Parameters
slotNum Card slot number

◆ JY5322ADITask() [2/2]

JY5322A.JY5322ADITask.JY5322ADITask ( string aliasName )

Constructor. Used to create an DItask object.

Parameters
aliasName AliasName

Member Function Documentation

◆ AddChannel() [1/2]

void JY5322A.JY5322ADITask.AddChannel ( int lineNum )

Add one line.

Parameters
lineNum
Exceptions
JYDriverException

◆ AddChannel() [2/2]

void JY5322A.JY5322ADITask.AddChannel ( int[] linesNum )

Add a group of channel.

Parameters
linesNum an array of line numbers of added ports.

◆ ReadData() [1/3]

void JY5322A.JY5322ADITask.ReadData | ( | ref byte | dataBuffer[,],
 |  | uint | samplesToAcquire,
 |  | int | timeOut = 10000 )

Read Data.

Parameters
dataBuffer | Data buffer
samplesToAcquire | Number of samples per line to be read
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadData() [2/3]

void JY5322A.JY5322ADITask.ReadData | ( | ref byte[] | dataBuffer,
 |  | uint | samplesToAcquire,
 |  | int | timeOut = 10000 )

Read Data.

Parameters
dataBuffer | Data buffer
samplesToAcquire | Number of samples per line to be read
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadData() [3/3]

void JY5322A.JY5322ADITask.ReadData | ( | ref ushort[] | dataBuffer,
 |  | uint | samplesToAcquire,
 |  | int | timeOut = 10000 )

Read the short data from all line.

Parameters
dataBuffer | Data buffer
samplesToAcquire | Number of samples per port to be read
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadSinglePoint() [1/2]

void JY5322A.JY5322ADITask.ReadSinglePoint | ( | ref bool | readValue,
 |  | int | line )

Read one sample for specified channel in register. Available when Mode is DIMode.Single.

Parameters
readValue | values read,. Buffer size >= 8
line | Each line is independently controlled. You can directly obtain the corresponding status based on the input of the corresponding line number

◆ ReadSinglePoint() [2/2]

void JY5322A.JY5322ADITask.ReadSinglePoint ( ref bool[] readValues )

Read one sample for all ports in register . Available when Mode is DIMode.Single.

Parameters
readValues Values read. Buffer size >= number of ports * 16.

◆ RemoveChannel()

void JY5322A.JY5322ADITask.RemoveChannel ( int lineNum )

Delete the specified port number .If it is -1, delete all ports.

Parameters
lineNum port number to be delete.

◆ SendSoftwareTrigger()

void JY5322A.JY5322ADITask.SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5322A.JY5322ADITask.Start ( )

Start DI task .

◆ Stop()

void JY5322A.JY5322ADITask.Stop ( )

Stop DI task .

Property Documentation

◆ AvailableSamples

ulong JY5322A.JY5322ADITask.AvailableSamples
get

Number of samples per channel that can be read in the buffer.

◆ BufLenInSamples

int JY5322A.JY5322ADITask.BufLenInSamples
get

Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.

◆ Channels

List<DIChannel> JY5322A.JY5322ADITask.Channels
get

List of DI channels.

◆ Device

JY5322ADevice JY5322A.JY5322ADITask.Device
get

Device Handle.

◆ Mode

DIMode JY5322A.JY5322ADITask.Mode
getset

DI acquisition mode，support Single/ Finite/Continuous.

◆ SampleClock

DISampleClock JY5322A.JY5322ADITask.SampleClock
getset

DI Sample Clock Configuration.

◆ SampleRate

double JY5322A.JY5322ADITask.SampleRate
getset

Sample rate per channel. Maximum sample rate is 10M The defalut sample rate = 10k You can read this property to obtain the sample rate that will actually take effect in the current configuration.

◆ SamplesToAcquire

int JY5322A.JY5322ADITask.SamplesToAcquire
getset

Number of samples to be read per channel. Only valid when Mode is DIMode.Finite.

◆ SignalExport

DISignalExport JY5322A.JY5322ADITask.SignalExport
getset

Export DI Signal.

◆ TransferedSamples

ulong JY5322A.JY5322ADITask.TransferedSamples
get

The number of samples that have been transfered from the local buffer (per channel). Valid when Mode is NOT DIMode.Single.

◆ Trigger

DITrigger JY5322A.JY5322ADITask.Trigger
getset

DI Trigger Configuration.

The documentation for this class was generated from the following file:
  • JY5322ADITask.cs


5322A C# API Manual: JY5322A.DIChannel Class Reference

  • DIChannel
Properties | List of all members
JY5322A.DIChannel Class Referencesealed

DI Channel parameter class . More...

Properties

int LineNum [get, set]
Line number.

Detailed Description

DI Channel parameter class .

Property Documentation

◆ LineNum

int JY5322A.DIChannel.LineNum
getset

Line number.

The documentation for this class was generated from the following file:
  • JY5322ADITask.cs


5322A C# API Manual: JY5322A.DISampleClock Class Reference

  • DISampleClock
Properties | List of all members
JY5322A.DISampleClock Class Reference

Sample clock configuration class. More...

Properties

DISampleClockSource | Source [get, set]
Clock Source. enum Internal/External.
DIExternalSampleClock | External [get, set]
External Sample Clock, Valid when Source is DISampleClockSource.External.

Detailed Description

Sample clock configuration class.

Property Documentation

◆ External

DIExternalSampleClock JY5322A.DISampleClock.External
getset

External Sample Clock, Valid when Source is DISampleClockSource.External.

◆ Source

DISampleClockSource JY5322A.DISampleClock.Source
getset

Clock Source. enum Internal/External.

The documentation for this class was generated from the following file:
  • JY5322ADITask.cs


5322A C# API Manual: JY5322A.DIExternalSampleClock Class Reference

  • DIExternalSampleClock
Properties | List of all members
JY5322A.DIExternalSampleClock Class Reference

External Sample Clock Configuration Class. More...

Properties

ClockTerminal | Terminal [get, set]
External Sample Clock Input Terminal.
double | ExpectedRate [get, set]
Expected External Sample Clock Rate.

Detailed Description

External Sample Clock Configuration Class.

Property Documentation

◆ ExpectedRate

double JY5322A.DIExternalSampleClock.ExpectedRate
getset

Expected External Sample Clock Rate.

◆ Terminal

ClockTerminal JY5322A.DIExternalSampleClock.Terminal
getset

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • JY5322ADITask.cs


5322A C# API Manual: JY5322A.DISignalExport Class Reference

  • DISignalExport
Public Member Functions | List of all members
JY5322A.DISignalExport Class Reference

DI Signal Export Class. More...

Public Member Functions

void | Add (DISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (DISignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

DI Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY5322A.DISignalExport.Add | ( | DISignalExportSource | source,
 |  | List< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | DI Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JY5322A.DISignalExport.Add | ( | DISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | DI Signal Source
destination | Export Desination

◆ Clear()

void JY5322A.DISignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY5322A.DISignalExport.ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • JY5322ADITask.cs


5322A C# API Manual: JY5322A.DITrigger Class Reference

  • DITrigger
Properties | List of all members
JY5322A.DITrigger Class Referencesealed

Constructor to create an DITrigger task object. Used to build DI Trigger. More...

Properties

DITriggerType | Type [get, set]
DI trigger type. enum Digital/Immediate/Soft.
DITriggerMode | Mode [get, set]
DI trigger mode. enum Start/Reference.
DIDigitalTrigger | Digital [get, set]
DI Digital Trigger.Valid when Type is DITriggerType.Digital.
uint | PreTriggerSamples [get, set]
Pretrigger Samples, must be less than or equal to JY5322ADITask.SamplesToAcquire. Valid when Mode is DITriggerMode.Reference. Pretrigger samples, must be greater than 1. Valid when Type is DITriggerType.Digital.

Detailed Description

Constructor to create an DITrigger task object. Used to build DI Trigger.

Property Documentation

◆ Digital

DIDigitalTrigger JY5322A.DITrigger.Digital
getset

DI Digital Trigger.Valid when Type is DITriggerType.Digital.

◆ Mode

DITriggerMode JY5322A.DITrigger.Mode
getset

DI trigger mode. enum Start/Reference.

◆ PreTriggerSamples

uint JY5322A.DITrigger.PreTriggerSamples
getset

Pretrigger Samples, must be less than or equal to JY5322ADITask.SamplesToAcquire. Valid when Mode is DITriggerMode.Reference. Pretrigger samples, must be greater than 1. Valid when Type is DITriggerType.Digital.

◆ Type

DITriggerType JY5322A.DITrigger.Type
getset

DI trigger type. enum Digital/Immediate/Soft.

The documentation for this class was generated from the following file:
  • JY5322ADITask.cs


5322A C# API Manual: JY5322A.DIDigitalTrigger Class Reference

  • DIDigitalTrigger
Properties | List of all members
JY5322A.DIDigitalTrigger Class Referencesealed

DI Digital trigger . More...

Properties

DIDigitalTriggerSource | Source [get, set]
DI Digital Trigger source.
DIDigitalTriggerEdge | Edge [get, set]
Digital Trigger edge，Rising/Falling.

Detailed Description

DI Digital trigger .

Property Documentation

◆ Edge

DIDigitalTriggerEdge JY5322A.DIDigitalTrigger.Edge
getset

Digital Trigger edge，Rising/Falling.

◆ Source

DIDigitalTriggerSource JY5322A.DIDigitalTrigger.Source
getset

DI Digital Trigger source.

The documentation for this class was generated from the following file:
  • JY5322ADITask.cs


5322A C# API Manual: JY5322ADOTask.cs File Reference

  • File List
Classes | Namespaces | Enumerations
JY5322ADOTask.cs File Reference

Classes

class | JY5322A.JY5322ADOTask
JY5322AA Digital Output Task. More...
class | JY5322A.DOChannel
DO Channel parameter class . More...
class | JY5322A.DOSampleClock
Sample clock configuration class. More...
class | JY5322A.DOExternalSampleClock
External Sample Clock Configuration Class. More...
class | JY5322A.DOTrigger
Constructor to create an DOTrigger task object. Used to build DO Trigger. More...
class | JY5322A.DODigitalTrigger
DO Digital trigger. More...
class | JY5322A.DOSignalExport
DO Signal Export Class. More...

Namespaces

namespace JY5322A

Enumerations

enum | JY5322A.DOSampleClockSource { JY5322A.Internal , JY5322A.External }
DO Sample Clock Source. More...
enum | JY5322A.DOMode { JY5322A.Single = 3 , JY5322A.Finite = 0 , JY5322A.ContinuousWrapping = 1 , JY5322A.ContinuousNoWrapping = 2 }
DOMode. More...
enum | JY5322A.DODigitalTriggerEdge { JY5322A.Rising , JY5322A.Falling }
DO Digital Trigger Edge. More...
enum JY5322A.DODigitalTriggerSource {
JY5322A.PFI0 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_0 , JY5322A.PFI1 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_1 , JY5322A.PFI2 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_2 , JY5322A.PFI3 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_3 ,
JY5322A.PFI4 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_4 , JY5322A.PFI5 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_5 , JY5322A.PFI6 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_6 , JY5322A.PFI7 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_7 ,
JY5322A.PFI8 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_8 , JY5322A.PFI9 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_9 , JY5322A.PFI10 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_10 , JY5322A.PFI11 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_11 ,
JY5322A.PFI12 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_12 , JY5322A.PFI13 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_13 , JY5322A.PFI14 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_14 , JY5322A.PFI15 = JY5322AImport.JY5322A_DigitalTriggerSource_PFI_15 ,
JY5322A.PXI_Trig0 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_0 , JY5322A.PXI_Trig1 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_1 , JY5322A.PXI_Trig2 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_2 , JY5322A.PXI_Trig3 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_3 ,
JY5322A.PXI_Trig4 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_4 , JY5322A.PXI_Trig5 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_5 , JY5322A.PXI_Trig6 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_6 , JY5322A.PXI_Trig7 = JY5322AImport.JY5322A_DigitalTriggerSource_PXI_7 ,
JY5322A.AI_StartTrig = JY5322AImport.JY5322A_AI_StartTrig , JY5322A.AI_ReferenceTrig = JY5322AImport.JY5322A_AI_ReferenceTrig , JY5322A.DI_StartTrig = JY5322AImport.JY5322A_DI_StartTrig , JY5322A.DI_ReferenceTrig = JY5322AImport.JY5322A_DI_ReferenceTrig ,
JY5322A.CIO_0_StartTrig = JY5322AImport.JY5322A_CIO_0_StartTrig , JY5322A.CO_0_Out = JY5322AImport.JY5322A_Inter_CO_0_Output
}
DO Digital trigger source. More...
enum | JY5322A.DOTriggerType { JY5322A.Immediate = JY5322AImport.JY5322A_TriggerType_Immediately , JY5322A.Digital = JY5322AImport.JY5322A_TriggerType_Digital , JY5322A.Soft = JY5322AImport.JY5322A_TriggerType_Soft }
TriggerType Digital/Immediate/Soft. More...
enum | JY5322A.DOSignalExportSource { JY5322A.StartTrig = JY5322AImport.JY5322A_DO_StartTrig , JY5322A.SampleClock = JY5322AImport.JY5322A_DO_SampleClock }
SourceSignal. More...
enum | JY5322A.OutputCompleteState { JY5322A.Zero , JY5322A.Hold }
Output Complete State. More...


5322A C# API Manual: JY5322A.JY5322ADOTask Class Reference

  • JY5322ADOTask
Public Member Functions | Properties | List of all members
JY5322A.JY5322ADOTask Class Referencesealed

JY5322AA Digital Output Task. More...

Public Member Functions

JY5322ADOTask (int slotNum)
Constructor. Used to create an DOtask by a slot number.
JY5322ADOTask (string boardName)
Constructor. Used to create an DO task by a board name.
void | AddChannel (int lineNum)
Add one channel.
void | AddChannel (int[] linesNum)
Add a group of channels.
void | RemoveChannel (int lineNum)
Delete the specified port number .If it is -1, delete all ports.
void | Start ()
Start DO task .
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Stop ()
Stop DO task .
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete. Available when Mode is DOMode.Finite.
void | WriteSinglePoint (bool writeValue, int line)
Write one sample to the specified port in register.Available when Mode is DOMode.Single.
void | WriteSinglePoint (bool[] writeValues)
write one sample to all ports in register . Available when Mode is DOMode.Single
void | WriteData (ushort[] dataBuffer, uint samplesToUpdate, int timeOut=10000)
Write the ushort data from one line or multi-lines. There are a total of 16 lines from 0 to 15. Each bit from low to high represents one line.
void | WriteData (byte[] dataBuffer, uint samplesToUpdate, int timeOut=10000)
Wirte the byte data to specified line.
void | WriteData (byte[,] dataBuffer, uint samplesToUpdate, int timeOut=10000)
Write the line byte data to the lines. Each line represents one line.

Properties

List< DOChannel > | Channels [get]
List of DO channels,32个line.
DOMode | Mode [get, set]
DO acquisition mode.Select DO Mode from enum:ContinuousNoWrapping/ContinuousWrapping/Finite/Single.
double | UpdateRate [get, set]
Update rate per channel. Maximum update rate is 10M . The defalut sample rate = 10000 You can read this property to obtain the update rate that will actually take effect in the current configuration.
int | SamplesToUpdate [get, set]
Number of output samples to write per channel , Only valid when Mode is DOMode.Finite.
DOSampleClock | SampleClock [get, set]
DO Sample Clock Configuration .
int | BufLenInSamples [get]
Number of samples per channel can be storage in the buffer, the PropretySamplesToUpdate must be less than or equal to this value.
uint | AvaliableLenInSamples [get]
Number of output samples per channel avaliable to write in DO buffuer.
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer (per channel). Valid when Mode is NOT DOMode.Single.
OutputCompleteState | CompleteState [get, set]
DO Output Complete State, Valid when Mode is NOT DOMode.Single.Default is Zero.
DOTrigger | Trigger [get, set]
DO Trigger Configuration.
DOSignalExport | SignalExport [get, set]
Export DO Signal.
JY5322ADevice | Device [get]
Device.

Detailed Description

JY5322AA Digital Output Task.

Constructor & Destructor Documentation

◆ JY5322ADOTask() [1/2]

JY5322A.JY5322ADOTask.JY5322ADOTask ( int slotNum )

Constructor. Used to create an DOtask by a slot number.

Parameters
slotNum Card slot number.

◆ JY5322ADOTask() [2/2]

JY5322A.JY5322ADOTask.JY5322ADOTask ( string boardName )

Constructor. Used to create an DO task by a board name.

Parameters
boardName Board name(device alias), set by device manager

Member Function Documentation

◆ AddChannel() [1/2]

void JY5322A.JY5322ADOTask.AddChannel ( int lineNum )

Add one channel.

Parameters
lineNum port number to be added.

◆ AddChannel() [2/2]

void JY5322A.JY5322ADOTask.AddChannel ( int[] linesNum )

Add a group of channels.

Parameters
linesNum an array of port numbers of added ports.

◆ RemoveChannel()

void JY5322A.JY5322ADOTask.RemoveChannel ( int lineNum )

Delete the specified port number .If it is -1, delete all ports.

Parameters
lineNum port number to be delete.

◆ SendSoftwareTrigger()

void JY5322A.JY5322ADOTask.SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5322A.JY5322ADOTask.Start ( )

Start DO task .

◆ Stop()

void JY5322A.JY5322ADOTask.Stop ( )

Stop DO task .

◆ WaitUntilDone()

bool JY5322A.JY5322ADOTask.WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete. Available when Mode is DOMode.Finite.

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

◆ WriteData() [1/3]

void JY5322A.JY5322ADOTask.WriteData | ( | byte | dataBuffer[,],
 |  | uint | samplesToUpdate,
 |  | int | timeOut = 10000 )

Write the line byte data to the lines. Each line represents one line.

Parameters
dataBuffer | Data buffer
samplesToUpdate | Number of samples per line to be write
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteData() [2/3]

void JY5322A.JY5322ADOTask.WriteData | ( | byte[] | dataBuffer,
 |  | uint | samplesToUpdate,
 |  | int | timeOut = 10000 )

Wirte the byte data to specified line.

Parameters
dataBuffer | Data buffer
samplesToUpdate | Number of samples per line to be write
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteData() [3/3]

void JY5322A.JY5322ADOTask.WriteData | ( | ushort[] | dataBuffer,
 |  | uint | samplesToUpdate,
 |  | int | timeOut = 10000 )

Write the ushort data from one line or multi-lines. There are a total of 16 lines from 0 to 15. Each bit from low to high represents one line.

Parameters
dataBuffer | Data buffer
samplesToUpdate | Number of samples per line to be write
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteSinglePoint() [1/2]

void JY5322A.JY5322ADOTask.WriteSinglePoint | ( | bool | writeValue,
 |  | int | line )

Write one sample to the specified port in register.Available when Mode is DOMode.Single.

Parameters
writeValue | Write values.Buffer size >= 16
line | Specified port.

◆ WriteSinglePoint() [2/2]

void JY5322A.JY5322ADOTask.WriteSinglePoint ( bool[] writeValues )

write one sample to all ports in register . Available when Mode is DOMode.Single

Parameters
writeValues Data to be written.Buffer size >= number of lines。

Property Documentation

◆ AvaliableLenInSamples

uint JY5322A.JY5322ADOTask.AvaliableLenInSamples
get

Number of output samples per channel avaliable to write in DO buffuer.

◆ BufLenInSamples

int JY5322A.JY5322ADOTask.BufLenInSamples
get

Number of samples per channel can be storage in the buffer, the PropretySamplesToUpdate must be less than or equal to this value.

◆ Channels

List<DOChannel> JY5322A.JY5322ADOTask.Channels
get

List of DO channels,32个line.

◆ CompleteState

OutputCompleteState JY5322A.JY5322ADOTask.CompleteState
getset

DO Output Complete State, Valid when Mode is NOT DOMode.Single.Default is Zero.

◆ Device

JY5322ADevice JY5322A.JY5322ADOTask.Device
get

Device.

◆ Mode

DOMode JY5322A.JY5322ADOTask.Mode
getset

DO acquisition mode.Select DO Mode from enum:ContinuousNoWrapping/ContinuousWrapping/Finite/Single.

◆ SampleClock

DOSampleClock JY5322A.JY5322ADOTask.SampleClock
getset

DO Sample Clock Configuration .

◆ SamplesToUpdate

int JY5322A.JY5322ADOTask.SamplesToUpdate
getset

Number of output samples to write per channel , Only valid when Mode is DOMode.Finite.

◆ SignalExport

DOSignalExport JY5322A.JY5322ADOTask.SignalExport
getset

Export DO Signal.

◆ TransferedSamples

ulong JY5322A.JY5322ADOTask.TransferedSamples
get

The number of samples that have been transfered from the local buffer (per channel). Valid when Mode is NOT DOMode.Single.

◆ Trigger

DOTrigger JY5322A.JY5322ADOTask.Trigger
getset

DO Trigger Configuration.

◆ UpdateRate

double JY5322A.JY5322ADOTask.UpdateRate
getset

Update rate per channel. Maximum update rate is 10M . The defalut sample rate = 10000 You can read this property to obtain the update rate that will actually take effect in the current configuration.

The documentation for this class was generated from the following file:
  • JY5322ADOTask.cs


5322A C# API Manual: JY5322A.DOChannel Class Reference

  • DOChannel
Properties | List of all members
JY5322A.DOChannel Class Referencesealed

DO Channel parameter class . More...

Properties

int LineNum [get, set]
port number.

Detailed Description

DO Channel parameter class .

Property Documentation

◆ LineNum

int JY5322A.DOChannel.LineNum
getset

port number.

The documentation for this class was generated from the following file:
  • JY5322ADOTask.cs


5322A C# API Manual: JY5322A.DOSampleClock Class Reference

  • DOSampleClock
Properties | List of all members
JY5322A.DOSampleClock Class Reference

Sample clock configuration class. More...

Properties

DOSampleClockSource | Source [get, set]
Clock Source. enum Internal/External.
DOExternalSampleClock | External [get, set]
External Sample Clock.Valid when Source is DOSampleClockSource.External.

Detailed Description

Sample clock configuration class.

Property Documentation

◆ External

DOExternalSampleClock JY5322A.DOSampleClock.External
getset

External Sample Clock.Valid when Source is DOSampleClockSource.External.

◆ Source

DOSampleClockSource JY5322A.DOSampleClock.Source
getset

Clock Source. enum Internal/External.

The documentation for this class was generated from the following file:
  • JY5322ADOTask.cs


5322A C# API Manual: JY5322A.DOExternalSampleClock Class Reference

  • DOExternalSampleClock
Properties | List of all members
JY5322A.DOExternalSampleClock Class Reference

External Sample Clock Configuration Class. More...

Properties

ClockTerminal | Terminal [get, set]
External Sample Clock Input Terminal.
double | ExpectedRate [get, set]
Expected External Sample Clock Rate.

Detailed Description

External Sample Clock Configuration Class.

Property Documentation

◆ ExpectedRate

double JY5322A.DOExternalSampleClock.ExpectedRate
getset

Expected External Sample Clock Rate.

◆ Terminal

ClockTerminal JY5322A.DOExternalSampleClock.Terminal
getset

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • JY5322ADOTask.cs


5322A C# API Manual: JY5322A.DOTrigger Class Reference

  • DOTrigger
Properties | List of all members
JY5322A.DOTrigger Class Referencesealed

Constructor to create an DOTrigger task object. Used to build DO Trigger. More...

Properties

DOTriggerType | Type [get, set]
DO trigger type. enum Digital/Immediate/Soft.
DODigitalTrigger | Digital [get, set]
DO Digital Trigger.Valid when Type is DOTriggerType.Digital.

Detailed Description

Constructor to create an DOTrigger task object. Used to build DO Trigger.

Property Documentation

◆ Digital

DODigitalTrigger JY5322A.DOTrigger.Digital
getset

DO Digital Trigger.Valid when Type is DOTriggerType.Digital.

◆ Type

DOTriggerType JY5322A.DOTrigger.Type
getset

DO trigger type. enum Digital/Immediate/Soft.

The documentation for this class was generated from the following file:
  • JY5322ADOTask.cs


5322A C# API Manual: JY5322A.DODigitalTrigger Class Reference

  • DODigitalTrigger
Properties | List of all members
JY5322A.DODigitalTrigger Class Referencesealed

DO Digital trigger. More...

Properties

DODigitalTriggerSource | Source [get, set]
DO Digital Trigger source.
DODigitalTriggerEdge | Edge [get, set]
Digital Trigger edge，Rising/Falling.

Detailed Description

DO Digital trigger.

Property Documentation

◆ Edge

DODigitalTriggerEdge JY5322A.DODigitalTrigger.Edge
getset

Digital Trigger edge，Rising/Falling.

◆ Source

DODigitalTriggerSource JY5322A.DODigitalTrigger.Source
getset

DO Digital Trigger source.

The documentation for this class was generated from the following file:
  • JY5322ADOTask.cs


5322A C# API Manual: JY5322A.DOSignalExport Class Reference

  • DOSignalExport
Public Member Functions | List of all members
JY5322A.DOSignalExport Class Reference

DO Signal Export Class. More...

Public Member Functions

void | Add (DOSignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (DOSignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

DO Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY5322A.DOSignalExport.Add | ( | DOSignalExportSource | source,
 |  | List< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | DO Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JY5322A.DOSignalExport.Add | ( | DOSignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | DO Signal Source
destination | Export Desination

◆ Clear()

void JY5322A.DOSignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY5322A.DOSignalExport.ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • JY5322ADOTask.cs


5322A C# API Manual: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
N JY5322A |
C JY5322AAITask | JY5322AA Analog Input Task
C AIChannel | AI Channel parameter class
C ScalingCoefficients | 将原始Raw数据转换为工程单位（电压值）的换算因子。
C AISampleClock | Sample clock configuration class
C AIExternalSampleClock | External Sample Clock Configuration Class
C AITrigger | AI Trigger class
C AIAnalogHysteresisComparator | AI Analog Hysteresis Comparator
C AIAnalogWindowComparator | AI Analog Window Comparator
C AIAnalogEdgeComparator | AI Analog Edge Comparator
C AIAnalogTrigger | AI Analog Trigger
C AIAnalogMultichannelComparator | AI Analog Multichannel Trigger/Comparator
C AIAnalogMultichannelHysteresisComparator | AI Analog Multichannel Hysteresis Comparator
C AIAnalogMultichannelHysteresisComparatorSource | AI Analog Multichannel Hysteresis Comparator Source
C AIAnalogMultichannelWindowComparator | AI Analog Multichannel Window Comparator
C AIAnalogMultichannelWindowComparatorSource | AI Analog Multichannel Window Comparator Source
C AIAnalogMultichannelEdgeComparator | AI Analog Multichannel Edge Comparator
C AIAnalogMultichannelEdgeComparatorSource | AI Analog Multichannel Edge Comparator Source
C AIDigitalTrigger | AI Digital Trigger
C AIRecord | AI Record class
C AIAdvanced | AI Advance parameter
C AISamplingInfo | AI Sampling information
C DSMode | DS Mode Class Paraments
C AISignalExport | Signal Export Class
C JY5322ACITask | JY5322A Counter Input Task
C CISampleClock | CI Sample Clock class
C CIInternalSampleClock | CI Internal Sample Clock Configuration Class
C CIImplicitSampleClock | CI Implicit Sample Clock class
C CIExternalSampleClock | CI Implicit Sample Clock class
C CIExternalTimebase |
C CITimebase |
C EdgeCounting | Configure CI EdgeCounting
C EdgeCountingOutEvent | Edge counting output event configuration class
C PauseTrigger | Pause trigger configuration class
C FrequencyMeas | Configure CI Measure
C PeriodMeas | Configure CI Measure
C PulseMeas | Configure CI Measure
C SemiPeriodMeas | Configure CI Measure
C TwoEdgeSeparation | Configure CI Measure
C QuadEncoder | Configure CI Measure
C TwoPulseEncoder | Configure CI Measure
C CITrigger | Constructor to create an CITrigger task object. Used to build CI Trigger
C CIDigitalTrigger | CI Digital trigger
C CISignalExport | CI Signal Export Class
C JY5322ACOTask | JY5322AA Counter Output Task
C COTrigger | Constructor to create an COTrigger task object. Used to build CO Trigger
C CODigitalTrigger | CO Digital trigger
C COPulse | Pulse Parameter
C COExternalTimebase |
C COTimebase |
C COSignalExport | CO Signal Export Class
C JY5322ADITask | JY5322AADITask Class
C DIChannel | DI Channel parameter class
C DISampleClock | Sample clock configuration class
C DIExternalSampleClock | External Sample Clock Configuration Class
C DISignalExport | DI Signal Export Class
C DITrigger | Constructor to create an DITrigger task object. Used to build DI Trigger
C DIDigitalTrigger | DI Digital trigger
C JY5322ADOTask | JY5322AA Digital Output Task
C DOChannel | DO Channel parameter class
C DOSampleClock | Sample clock configuration class
C DOExternalSampleClock | External Sample Clock Configuration Class
C DOTrigger | Constructor to create an DOTrigger task object. Used to build DO Trigger
C DODigitalTrigger | DO Digital trigger
C DOSignalExport | DO Signal Export Class


5322A C# API Manual: Member List

  • AIAdvanced
JY5322A.AIAdvanced Member List

This is the complete list of members for JY5322A.AIAdvanced, including all inherited members.

DSMode | JY5322A.AIAdvanced
RawDataWidth | JY5322A.AIAdvanced


5322A C# API Manual: Member List

  • AIAnalogEdgeComparator
JY5322A.AIAnalogEdgeComparator Member List

This is the complete list of members for JY5322A.AIAnalogEdgeComparator, including all inherited members.

Slope | JY5322A.AIAnalogEdgeComparator
Threshold | JY5322A.AIAnalogEdgeComparator


5322A C# API Manual: Member List

  • AIAnalogHysteresisComparator
JY5322A.AIAnalogHysteresisComparator Member List

This is the complete list of members for JY5322A.AIAnalogHysteresisComparator, including all inherited members.

HighThreshold | JY5322A.AIAnalogHysteresisComparator
LowThreshold | JY5322A.AIAnalogHysteresisComparator
Slope | JY5322A.AIAnalogHysteresisComparator


5322A C# API Manual: Member List

  • AIAnalogMultichannelComparator
JY5322A.AIAnalogMultichannelComparator Member List

This is the complete list of members for JY5322A.AIAnalogMultichannelComparator, including all inherited members.

AIAnalogMultichannelComparator() | JY5322A.AIAnalogMultichannelComparator
Comparator | JY5322A.AIAnalogMultichannelComparator
Edge | JY5322A.AIAnalogMultichannelComparator
Hysteresis | JY5322A.AIAnalogMultichannelComparator
Logic | JY5322A.AIAnalogMultichannelComparator
Window | JY5322A.AIAnalogMultichannelComparator


5322A C# API Manual: Member List

  • AIAnalogMultichannelEdgeComparator
JY5322A.AIAnalogMultichannelEdgeComparator Member List

This is the complete list of members for JY5322A.AIAnalogMultichannelEdgeComparator, including all inherited members.

Add(AIAnalogTriggerSource source, AIAnalogTriggerEdge slope, double threshold) | JY5322A.AIAnalogMultichannelEdgeComparator
AIAnalogMultichannelEdgeComparator() | JY5322A.AIAnalogMultichannelEdgeComparator
Clear() | JY5322A.AIAnalogMultichannelEdgeComparator
Sources | JY5322A.AIAnalogMultichannelEdgeComparator


5322A C# API Manual: Member List

  • AIAnalogMultichannelEdgeComparatorSource
JY5322A.AIAnalogMultichannelEdgeComparatorSource Member List

This is the complete list of members for JY5322A.AIAnalogMultichannelEdgeComparatorSource, including all inherited members.

AIAnalogMultichannelEdgeComparatorSource() | JY5322A.AIAnalogMultichannelEdgeComparatorSource
AIAnalogMultichannelEdgeComparatorSource(AIAnalogTriggerSource source, AIAnalogTriggerEdge slope, double threshold) | JY5322A.AIAnalogMultichannelEdgeComparatorSource
Slope | JY5322A.AIAnalogMultichannelEdgeComparatorSource
Source | JY5322A.AIAnalogMultichannelEdgeComparatorSource
Threshold | JY5322A.AIAnalogMultichannelEdgeComparatorSource


5322A C# API Manual: Member List

  • AIAnalogMultichannelHysteresisComparator
JY5322A.AIAnalogMultichannelHysteresisComparator Member List

This is the complete list of members for JY5322A.AIAnalogMultichannelHysteresisComparator, including all inherited members.

Add(AIAnalogTriggerSource source, AIAnalogTriggerEdge slope, double highThreshold, double lowThreshold) | JY5322A.AIAnalogMultichannelHysteresisComparator
AIAnalogMultichannelHysteresisComparator() | JY5322A.AIAnalogMultichannelHysteresisComparator
Clear() | JY5322A.AIAnalogMultichannelHysteresisComparator
Sources | JY5322A.AIAnalogMultichannelHysteresisComparator


5322A C# API Manual: Member List

  • AIAnalogMultichannelHysteresisComparatorSource
JY5322A.AIAnalogMultichannelHysteresisComparatorSource Member List

This is the complete list of members for JY5322A.AIAnalogMultichannelHysteresisComparatorSource, including all inherited members.

AIAnalogMultichannelHysteresisComparatorSource() | JY5322A.AIAnalogMultichannelHysteresisComparatorSource
AIAnalogMultichannelHysteresisComparatorSource(AIAnalogTriggerSource source, AIAnalogTriggerEdge slope, double highThreshold, double lowThreshold) | JY5322A.AIAnalogMultichannelHysteresisComparatorSource
HighThreshold | JY5322A.AIAnalogMultichannelHysteresisComparatorSource
LowThreshold | JY5322A.AIAnalogMultichannelHysteresisComparatorSource
Slope | JY5322A.AIAnalogMultichannelHysteresisComparatorSource
Source | JY5322A.AIAnalogMultichannelHysteresisComparatorSource


5322A C# API Manual: Member List

  • AIAnalogMultichannelWindowComparator
JY5322A.AIAnalogMultichannelWindowComparator Member List

This is the complete list of members for JY5322A.AIAnalogMultichannelWindowComparator, including all inherited members.

Add(AIAnalogTriggerSource source, AIAnalogWindowCondition condition, double highThreshold, double lowThreshold) | JY5322A.AIAnalogMultichannelWindowComparator
AIAnalogMultichannelWindowComparator() | JY5322A.AIAnalogMultichannelWindowComparator
Clear() | JY5322A.AIAnalogMultichannelWindowComparator
Sources | JY5322A.AIAnalogMultichannelWindowComparator


5322A C# API Manual: Member List

  • AIAnalogMultichannelWindowComparatorSource
JY5322A.AIAnalogMultichannelWindowComparatorSource Member List

This is the complete list of members for JY5322A.AIAnalogMultichannelWindowComparatorSource, including all inherited members.

AIAnalogMultichannelWindowComparatorSource(AIAnalogTriggerSource source, AIAnalogWindowCondition condition, double highThreshold, double lowThreshold) | JY5322A.AIAnalogMultichannelWindowComparatorSource
Condition | JY5322A.AIAnalogMultichannelWindowComparatorSource
HighThreshold | JY5322A.AIAnalogMultichannelWindowComparatorSource
LowThreshold | JY5322A.AIAnalogMultichannelWindowComparatorSource
Source | JY5322A.AIAnalogMultichannelWindowComparatorSource


5322A C# API Manual: Member List

  • AIAnalogTrigger
JY5322A.AIAnalogTrigger Member List

This is the complete list of members for JY5322A.AIAnalogTrigger, including all inherited members.

AIAnalogTrigger() | JY5322A.AIAnalogTrigger
Comparator | JY5322A.AIAnalogTrigger
Edge | JY5322A.AIAnalogTrigger
Hysteresis | JY5322A.AIAnalogTrigger
Source | JY5322A.AIAnalogTrigger
Window | JY5322A.AIAnalogTrigger


5322A C# API Manual: Member List

  • AIAnalogWindowComparator
JY5322A.AIAnalogWindowComparator Member List

This is the complete list of members for JY5322A.AIAnalogWindowComparator, including all inherited members.

Condition | JY5322A.AIAnalogWindowComparator
HighThreshold | JY5322A.AIAnalogWindowComparator
LowThreshold | JY5322A.AIAnalogWindowComparator


5322A C# API Manual: Member List

  • AIChannel
JY5322A.AIChannel Member List

This is the complete list of members for JY5322A.AIChannel, including all inherited members.

AIChannel(int channelId, double rangeLow, double rangeHigh, AIBandWidth bandWidth) | JY5322A.AIChannel
BandWidth | JY5322A.AIChannel
ChannelID | JY5322A.AIChannel
RangeHigh | JY5322A.AIChannel
RangeLow | JY5322A.AIChannel


5322A C# API Manual: Member List

  • AIDigitalTrigger
JY5322A.AIDigitalTrigger Member List

This is the complete list of members for JY5322A.AIDigitalTrigger, including all inherited members.

Edge | JY5322A.AIDigitalTrigger
InvertInput | JY5322A.AIDigitalTrigger
Source | JY5322A.AIDigitalTrigger


5322A C# API Manual: Member List

  • AIExternalSampleClock
JY5322A.AIExternalSampleClock Member List

This is the complete list of members for JY5322A.AIExternalSampleClock, including all inherited members.

ExpectedRate | JY5322A.AIExternalSampleClock
Terminal | JY5322A.AIExternalSampleClock


5322A C# API Manual: Member List

  • AIRecord
JY5322A.AIRecord Member List

This is the complete list of members for JY5322A.AIRecord, including all inherited members.

FileFormat | JY5322A.AIRecord
FilePath | JY5322A.AIRecord
Length | JY5322A.AIRecord
Mode | JY5322A.AIRecord


5322A C# API Manual: Member List

  • AISampleClock
JY5322A.AISampleClock Member List

This is the complete list of members for JY5322A.AISampleClock, including all inherited members.

External | JY5322A.AISampleClock
Source | JY5322A.AISampleClock


5322A C# API Manual: Member List

  • AISamplingInfo
JY5322A.AISamplingInfo Member List

This is the complete list of members for JY5322A.AISamplingInfo, including all inherited members.

ConvertClockRate | JY5322A.AISamplingInfo
GroupDelay | JY5322A.AISamplingInfo
OversamplingRatio | JY5322A.AISamplingInfo
RawDataWidth | JY5322A.AISamplingInfo


5322A C# API Manual: Member List

  • AISignalExport
JY5322A.AISignalExport Member List

This is the complete list of members for JY5322A.AISignalExport, including all inherited members.

Add(AISignalExportSource source, SignalExportDestination destination) | JY5322A.AISignalExport
Add(AISignalExportSource source, List< SignalExportDestination > destinations) | JY5322A.AISignalExport
Add(AISignalExportSource source, SignalExportDestination destination, SignalExportOutputType outType, bool invertOutput) | JY5322A.AISignalExport
Add(AISignalExportSource source, List< SignalExportDestination > destinations, SignalExportOutputType outType, bool invertOutput) | JY5322A.AISignalExport
Add(AIAnalogMultichannelComparator analogTrigComparatorParam, SignalExportDestination destination, SignalExportOutputType outType, bool invertOutput) | JY5322A.AISignalExport
Arm() | JY5322A.AISignalExport
Clear(SignalExportDestination destination) | JY5322A.AISignalExport
ClearAll() | JY5322A.AISignalExport


5322A C# API Manual: Member List

  • AITrigger
JY5322A.AITrigger Member List

This is the complete list of members for JY5322A.AITrigger, including all inherited members.

Analog | JY5322A.AITrigger
Digital | JY5322A.AITrigger
Mode | JY5322A.AITrigger
Multichannel | JY5322A.AITrigger
PreTriggerSamples | JY5322A.AITrigger
ReTriggerCount | JY5322A.AITrigger
Type | JY5322A.AITrigger


5322A C# API Manual: Member List

  • CIDigitalTrigger
JY5322A.CIDigitalTrigger Member List

This is the complete list of members for JY5322A.CIDigitalTrigger, including all inherited members.

Edge | JY5322A.CIDigitalTrigger
Source | JY5322A.CIDigitalTrigger


5322A C# API Manual: Member List

  • CIExternalSampleClock
JY5322A.CIExternalSampleClock Member List

This is the complete list of members for JY5322A.CIExternalSampleClock, including all inherited members.

ExpectedRate | JY5322A.CIExternalSampleClock
IgnoreFirstSampleClock | JY5322A.CIExternalSampleClock
Terminal | JY5322A.CIExternalSampleClock


5322A C# API Manual: Member List

  • CIExternalTimebase
JY5322A.CIExternalTimebase Member List

This is the complete list of members for JY5322A.CIExternalTimebase, including all inherited members.

Frequency | JY5322A.CIExternalTimebase
Terminal | JY5322A.CIExternalTimebase


5322A C# API Manual: Member List

  • CIImplicitSampleClock
JY5322A.CIImplicitSampleClock Member List

This is the complete list of members for JY5322A.CIImplicitSampleClock, including all inherited members.

ExpectedRate JY5322A.CIImplicitSampleClock


5322A C# API Manual: Member List

  • CIInternalSampleClock
JY5322A.CIInternalSampleClock Member List

This is the complete list of members for JY5322A.CIInternalSampleClock, including all inherited members.

IgnoreFirstSampleClock | JY5322A.CIInternalSampleClock
Rate | JY5322A.CIInternalSampleClock


5322A C# API Manual: Member List

  • CISampleClock
JY5322A.CISampleClock Member List

This is the complete list of members for JY5322A.CISampleClock, including all inherited members.

External | JY5322A.CISampleClock
Implicit | JY5322A.CISampleClock
Internal | JY5322A.CISampleClock
Source | JY5322A.CISampleClock


5322A C# API Manual: Member List

  • CISignalExport
JY5322A.CISignalExport Member List

This is the complete list of members for JY5322A.CISignalExport, including all inherited members.

Add(CISignalExportSource source, SignalExportDestination destination) | JY5322A.CISignalExport
Add(CISignalExportSource source, List< SignalExportDestination > destinations) | JY5322A.CISignalExport
Clear(SignalExportDestination destination) | JY5322A.CISignalExport
ClearAll() | JY5322A.CISignalExport


5322A C# API Manual: Member List

  • CITimebase
JY5322A.CITimebase Member List

This is the complete list of members for JY5322A.CITimebase, including all inherited members.

External | JY5322A.CITimebase
Source | JY5322A.CITimebase


5322A C# API Manual: Member List

  • CITrigger
JY5322A.CITrigger Member List

This is the complete list of members for JY5322A.CITrigger, including all inherited members.

Digital | JY5322A.CITrigger
Type | JY5322A.CITrigger


5322A C# API Manual: Member List

  • CODigitalTrigger
JY5322A.CODigitalTrigger Member List

This is the complete list of members for JY5322A.CODigitalTrigger, including all inherited members.

Edge | JY5322A.CODigitalTrigger
Source | JY5322A.CODigitalTrigger


5322A C# API Manual: Member List

  • COExternalTimebase
JY5322A.COExternalTimebase Member List

This is the complete list of members for JY5322A.COExternalTimebase, including all inherited members.

Frequency | JY5322A.COExternalTimebase
Terminal | JY5322A.COExternalTimebase


5322A C# API Manual: Member List

  • COPulse
JY5322A.COPulse Member List

This is the complete list of members for JY5322A.COPulse, including all inherited members.

COPulse(COPulseType type, double param1, double param2, int count) JY5322A.COPulse


5322A C# API Manual: Member List

  • COSignalExport
JY5322A.COSignalExport Member List

This is the complete list of members for JY5322A.COSignalExport, including all inherited members.

Add(COSignalExportSource source, SignalExportDestination destination) | JY5322A.COSignalExport
Add(COSignalExportSource source, List< SignalExportDestination > destinations) | JY5322A.COSignalExport
Clear(SignalExportDestination destination) | JY5322A.COSignalExport
ClearAll() | JY5322A.COSignalExport


5322A C# API Manual: Member List

  • COTimebase
JY5322A.COTimebase Member List

This is the complete list of members for JY5322A.COTimebase, including all inherited members.

External | JY5322A.COTimebase
Source | JY5322A.COTimebase


5322A C# API Manual: Member List

  • COTrigger
JY5322A.COTrigger Member List

This is the complete list of members for JY5322A.COTrigger, including all inherited members.

Digital | JY5322A.COTrigger
Type | JY5322A.COTrigger


5322A C# API Manual: Member List

  • DIChannel
JY5322A.DIChannel Member List

This is the complete list of members for JY5322A.DIChannel, including all inherited members.

LineNum JY5322A.DIChannel


5322A C# API Manual: Member List

  • DIDigitalTrigger
JY5322A.DIDigitalTrigger Member List

This is the complete list of members for JY5322A.DIDigitalTrigger, including all inherited members.

Edge | JY5322A.DIDigitalTrigger
Source | JY5322A.DIDigitalTrigger


5322A C# API Manual: Member List

  • DIExternalSampleClock
JY5322A.DIExternalSampleClock Member List

This is the complete list of members for JY5322A.DIExternalSampleClock, including all inherited members.

ExpectedRate | JY5322A.DIExternalSampleClock
Terminal | JY5322A.DIExternalSampleClock


5322A C# API Manual: Member List

  • DISampleClock
JY5322A.DISampleClock Member List

This is the complete list of members for JY5322A.DISampleClock, including all inherited members.

External | JY5322A.DISampleClock
Source | JY5322A.DISampleClock


5322A C# API Manual: Member List

  • DISignalExport
JY5322A.DISignalExport Member List

This is the complete list of members for JY5322A.DISignalExport, including all inherited members.

Add(DISignalExportSource source, SignalExportDestination destination) | JY5322A.DISignalExport
Add(DISignalExportSource source, List< SignalExportDestination > destinations) | JY5322A.DISignalExport
Clear(SignalExportDestination destination) | JY5322A.DISignalExport
ClearAll() | JY5322A.DISignalExport


5322A C# API Manual: Member List

  • DITrigger
JY5322A.DITrigger Member List

This is the complete list of members for JY5322A.DITrigger, including all inherited members.

Digital | JY5322A.DITrigger
Mode | JY5322A.DITrigger
PreTriggerSamples | JY5322A.DITrigger
Type | JY5322A.DITrigger


5322A C# API Manual: Member List

  • DOChannel
JY5322A.DOChannel Member List

This is the complete list of members for JY5322A.DOChannel, including all inherited members.

LineNum JY5322A.DOChannel


5322A C# API Manual: Member List

  • DODigitalTrigger
JY5322A.DODigitalTrigger Member List

This is the complete list of members for JY5322A.DODigitalTrigger, including all inherited members.

Edge | JY5322A.DODigitalTrigger
Source | JY5322A.DODigitalTrigger


5322A C# API Manual: Member List

  • DOExternalSampleClock
JY5322A.DOExternalSampleClock Member List

This is the complete list of members for JY5322A.DOExternalSampleClock, including all inherited members.

ExpectedRate | JY5322A.DOExternalSampleClock
Terminal | JY5322A.DOExternalSampleClock


5322A C# API Manual: Member List

  • DOSampleClock
JY5322A.DOSampleClock Member List

This is the complete list of members for JY5322A.DOSampleClock, including all inherited members.

External | JY5322A.DOSampleClock
Source | JY5322A.DOSampleClock


5322A C# API Manual: Member List

  • DOSignalExport
JY5322A.DOSignalExport Member List

This is the complete list of members for JY5322A.DOSignalExport, including all inherited members.

Add(DOSignalExportSource source, SignalExportDestination destination) | JY5322A.DOSignalExport
Add(DOSignalExportSource source, List< SignalExportDestination > destinations) | JY5322A.DOSignalExport
Clear(SignalExportDestination destination) | JY5322A.DOSignalExport
ClearAll() | JY5322A.DOSignalExport


5322A C# API Manual: Member List

  • DOTrigger
JY5322A.DOTrigger Member List

This is the complete list of members for JY5322A.DOTrigger, including all inherited members.

Digital | JY5322A.DOTrigger
Type | JY5322A.DOTrigger


5322A C# API Manual: Member List

  • DSMode
JY5322A.DSMode Member List

This is the complete list of members for JY5322A.DSMode, including all inherited members.

Enable JY5322A.DSMode


5322A C# API Manual: Member List

  • EdgeCounting
JY5322A.EdgeCounting Member List

This is the complete list of members for JY5322A.EdgeCounting, including all inherited members.

ActiveEdge | JY5322A.EdgeCounting
Direction | JY5322A.EdgeCounting
DirectionSignalReversed | JY5322A.EdgeCounting
DirTerminal | JY5322A.EdgeCounting
InitialCount | JY5322A.EdgeCounting
InputSignalReversed | JY5322A.EdgeCounting
InputTerminal | JY5322A.EdgeCounting
OutEvent | JY5322A.EdgeCounting
Pause | JY5322A.EdgeCounting


5322A C# API Manual: Member List

  • EdgeCountingOutEvent
JY5322A.EdgeCountingOutEvent Member List

This is the complete list of members for JY5322A.EdgeCountingOutEvent, including all inherited members.

IdleState | JY5322A.EdgeCountingOutEvent
Reset | JY5322A.EdgeCountingOutEvent
Terminal | JY5322A.EdgeCountingOutEvent
Threshold | JY5322A.EdgeCountingOutEvent


5322A C# API Manual: Member List

  • FrequencyMeas
JY5322A.FrequencyMeas Member List

This is the complete list of members for JY5322A.FrequencyMeas, including all inherited members.

InputTerminal | JY5322A.FrequencyMeas
StartingEdge | JY5322A.FrequencyMeas
Timebase | JY5322A.FrequencyMeas


5322A C# API Manual: Member List

  • JY5322AAITask
JY5322A.JY5322AAITask Member List

This is the complete list of members for JY5322A.JY5322AAITask, including all inherited members.

AddChannel(int chnId, double rangeLow=-10, double rangeHigh=10, AIBandWidth bandWidth=AIBandWidth._220KHz) | JY5322A.JY5322AAITask
AddChannel(int[] chnsId, double rangeLow=-10, double rangeHigh=10, AIBandWidth bandWidth=AIBandWidth._220KHz) | JY5322A.JY5322AAITask
AddChannel(int[] chnsId, double[] rangeLow, double[] rangeHigh, AIBandWidth[] bandWidth) | JY5322A.JY5322AAITask
Advanced | JY5322A.JY5322AAITask
AvailableSamples | JY5322A.JY5322AAITask
BufLenInSamples | JY5322A.JY5322AAITask
Channels | JY5322A.JY5322AAITask
Device | JY5322A.JY5322AAITask
GetRecordPreviewData(ref double[,] buf, int samplesPerChannel, int timeout=1000) | JY5322A.JY5322AAITask
GetRecordPreviewData(ref double[,] buf, int timeout=1000) | JY5322A.JY5322AAITask
GetRecordPreviewData(ref double[] buf, int samplesPerChannel, int timeout=1000) | JY5322A.JY5322AAITask
GetRecordPreviewData(ref double[] buf, int timeout=1000) | JY5322A.JY5322AAITask
GetRecordStatus(out double recordedLength, out bool recordDone) | JY5322A.JY5322AAITask
GetSamplingInfo() | JY5322A.JY5322AAITask
GetScalingCoefficients() | JY5322A.JY5322AAITask
JY5322AAITask(int slotNumber) | JY5322A.JY5322AAITask
JY5322AAITask(string boardName) | JY5322A.JY5322AAITask
Mode | JY5322A.JY5322AAITask
ReadData(IntPtr buf, int samplesPerChannel, int timeout=10000) | JY5322A.JY5322AAITask
ReadData(ref double[,] buf, int samplesPerChannel, int timeout=10000) | JY5322A.JY5322AAITask
ReadData(ref double[,] buf, int timeout=10000) | JY5322A.JY5322AAITask
ReadData(ref double[] buf, int samplesPerChannel, int timeout=10000) | JY5322A.JY5322AAITask
ReadData(ref double[] buf, int timeout=10000) | JY5322A.JY5322AAITask
ReadRawData(IntPtr buf, int samplesPerChannel, int timeout=10000) | JY5322A.JY5322AAITask
ReadRawData(ref short[,] buf, int samplesPerChannel, int timeout=10000) | JY5322A.JY5322AAITask
ReadRawData(ref short[,] buf, int timeout=10000) | JY5322A.JY5322AAITask
ReadRawData(ref short[] buf, int samplesPerChannel, int timeout=10000) | JY5322A.JY5322AAITask
ReadRawData(ref short[] buf, int timeout=10000) | JY5322A.JY5322AAITask
ReadRawData(ref int[,] buf, int samplesPerChannel, int timeout=10000) | JY5322A.JY5322AAITask
ReadRawData(ref int[,] buf, int timeout=10000) | JY5322A.JY5322AAITask
ReadRawData(ref int[] buf, int samplesPerChannel, int timeout=10000) | JY5322A.JY5322AAITask
ReadRawData(ref int[] buf, int timeout=10000) | JY5322A.JY5322AAITask
ReadRawSinglePoint(ref int[] readValues) | JY5322A.JY5322AAITask
ReadRawSinglePoint(ref int readValue, int channel) | JY5322A.JY5322AAITask
ReadSinglePoint(ref double readValue, int channel) | JY5322A.JY5322AAITask
ReadSinglePoint(ref double[] readValues) | JY5322A.JY5322AAITask
Record | JY5322A.JY5322AAITask
RemoveChannel(int chnId) | JY5322A.JY5322AAITask
SampleClock | JY5322A.JY5322AAITask
SampleRate | JY5322A.JY5322AAITask
SamplesToAcquire | JY5322A.JY5322AAITask
SendSoftwareTrigger() | JY5322A.JY5322AAITask
SignalExport | JY5322A.JY5322AAITask
Start() | JY5322A.JY5322AAITask
Stop() | JY5322A.JY5322AAITask
TerminalBoard | JY5322A.JY5322AAITask
TransferedSamples | JY5322A.JY5322AAITask
Trigger | JY5322A.JY5322AAITask
WaitUntilDone(int timeout=-1) | JY5322A.JY5322AAITask


5322A C# API Manual: Member List

  • JY5322ACITask
JY5322A.JY5322ACITask Member List

This is the complete list of members for JY5322A.JY5322ACITask, including all inherited members.

AvailableSamples | JY5322A.JY5322ACITask
Device | JY5322A.JY5322ACITask
EdgeCounting | JY5322A.JY5322ACITask
FrequencyMeas | JY5322A.JY5322ACITask
JY5322ACITask(int slotNum, int channel) | JY5322A.JY5322ACITask
JY5322ACITask(string boardName, int channel) | JY5322A.JY5322ACITask
Mode | JY5322A.JY5322ACITask
PeriodMeas | JY5322A.JY5322ACITask
PulseMeas | JY5322A.JY5322ACITask
QuadEncoder | JY5322A.JY5322ACITask
ReadData(ref uint[] bufCount, int samplesToAcquire, int timeout=10000) | JY5322A.JY5322ACITask
ReadData(ref uint[] bufCount, int timeout=10000) | JY5322A.JY5322ACITask
ReadData(ref double[] bufMeasurement, int samplesToAcquire, int timeout=10000) | JY5322A.JY5322ACITask
ReadData(ref double[] bufMeasurement, int timeout=10000) | JY5322A.JY5322ACITask
ReadData(ref double[] bufMeasurement1, ref double[] bufMeasurement2, int samplesToAcquire, int timeout=10000) | JY5322A.JY5322ACITask
ReadData(ref double[] bufMeasurement1, ref double[] bufMeasurement2, int timeout=10000) | JY5322A.JY5322ACITask
ReadSinglePoint(ref uint count) | JY5322A.JY5322ACITask
ReadSinglePoint(ref double measurement, int timeout=10000) | JY5322A.JY5322ACITask
ReadSinglePoint(ref double measurement1, ref double measurement2, int timeout=10000) | JY5322A.JY5322ACITask
SampleClock | JY5322A.JY5322ACITask
SamplesToAcquire | JY5322A.JY5322ACITask
SemiPeriodMeas | JY5322A.JY5322ACITask
SendSoftwareTrigger() | JY5322A.JY5322ACITask
SignalExport | JY5322A.JY5322ACITask
Start() | JY5322A.JY5322ACITask
Stop() | JY5322A.JY5322ACITask
TransferedSamples | JY5322A.JY5322ACITask
Trigger | JY5322A.JY5322ACITask
TwoEdgeSeparation | JY5322A.JY5322ACITask
TwoPulseEncoder | JY5322A.JY5322ACITask
Type | JY5322A.JY5322ACITask


5322A C# API Manual: Member List

  • JY5322ACOTask
JY5322A.JY5322ACOTask Member List

This is the complete list of members for JY5322A.JY5322ACOTask, including all inherited members.

AvaliableLenInSamples | JY5322A.JY5322ACOTask
Device | JY5322A.JY5322ACOTask
IdleState | JY5322A.JY5322ACOTask
InitialDelay | JY5322A.JY5322ACOTask
JY5322ACOTask(int slotNum, int channel) | JY5322A.JY5322ACOTask
JY5322ACOTask(string boardName, int channel) | JY5322A.JY5322ACOTask
Mode | JY5322A.JY5322ACOTask
OutputTerminal | JY5322A.JY5322ACOTask
Pause | JY5322A.JY5322ACOTask
SamplesToUpdate | JY5322A.JY5322ACOTask
SendSoftwareTrigger() | JY5322A.JY5322ACOTask
SignalExport | JY5322A.JY5322ACOTask
Start() | JY5322A.JY5322ACOTask
Stop() | JY5322A.JY5322ACOTask
Timebase | JY5322A.JY5322ACOTask
TransferedPulses | JY5322A.JY5322ACOTask
TransferedSamples | JY5322A.JY5322ACOTask
Trigger | JY5322A.JY5322ACOTask
WaitUntilDone(int timeout=-1) | JY5322A.JY5322ACOTask
WriteData(COPulse[] pulsesGroup, int samplesToWrite, int timeout=10000) | JY5322A.JY5322ACOTask
WriteSinglePoint(COPulse pulse) | JY5322A.JY5322ACOTask


5322A C# API Manual: Member List

  • JY5322ADITask
JY5322A.JY5322ADITask Member List

This is the complete list of members for JY5322A.JY5322ADITask, including all inherited members.

AddChannel(int lineNum) | JY5322A.JY5322ADITask
AddChannel(int[] linesNum) | JY5322A.JY5322ADITask
AvailableSamples | JY5322A.JY5322ADITask
BufLenInSamples | JY5322A.JY5322ADITask
Channels | JY5322A.JY5322ADITask
Device | JY5322A.JY5322ADITask
JY5322ADITask(int slotNum) | JY5322A.JY5322ADITask
JY5322ADITask(string aliasName) | JY5322A.JY5322ADITask
Mode | JY5322A.JY5322ADITask
ReadData(ref ushort[] dataBuffer, uint samplesToAcquire, int timeOut=10000) | JY5322A.JY5322ADITask
ReadData(ref byte[] dataBuffer, uint samplesToAcquire, int timeOut=10000) | JY5322A.JY5322ADITask
ReadData(ref byte[,] dataBuffer, uint samplesToAcquire, int timeOut=10000) | JY5322A.JY5322ADITask
ReadSinglePoint(ref bool readValue, int line) | JY5322A.JY5322ADITask
ReadSinglePoint(ref bool[] readValues) | JY5322A.JY5322ADITask
RemoveChannel(int lineNum) | JY5322A.JY5322ADITask
SampleClock | JY5322A.JY5322ADITask
SampleRate | JY5322A.JY5322ADITask
SamplesToAcquire | JY5322A.JY5322ADITask
SendSoftwareTrigger() | JY5322A.JY5322ADITask
SignalExport | JY5322A.JY5322ADITask
Start() | JY5322A.JY5322ADITask
Stop() | JY5322A.JY5322ADITask
TransferedSamples | JY5322A.JY5322ADITask
Trigger | JY5322A.JY5322ADITask


5322A C# API Manual: Member List

  • JY5322ADOTask
JY5322A.JY5322ADOTask Member List

This is the complete list of members for JY5322A.JY5322ADOTask, including all inherited members.

AddChannel(int lineNum) | JY5322A.JY5322ADOTask
AddChannel(int[] linesNum) | JY5322A.JY5322ADOTask
AvaliableLenInSamples | JY5322A.JY5322ADOTask
BufLenInSamples | JY5322A.JY5322ADOTask
Channels | JY5322A.JY5322ADOTask
CompleteState | JY5322A.JY5322ADOTask
Device | JY5322A.JY5322ADOTask
JY5322ADOTask(int slotNum) | JY5322A.JY5322ADOTask
JY5322ADOTask(string boardName) | JY5322A.JY5322ADOTask
Mode | JY5322A.JY5322ADOTask
RemoveChannel(int lineNum) | JY5322A.JY5322ADOTask
SampleClock | JY5322A.JY5322ADOTask
SamplesToUpdate | JY5322A.JY5322ADOTask
SendSoftwareTrigger() | JY5322A.JY5322ADOTask
SignalExport | JY5322A.JY5322ADOTask
Start() | JY5322A.JY5322ADOTask
Stop() | JY5322A.JY5322ADOTask
TransferedSamples | JY5322A.JY5322ADOTask
Trigger | JY5322A.JY5322ADOTask
UpdateRate | JY5322A.JY5322ADOTask
WaitUntilDone(int timeout=-1) | JY5322A.JY5322ADOTask
WriteData(ushort[] dataBuffer, uint samplesToUpdate, int timeOut=10000) | JY5322A.JY5322ADOTask
WriteData(byte[] dataBuffer, uint samplesToUpdate, int timeOut=10000) | JY5322A.JY5322ADOTask
WriteData(byte[,] dataBuffer, uint samplesToUpdate, int timeOut=10000) | JY5322A.JY5322ADOTask
WriteSinglePoint(bool writeValue, int line) | JY5322A.JY5322ADOTask
WriteSinglePoint(bool[] writeValues) | JY5322A.JY5322ADOTask


5322A C# API Manual: Member List

  • PauseTrigger
JY5322A.PauseTrigger Member List

This is the complete list of members for JY5322A.PauseTrigger, including all inherited members.

ActivePolarity | JY5322A.PauseTrigger
OutputState | JY5322A.PauseTrigger
SignalReversed | JY5322A.PauseTrigger
Terminal | JY5322A.PauseTrigger


5322A C# API Manual: Member List

  • PeriodMeas
JY5322A.PeriodMeas Member List

This is the complete list of members for JY5322A.PeriodMeas, including all inherited members.

InputTerminal | JY5322A.PeriodMeas
StartingEdge | JY5322A.PeriodMeas
Timebase | JY5322A.PeriodMeas


5322A C# API Manual: Member List

  • PulseMeas
JY5322A.PulseMeas Member List

This is the complete list of members for JY5322A.PulseMeas, including all inherited members.

InputTerminal | JY5322A.PulseMeas
SignalReversed | JY5322A.PulseMeas
StartingEdge | JY5322A.PulseMeas
Timebase | JY5322A.PulseMeas


5322A C# API Manual: Member List

  • QuadEncoder
JY5322A.QuadEncoder Member List

This is the complete list of members for JY5322A.QuadEncoder, including all inherited members.

AInputTerminal | JY5322A.QuadEncoder
ASignalReversed | JY5322A.QuadEncoder
BInputTerminal | JY5322A.QuadEncoder
BSignalReversed | JY5322A.QuadEncoder
EncodingType | JY5322A.QuadEncoder
InitialCount | JY5322A.QuadEncoder
ZInputTerminal | JY5322A.QuadEncoder
ZReloadEnabled | JY5322A.QuadEncoder
ZSignalReversed | JY5322A.QuadEncoder


5322A C# API Manual: Member List

  • ScalingCoefficients
JY5322A.ScalingCoefficients Member List

This is the complete list of members for JY5322A.ScalingCoefficients, including all inherited members.

Gain | JY5322A.ScalingCoefficients
Offset | JY5322A.ScalingCoefficients
Reserved1 | JY5322A.ScalingCoefficients
Reserved2 | JY5322A.ScalingCoefficients
ScalingCoefficients() | JY5322A.ScalingCoefficients
ScalingCoefficients(double offset, double gain) | JY5322A.ScalingCoefficients


5322A C# API Manual: Member List

  • SemiPeriodMeas
JY5322A.SemiPeriodMeas Member List

This is the complete list of members for JY5322A.SemiPeriodMeas, including all inherited members.

InputTerminal | JY5322A.SemiPeriodMeas
SignalReversed | JY5322A.SemiPeriodMeas
StartingEdge | JY5322A.SemiPeriodMeas
Timebase | JY5322A.SemiPeriodMeas


5322A C# API Manual: Member List

  • TwoEdgeSeparation
JY5322A.TwoEdgeSeparation Member List

This is the complete list of members for JY5322A.TwoEdgeSeparation, including all inherited members.

EdgeSeparationMode | JY5322A.TwoEdgeSeparation
FirstInputTerminal | JY5322A.TwoEdgeSeparation
FirstSignalReversed | JY5322A.TwoEdgeSeparation
SecondInputTerminal | JY5322A.TwoEdgeSeparation
SecondSignalReversed | JY5322A.TwoEdgeSeparation
Timebase | JY5322A.TwoEdgeSeparation


5322A C# API Manual: Member List

  • TwoPulseEncoder
JY5322A.TwoPulseEncoder Member List

This is the complete list of members for JY5322A.TwoPulseEncoder, including all inherited members.

AInputTerminal | JY5322A.TwoPulseEncoder
ASignalReversed | JY5322A.TwoPulseEncoder
BInputTerminal | JY5322A.TwoPulseEncoder
BSignalReversed | JY5322A.TwoPulseEncoder
InitialCount | JY5322A.TwoPulseEncoder


5322A C# API Manual: Class Index

Class Index
A | C | D | E | F | J | P | Q | S | T
A
AIAdvanced (JY5322A)
AIAnalogEdgeComparator (JY5322A)
AIAnalogHysteresisComparator (JY5322A)
AIAnalogMultichannelComparator (JY5322A)
AIAnalogMultichannelEdgeComparator (JY5322A)
AIAnalogMultichannelEdgeComparatorSource (JY5322A)
AIAnalogMultichannelHysteresisComparator (JY5322A)
AIAnalogMultichannelHysteresisComparatorSource (JY5322A)
AIAnalogMultichannelWindowComparator (JY5322A)
AIAnalogMultichannelWindowComparatorSource (JY5322A)
AIAnalogTrigger (JY5322A)
AIAnalogWindowComparator (JY5322A)
AIChannel (JY5322A)
AIDigitalTrigger (JY5322A)
AIExternalSampleClock (JY5322A)
AIRecord (JY5322A)
AISampleClock (JY5322A)
AISamplingInfo (JY5322A)
AISignalExport (JY5322A)
AITrigger (JY5322A)
C
CIDigitalTrigger (JY5322A)
CIExternalSampleClock (JY5322A)
CIExternalTimebase (JY5322A)
CIImplicitSampleClock (JY5322A)
CIInternalSampleClock (JY5322A)
CISampleClock (JY5322A)
CISignalExport (JY5322A)
CITimebase (JY5322A)
CITrigger (JY5322A)
CODigitalTrigger (JY5322A)
COExternalTimebase (JY5322A)
COPulse (JY5322A)
COSignalExport (JY5322A)
COTimebase (JY5322A)
COTrigger (JY5322A)
D
DIChannel (JY5322A)
DIDigitalTrigger (JY5322A)
DIExternalSampleClock (JY5322A)
DISampleClock (JY5322A)
DISignalExport (JY5322A)
DITrigger (JY5322A)
DOChannel (JY5322A)
DODigitalTrigger (JY5322A)
DOExternalSampleClock (JY5322A)
DOSampleClock (JY5322A)
DOSignalExport (JY5322A)
DOTrigger (JY5322A)
DSMode (JY5322A)
E
EdgeCounting (JY5322A)
EdgeCountingOutEvent (JY5322A)
F
FrequencyMeas (JY5322A)
J
JY5322AAITask (JY5322A)
JY5322ACITask (JY5322A)
JY5322ACOTask (JY5322A)
JY5322ADITask (JY5322A)
JY5322ADOTask (JY5322A)
P
PauseTrigger (JY5322A)
PeriodMeas (JY5322A)
PulseMeas (JY5322A)
Q
QuadEncoder (JY5322A)
S
ScalingCoefficients (JY5322A)
SemiPeriodMeas (JY5322A)
T
TwoEdgeSeparation (JY5322A)
TwoPulseEncoder (JY5322A)


5322A C# API Manual: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- a -

  • ActiveEdge : JY5322A.EdgeCounting
  • ActivePolarity : JY5322A.PauseTrigger
  • Add() : JY5322A.AIAnalogMultichannelEdgeComparator, JY5322A.AIAnalogMultichannelHysteresisComparator, JY5322A.AIAnalogMultichannelWindowComparator, JY5322A.AISignalExport, JY5322A.CISignalExport, JY5322A.COSignalExport, JY5322A.DISignalExport, JY5322A.DOSignalExport
  • AddChannel() : JY5322A.JY5322AAITask, JY5322A.JY5322ADITask, JY5322A.JY5322ADOTask
  • Advanced : JY5322A.JY5322AAITask
  • AIAnalogMultichannelComparator() : JY5322A.AIAnalogMultichannelComparator
  • AIAnalogMultichannelEdgeComparator() : JY5322A.AIAnalogMultichannelEdgeComparator
  • AIAnalogMultichannelEdgeComparatorSource() : JY5322A.AIAnalogMultichannelEdgeComparatorSource
  • AIAnalogMultichannelHysteresisComparator() : JY5322A.AIAnalogMultichannelHysteresisComparator
  • AIAnalogMultichannelHysteresisComparatorSource() : JY5322A.AIAnalogMultichannelHysteresisComparatorSource
  • AIAnalogMultichannelWindowComparator() : JY5322A.AIAnalogMultichannelWindowComparator
  • AIAnalogMultichannelWindowComparatorSource() : JY5322A.AIAnalogMultichannelWindowComparatorSource
  • AIAnalogTrigger() : JY5322A.AIAnalogTrigger
  • AIChannel() : JY5322A.AIChannel
  • AInputTerminal : JY5322A.QuadEncoder, JY5322A.TwoPulseEncoder
  • Analog : JY5322A.AITrigger
  • Arm() : JY5322A.AISignalExport
  • ASignalReversed : JY5322A.QuadEncoder, JY5322A.TwoPulseEncoder
  • AvailableSamples : JY5322A.JY5322AAITask, JY5322A.JY5322ACITask, JY5322A.JY5322ADITask
  • AvaliableLenInSamples : JY5322A.JY5322ACOTask, JY5322A.JY5322ADOTask


5322A C# API Manual: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- b -

  • BandWidth : JY5322A.AIChannel
  • BInputTerminal : JY5322A.QuadEncoder, JY5322A.TwoPulseEncoder
  • BSignalReversed : JY5322A.QuadEncoder, JY5322A.TwoPulseEncoder
  • BufLenInSamples : JY5322A.JY5322AAITask, JY5322A.JY5322ADITask, JY5322A.JY5322ADOTask


5322A C# API Manual: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- c -

  • ChannelID : JY5322A.AIChannel
  • Channels : JY5322A.JY5322AAITask, JY5322A.JY5322ADITask, JY5322A.JY5322ADOTask
  • Clear() : JY5322A.AIAnalogMultichannelEdgeComparator, JY5322A.AIAnalogMultichannelHysteresisComparator, JY5322A.AIAnalogMultichannelWindowComparator, JY5322A.AISignalExport, JY5322A.CISignalExport, JY5322A.COSignalExport, JY5322A.DISignalExport, JY5322A.DOSignalExport
  • ClearAll() : JY5322A.AISignalExport, JY5322A.CISignalExport, JY5322A.COSignalExport, JY5322A.DISignalExport, JY5322A.DOSignalExport
  • Comparator : JY5322A.AIAnalogMultichannelComparator, JY5322A.AIAnalogTrigger
  • CompleteState : JY5322A.JY5322ADOTask
  • Condition : JY5322A.AIAnalogMultichannelWindowComparatorSource, JY5322A.AIAnalogWindowComparator
  • ConvertClockRate : JY5322A.AISamplingInfo
  • COPulse() : JY5322A.COPulse


5322A C# API Manual: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- d -

  • Device : JY5322A.JY5322AAITask, JY5322A.JY5322ACITask, JY5322A.JY5322ACOTask, JY5322A.JY5322ADITask, JY5322A.JY5322ADOTask
  • Digital : JY5322A.AITrigger, JY5322A.CITrigger, JY5322A.COTrigger, JY5322A.DITrigger, JY5322A.DOTrigger
  • Direction : JY5322A.EdgeCounting
  • DirectionSignalReversed : JY5322A.EdgeCounting
  • DirTerminal : JY5322A.EdgeCounting
  • DSMode : JY5322A.AIAdvanced


5322A C# API Manual: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- e -

  • Edge : JY5322A.AIAnalogMultichannelComparator, JY5322A.AIAnalogTrigger, JY5322A.AIDigitalTrigger, JY5322A.CIDigitalTrigger, JY5322A.CODigitalTrigger, JY5322A.DIDigitalTrigger, JY5322A.DODigitalTrigger
  • EdgeCounting : JY5322A.JY5322ACITask
  • EdgeSeparationMode : JY5322A.TwoEdgeSeparation
  • Enable : JY5322A.DSMode
  • EncodingType : JY5322A.QuadEncoder
  • ExpectedRate : JY5322A.AIExternalSampleClock, JY5322A.CIExternalSampleClock, JY5322A.CIImplicitSampleClock, JY5322A.DIExternalSampleClock, JY5322A.DOExternalSampleClock
  • External : JY5322A.AISampleClock, JY5322A.CISampleClock, JY5322A.CITimebase, JY5322A.COTimebase, JY5322A.DISampleClock, JY5322A.DOSampleClock


5322A C# API Manual: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- f -

  • FileFormat : JY5322A.AIRecord
  • FilePath : JY5322A.AIRecord
  • FirstInputTerminal : JY5322A.TwoEdgeSeparation
  • FirstSignalReversed : JY5322A.TwoEdgeSeparation
  • Frequency : JY5322A.CIExternalTimebase, JY5322A.COExternalTimebase
  • FrequencyMeas : JY5322A.JY5322ACITask


5322A C# API Manual: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • c
  • g
  • j
  • r
  • s
  • w
Here is a list of all functions with links to the classes they belong to:

- a -

  • Add() : JY5322A.AIAnalogMultichannelEdgeComparator, JY5322A.AIAnalogMultichannelHysteresisComparator, JY5322A.AIAnalogMultichannelWindowComparator, JY5322A.AISignalExport, JY5322A.CISignalExport, JY5322A.COSignalExport, JY5322A.DISignalExport, JY5322A.DOSignalExport
  • AddChannel() : JY5322A.JY5322AAITask, JY5322A.JY5322ADITask, JY5322A.JY5322ADOTask
  • AIAnalogMultichannelComparator() : JY5322A.AIAnalogMultichannelComparator
  • AIAnalogMultichannelEdgeComparator() : JY5322A.AIAnalogMultichannelEdgeComparator
  • AIAnalogMultichannelEdgeComparatorSource() : JY5322A.AIAnalogMultichannelEdgeComparatorSource
  • AIAnalogMultichannelHysteresisComparator() : JY5322A.AIAnalogMultichannelHysteresisComparator
  • AIAnalogMultichannelHysteresisComparatorSource() : JY5322A.AIAnalogMultichannelHysteresisComparatorSource
  • AIAnalogMultichannelWindowComparator() : JY5322A.AIAnalogMultichannelWindowComparator
  • AIAnalogMultichannelWindowComparatorSource() : JY5322A.AIAnalogMultichannelWindowComparatorSource
  • AIAnalogTrigger() : JY5322A.AIAnalogTrigger
  • AIChannel() : JY5322A.AIChannel
  • Arm() : JY5322A.AISignalExport

- c -

  • Clear() : JY5322A.AIAnalogMultichannelEdgeComparator, JY5322A.AIAnalogMultichannelHysteresisComparator, JY5322A.AIAnalogMultichannelWindowComparator, JY5322A.AISignalExport, JY5322A.CISignalExport, JY5322A.COSignalExport, JY5322A.DISignalExport, JY5322A.DOSignalExport
  • ClearAll() : JY5322A.AISignalExport, JY5322A.CISignalExport, JY5322A.COSignalExport, JY5322A.DISignalExport, JY5322A.DOSignalExport
  • COPulse() : JY5322A.COPulse

- g -

  • GetRecordPreviewData() : JY5322A.JY5322AAITask
  • GetRecordStatus() : JY5322A.JY5322AAITask
  • GetSamplingInfo() : JY5322A.JY5322AAITask
  • GetScalingCoefficients() : JY5322A.JY5322AAITask

- j -

  • JY5322AAITask() : JY5322A.JY5322AAITask
  • JY5322ACITask() : JY5322A.JY5322ACITask
  • JY5322ACOTask() : JY5322A.JY5322ACOTask
  • JY5322ADITask() : JY5322A.JY5322ADITask
  • JY5322ADOTask() : JY5322A.JY5322ADOTask

- r -

  • ReadData() : JY5322A.JY5322AAITask, JY5322A.JY5322ACITask, JY5322A.JY5322ADITask
  • ReadRawData() : JY5322A.JY5322AAITask
  • ReadRawSinglePoint() : JY5322A.JY5322AAITask
  • ReadSinglePoint() : JY5322A.JY5322AAITask, JY5322A.JY5322ACITask, JY5322A.JY5322ADITask
  • RemoveChannel() : JY5322A.JY5322AAITask, JY5322A.JY5322ADITask, JY5322A.JY5322ADOTask

- s -

  • ScalingCoefficients() : JY5322A.ScalingCoefficients
  • SendSoftwareTrigger() : JY5322A.JY5322AAITask, JY5322A.JY5322ACITask, JY5322A.JY5322ACOTask, JY5322A.JY5322ADITask, JY5322A.JY5322ADOTask
  • Start() : JY5322A.JY5322AAITask, JY5322A.JY5322ACITask, JY5322A.JY5322ACOTask, JY5322A.JY5322ADITask, JY5322A.JY5322ADOTask
  • Stop() : JY5322A.JY5322AAITask, JY5322A.JY5322ACITask, JY5322A.JY5322ACOTask, JY5322A.JY5322ADITask, JY5322A.JY5322ADOTask

- w -

  • WaitUntilDone() : JY5322A.JY5322AAITask, JY5322A.JY5322ACOTask, JY5322A.JY5322ADOTask
  • WriteData() : JY5322A.JY5322ACOTask, JY5322A.JY5322ADOTask
  • WriteSinglePoint() : JY5322A.JY5322ACOTask, JY5322A.JY5322ADOTask


5322A C# API Manual: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- g -

  • Gain : JY5322A.ScalingCoefficients
  • GetRecordPreviewData() : JY5322A.JY5322AAITask
  • GetRecordStatus() : JY5322A.JY5322AAITask
  • GetSamplingInfo() : JY5322A.JY5322AAITask
  • GetScalingCoefficients() : JY5322A.JY5322AAITask
  • GroupDelay : JY5322A.AISamplingInfo


5322A C# API Manual: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- h -

  • HighThreshold : JY5322A.AIAnalogHysteresisComparator, JY5322A.AIAnalogMultichannelHysteresisComparatorSource, JY5322A.AIAnalogMultichannelWindowComparatorSource, JY5322A.AIAnalogWindowComparator
  • Hysteresis : JY5322A.AIAnalogMultichannelComparator, JY5322A.AIAnalogTrigger


5322A C# API Manual: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- i -

  • IdleState : JY5322A.EdgeCountingOutEvent, JY5322A.JY5322ACOTask
  • IgnoreFirstSampleClock : JY5322A.CIExternalSampleClock, JY5322A.CIInternalSampleClock
  • Implicit : JY5322A.CISampleClock
  • InitialCount : JY5322A.EdgeCounting, JY5322A.QuadEncoder, JY5322A.TwoPulseEncoder
  • InitialDelay : JY5322A.JY5322ACOTask
  • InputSignalReversed : JY5322A.EdgeCounting
  • InputTerminal : JY5322A.EdgeCounting, JY5322A.FrequencyMeas, JY5322A.PeriodMeas, JY5322A.PulseMeas, JY5322A.SemiPeriodMeas
  • Internal : JY5322A.CISampleClock
  • InvertInput : JY5322A.AIDigitalTrigger


5322A C# API Manual: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- j -

  • JY5322AAITask() : JY5322A.JY5322AAITask
  • JY5322ACITask() : JY5322A.JY5322ACITask
  • JY5322ACOTask() : JY5322A.JY5322ACOTask
  • JY5322ADITask() : JY5322A.JY5322ADITask
  • JY5322ADOTask() : JY5322A.JY5322ADOTask


5322A C# API Manual: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- l -

  • Length : JY5322A.AIRecord
  • LineNum : JY5322A.DIChannel, JY5322A.DOChannel
  • Logic : JY5322A.AIAnalogMultichannelComparator
  • LowThreshold : JY5322A.AIAnalogHysteresisComparator, JY5322A.AIAnalogMultichannelHysteresisComparatorSource, JY5322A.AIAnalogMultichannelWindowComparatorSource, JY5322A.AIAnalogWindowComparator


5322A C# API Manual: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- m -

  • Mode : JY5322A.AIRecord, JY5322A.AITrigger, JY5322A.DITrigger, JY5322A.JY5322AAITask, JY5322A.JY5322ACITask, JY5322A.JY5322ACOTask, JY5322A.JY5322ADITask, JY5322A.JY5322ADOTask
  • Multichannel : JY5322A.AITrigger


5322A C# API Manual: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- o -

  • Offset : JY5322A.ScalingCoefficients
  • OutEvent : JY5322A.EdgeCounting
  • OutputState : JY5322A.PauseTrigger
  • OutputTerminal : JY5322A.JY5322ACOTask
  • OversamplingRatio : JY5322A.AISamplingInfo


5322A C# API Manual: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- p -

  • Pause : JY5322A.EdgeCounting, JY5322A.JY5322ACOTask
  • PeriodMeas : JY5322A.JY5322ACITask
  • PreTriggerSamples : JY5322A.AITrigger, JY5322A.DITrigger
  • PulseMeas : JY5322A.JY5322ACITask


5322A C# API Manual: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all properties with links to the classes they belong to:

- a -

  • ActiveEdge : JY5322A.EdgeCounting
  • ActivePolarity : JY5322A.PauseTrigger
  • Advanced : JY5322A.JY5322AAITask
  • AInputTerminal : JY5322A.QuadEncoder, JY5322A.TwoPulseEncoder
  • Analog : JY5322A.AITrigger
  • ASignalReversed : JY5322A.QuadEncoder, JY5322A.TwoPulseEncoder
  • AvailableSamples : JY5322A.JY5322AAITask, JY5322A.JY5322ACITask, JY5322A.JY5322ADITask
  • AvaliableLenInSamples : JY5322A.JY5322ACOTask, JY5322A.JY5322ADOTask


5322A C# API Manual: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all properties with links to the classes they belong to:

- b -

  • BandWidth : JY5322A.AIChannel
  • BInputTerminal : JY5322A.QuadEncoder, JY5322A.TwoPulseEncoder
  • BSignalReversed : JY5322A.QuadEncoder, JY5322A.TwoPulseEncoder
  • BufLenInSamples : JY5322A.JY5322AAITask, JY5322A.JY5322ADITask, JY5322A.JY5322ADOTask


5322A C# API Manual: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all properties with links to the classes they belong to:

- c -

  • ChannelID : JY5322A.AIChannel
  • Channels : JY5322A.JY5322AAITask, JY5322A.JY5322ADITask, JY5322A.JY5322ADOTask
  • Comparator : JY5322A.AIAnalogMultichannelComparator, JY5322A.AIAnalogTrigger
  • CompleteState : JY5322A.JY5322ADOTask
  • Condition : JY5322A.AIAnalogMultichannelWindowComparatorSource, JY5322A.AIAnalogWindowComparator
  • ConvertClockRate : JY5322A.AISamplingInfo


5322A C# API Manual: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all properties with links to the classes they belong to:

- d -

  • Device : JY5322A.JY5322AAITask, JY5322A.JY5322ACITask, JY5322A.JY5322ACOTask, JY5322A.JY5322ADITask, JY5322A.JY5322ADOTask
  • Digital : JY5322A.AITrigger, JY5322A.CITrigger, JY5322A.COTrigger, JY5322A.DITrigger, JY5322A.DOTrigger
  • Direction : JY5322A.EdgeCounting
  • DirectionSignalReversed : JY5322A.EdgeCounting
  • DirTerminal : JY5322A.EdgeCounting
  • DSMode : JY5322A.AIAdvanced


5322A C# API Manual: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all properties with links to the classes they belong to:

- e -

  • Edge : JY5322A.AIAnalogMultichannelComparator, JY5322A.AIAnalogTrigger, JY5322A.AIDigitalTrigger, JY5322A.CIDigitalTrigger, JY5322A.CODigitalTrigger, JY5322A.DIDigitalTrigger, JY5322A.DODigitalTrigger
  • EdgeCounting : JY5322A.JY5322ACITask
  • EdgeSeparationMode : JY5322A.TwoEdgeSeparation
  • Enable : JY5322A.DSMode
  • EncodingType : JY5322A.QuadEncoder
  • ExpectedRate : JY5322A.AIExternalSampleClock, JY5322A.CIExternalSampleClock, JY5322A.CIImplicitSampleClock, JY5322A.DIExternalSampleClock, JY5322A.DOExternalSampleClock
  • External : JY5322A.AISampleClock, JY5322A.CISampleClock, JY5322A.CITimebase, JY5322A.COTimebase, JY5322A.DISampleClock, JY5322A.DOSampleClock


5322A C# API Manual: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all properties with links to the classes they belong to:

- f -

  • FileFormat : JY5322A.AIRecord
  • FilePath : JY5322A.AIRecord
  • FirstInputTerminal : JY5322A.TwoEdgeSeparation
  • FirstSignalReversed : JY5322A.TwoEdgeSeparation
  • Frequency : JY5322A.CIExternalTimebase, JY5322A.COExternalTimebase
  • FrequencyMeas : JY5322A.JY5322ACITask


5322A C# API Manual: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all properties with links to the classes they belong to:

- g -

  • Gain : JY5322A.ScalingCoefficients
  • GroupDelay : JY5322A.AISamplingInfo


5322A C# API Manual: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all properties with links to the classes they belong to:

- h -

  • HighThreshold : JY5322A.AIAnalogHysteresisComparator, JY5322A.AIAnalogMultichannelHysteresisComparatorSource, JY5322A.AIAnalogMultichannelWindowComparatorSource, JY5322A.AIAnalogWindowComparator
  • Hysteresis : JY5322A.AIAnalogMultichannelComparator, JY5322A.AIAnalogTrigger


5322A C# API Manual: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all properties with links to the classes they belong to:

- i -

  • IdleState : JY5322A.EdgeCountingOutEvent, JY5322A.JY5322ACOTask
  • IgnoreFirstSampleClock : JY5322A.CIExternalSampleClock, JY5322A.CIInternalSampleClock
  • Implicit : JY5322A.CISampleClock
  • InitialCount : JY5322A.EdgeCounting, JY5322A.QuadEncoder, JY5322A.TwoPulseEncoder
  • InitialDelay : JY5322A.JY5322ACOTask
  • InputSignalReversed : JY5322A.EdgeCounting
  • InputTerminal : JY5322A.EdgeCounting, JY5322A.FrequencyMeas, JY5322A.PeriodMeas, JY5322A.PulseMeas, JY5322A.SemiPeriodMeas
  • Internal : JY5322A.CISampleClock
  • InvertInput : JY5322A.AIDigitalTrigger


5322A C# API Manual: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all properties with links to the classes they belong to:

- l -

  • Length : JY5322A.AIRecord
  • LineNum : JY5322A.DIChannel, JY5322A.DOChannel
  • Logic : JY5322A.AIAnalogMultichannelComparator
  • LowThreshold : JY5322A.AIAnalogHysteresisComparator, JY5322A.AIAnalogMultichannelHysteresisComparatorSource, JY5322A.AIAnalogMultichannelWindowComparatorSource, JY5322A.AIAnalogWindowComparator


5322A C# API Manual: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all properties with links to the classes they belong to:

- m -

  • Mode : JY5322A.AIRecord, JY5322A.AITrigger, JY5322A.DITrigger, JY5322A.JY5322AAITask, JY5322A.JY5322ACITask, JY5322A.JY5322ACOTask, JY5322A.JY5322ADITask, JY5322A.JY5322ADOTask
  • Multichannel : JY5322A.AITrigger


5322A C# API Manual: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all properties with links to the classes they belong to:

- o -

  • Offset : JY5322A.ScalingCoefficients
  • OutEvent : JY5322A.EdgeCounting
  • OutputState : JY5322A.PauseTrigger
  • OutputTerminal : JY5322A.JY5322ACOTask
  • OversamplingRatio : JY5322A.AISamplingInfo


5322A C# API Manual: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all properties with links to the classes they belong to:

- p -

  • Pause : JY5322A.EdgeCounting, JY5322A.JY5322ACOTask
  • PeriodMeas : JY5322A.JY5322ACITask
  • PreTriggerSamples : JY5322A.AITrigger, JY5322A.DITrigger
  • PulseMeas : JY5322A.JY5322ACITask


5322A C# API Manual: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all properties with links to the classes they belong to:

- q -

  • QuadEncoder : JY5322A.JY5322ACITask


5322A C# API Manual: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all properties with links to the classes they belong to:

- r -

  • RangeHigh : JY5322A.AIChannel
  • RangeLow : JY5322A.AIChannel
  • Rate : JY5322A.CIInternalSampleClock
  • RawDataWidth : JY5322A.AIAdvanced, JY5322A.AISamplingInfo
  • Record : JY5322A.JY5322AAITask
  • Reserved1 : JY5322A.ScalingCoefficients
  • Reserved2 : JY5322A.ScalingCoefficients
  • Reset : JY5322A.EdgeCountingOutEvent
  • ReTriggerCount : JY5322A.AITrigger


5322A C# API Manual: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all properties with links to the classes they belong to:

- s -

  • SampleClock : JY5322A.JY5322AAITask, JY5322A.JY5322ACITask, JY5322A.JY5322ADITask, JY5322A.JY5322ADOTask
  • SampleRate : JY5322A.JY5322AAITask, JY5322A.JY5322ADITask
  • SamplesToAcquire : JY5322A.JY5322AAITask, JY5322A.JY5322ACITask, JY5322A.JY5322ADITask
  • SamplesToUpdate : JY5322A.JY5322ACOTask, JY5322A.JY5322ADOTask
  • SecondInputTerminal : JY5322A.TwoEdgeSeparation
  • SecondSignalReversed : JY5322A.TwoEdgeSeparation
  • SemiPeriodMeas : JY5322A.JY5322ACITask
  • SignalExport : JY5322A.JY5322AAITask, JY5322A.JY5322ACITask, JY5322A.JY5322ACOTask, JY5322A.JY5322ADITask, JY5322A.JY5322ADOTask
  • SignalReversed : JY5322A.PauseTrigger, JY5322A.PulseMeas, JY5322A.SemiPeriodMeas
  • Slope : JY5322A.AIAnalogEdgeComparator, JY5322A.AIAnalogHysteresisComparator, JY5322A.AIAnalogMultichannelEdgeComparatorSource, JY5322A.AIAnalogMultichannelHysteresisComparatorSource
  • Source : JY5322A.AIAnalogMultichannelEdgeComparatorSource, JY5322A.AIAnalogMultichannelHysteresisComparatorSource, JY5322A.AIAnalogMultichannelWindowComparatorSource, JY5322A.AIAnalogTrigger, JY5322A.AIDigitalTrigger, JY5322A.AISampleClock, JY5322A.CIDigitalTrigger, JY5322A.CISampleClock, JY5322A.CITimebase, JY5322A.CODigitalTrigger, JY5322A.COTimebase, JY5322A.DIDigitalTrigger, JY5322A.DISampleClock, JY5322A.DODigitalTrigger, JY5322A.DOSampleClock
  • Sources : JY5322A.AIAnalogMultichannelEdgeComparator, JY5322A.AIAnalogMultichannelHysteresisComparator, JY5322A.AIAnalogMultichannelWindowComparator
  • StartingEdge : JY5322A.FrequencyMeas, JY5322A.PeriodMeas, JY5322A.PulseMeas, JY5322A.SemiPeriodMeas


5322A C# API Manual: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all properties with links to the classes they belong to:

- t -

  • Terminal : JY5322A.AIExternalSampleClock, JY5322A.CIExternalSampleClock, JY5322A.CIExternalTimebase, JY5322A.COExternalTimebase, JY5322A.DIExternalSampleClock, JY5322A.DOExternalSampleClock, JY5322A.EdgeCountingOutEvent, JY5322A.PauseTrigger
  • TerminalBoard : JY5322A.JY5322AAITask
  • Threshold : JY5322A.AIAnalogEdgeComparator, JY5322A.AIAnalogMultichannelEdgeComparatorSource, JY5322A.EdgeCountingOutEvent
  • Timebase : JY5322A.FrequencyMeas, JY5322A.JY5322ACOTask, JY5322A.PeriodMeas, JY5322A.PulseMeas, JY5322A.SemiPeriodMeas, JY5322A.TwoEdgeSeparation
  • TransferedPulses : JY5322A.JY5322ACOTask
  • TransferedSamples : JY5322A.JY5322AAITask, JY5322A.JY5322ACITask, JY5322A.JY5322ACOTask, JY5322A.JY5322ADITask, JY5322A.JY5322ADOTask
  • Trigger : JY5322A.JY5322AAITask, JY5322A.JY5322ACITask, JY5322A.JY5322ACOTask, JY5322A.JY5322ADITask, JY5322A.JY5322ADOTask
  • TwoEdgeSeparation : JY5322A.JY5322ACITask
  • TwoPulseEncoder : JY5322A.JY5322ACITask
  • Type : JY5322A.AITrigger, JY5322A.CITrigger, JY5322A.COTrigger, JY5322A.DITrigger, JY5322A.DOTrigger, JY5322A.JY5322ACITask


5322A C# API Manual: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all properties with links to the classes they belong to:

- u -

  • UpdateRate : JY5322A.JY5322ADOTask


5322A C# API Manual: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all properties with links to the classes they belong to:

- w -

  • Window : JY5322A.AIAnalogMultichannelComparator, JY5322A.AIAnalogTrigger


5322A C# API Manual: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all properties with links to the classes they belong to:

- z -

  • ZInputTerminal : JY5322A.QuadEncoder
  • ZReloadEnabled : JY5322A.QuadEncoder
  • ZSignalReversed : JY5322A.QuadEncoder


5322A C# API Manual: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- q -

  • QuadEncoder : JY5322A.JY5322ACITask


5322A C# API Manual: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- r -

  • RangeHigh : JY5322A.AIChannel
  • RangeLow : JY5322A.AIChannel
  • Rate : JY5322A.CIInternalSampleClock
  • RawDataWidth : JY5322A.AIAdvanced, JY5322A.AISamplingInfo
  • ReadData() : JY5322A.JY5322AAITask, JY5322A.JY5322ACITask, JY5322A.JY5322ADITask
  • ReadRawData() : JY5322A.JY5322AAITask
  • ReadRawSinglePoint() : JY5322A.JY5322AAITask
  • ReadSinglePoint() : JY5322A.JY5322AAITask, JY5322A.JY5322ACITask, JY5322A.JY5322ADITask
  • Record : JY5322A.JY5322AAITask
  • RemoveChannel() : JY5322A.JY5322AAITask, JY5322A.JY5322ADITask, JY5322A.JY5322ADOTask
  • Reserved1 : JY5322A.ScalingCoefficients
  • Reserved2 : JY5322A.ScalingCoefficients
  • Reset : JY5322A.EdgeCountingOutEvent
  • ReTriggerCount : JY5322A.AITrigger


5322A C# API Manual: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- s -

  • SampleClock : JY5322A.JY5322AAITask, JY5322A.JY5322ACITask, JY5322A.JY5322ADITask, JY5322A.JY5322ADOTask
  • SampleRate : JY5322A.JY5322AAITask, JY5322A.JY5322ADITask
  • SamplesToAcquire : JY5322A.JY5322AAITask, JY5322A.JY5322ACITask, JY5322A.JY5322ADITask
  • SamplesToUpdate : JY5322A.JY5322ACOTask, JY5322A.JY5322ADOTask
  • ScalingCoefficients() : JY5322A.ScalingCoefficients
  • SecondInputTerminal : JY5322A.TwoEdgeSeparation
  • SecondSignalReversed : JY5322A.TwoEdgeSeparation
  • SemiPeriodMeas : JY5322A.JY5322ACITask
  • SendSoftwareTrigger() : JY5322A.JY5322AAITask, JY5322A.JY5322ACITask, JY5322A.JY5322ACOTask, JY5322A.JY5322ADITask, JY5322A.JY5322ADOTask
  • SignalExport : JY5322A.JY5322AAITask, JY5322A.JY5322ACITask, JY5322A.JY5322ACOTask, JY5322A.JY5322ADITask, JY5322A.JY5322ADOTask
  • SignalReversed : JY5322A.PauseTrigger, JY5322A.PulseMeas, JY5322A.SemiPeriodMeas
  • Slope : JY5322A.AIAnalogEdgeComparator, JY5322A.AIAnalogHysteresisComparator, JY5322A.AIAnalogMultichannelEdgeComparatorSource, JY5322A.AIAnalogMultichannelHysteresisComparatorSource
  • Source : JY5322A.AIAnalogMultichannelEdgeComparatorSource, JY5322A.AIAnalogMultichannelHysteresisComparatorSource, JY5322A.AIAnalogMultichannelWindowComparatorSource, JY5322A.AIAnalogTrigger, JY5322A.AIDigitalTrigger, JY5322A.AISampleClock, JY5322A.CIDigitalTrigger, JY5322A.CISampleClock, JY5322A.CITimebase, JY5322A.CODigitalTrigger, JY5322A.COTimebase, JY5322A.DIDigitalTrigger, JY5322A.DISampleClock, JY5322A.DODigitalTrigger, JY5322A.DOSampleClock
  • Sources : JY5322A.AIAnalogMultichannelEdgeComparator, JY5322A.AIAnalogMultichannelHysteresisComparator, JY5322A.AIAnalogMultichannelWindowComparator
  • Start() : JY5322A.JY5322AAITask, JY5322A.JY5322ACITask, JY5322A.JY5322ACOTask, JY5322A.JY5322ADITask, JY5322A.JY5322ADOTask
  • StartingEdge : JY5322A.FrequencyMeas, JY5322A.PeriodMeas, JY5322A.PulseMeas, JY5322A.SemiPeriodMeas
  • Stop() : JY5322A.JY5322AAITask, JY5322A.JY5322ACITask, JY5322A.JY5322ACOTask, JY5322A.JY5322ADITask, JY5322A.JY5322ADOTask


5322A C# API Manual: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- t -

  • Terminal : JY5322A.AIExternalSampleClock, JY5322A.CIExternalSampleClock, JY5322A.CIExternalTimebase, JY5322A.COExternalTimebase, JY5322A.DIExternalSampleClock, JY5322A.DOExternalSampleClock, JY5322A.EdgeCountingOutEvent, JY5322A.PauseTrigger
  • TerminalBoard : JY5322A.JY5322AAITask
  • Threshold : JY5322A.AIAnalogEdgeComparator, JY5322A.AIAnalogMultichannelEdgeComparatorSource, JY5322A.EdgeCountingOutEvent
  • Timebase : JY5322A.FrequencyMeas, JY5322A.JY5322ACOTask, JY5322A.PeriodMeas, JY5322A.PulseMeas, JY5322A.SemiPeriodMeas, JY5322A.TwoEdgeSeparation
  • TransferedPulses : JY5322A.JY5322ACOTask
  • TransferedSamples : JY5322A.JY5322AAITask, JY5322A.JY5322ACITask, JY5322A.JY5322ACOTask, JY5322A.JY5322ADITask, JY5322A.JY5322ADOTask
  • Trigger : JY5322A.JY5322AAITask, JY5322A.JY5322ACITask, JY5322A.JY5322ACOTask, JY5322A.JY5322ADITask, JY5322A.JY5322ADOTask
  • TwoEdgeSeparation : JY5322A.JY5322ACITask
  • TwoPulseEncoder : JY5322A.JY5322ACITask
  • Type : JY5322A.AITrigger, JY5322A.CITrigger, JY5322A.COTrigger, JY5322A.DITrigger, JY5322A.DOTrigger, JY5322A.JY5322ACITask


5322A C# API Manual: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- u -

  • UpdateRate : JY5322A.JY5322ADOTask


5322A C# API Manual: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- w -

  • WaitUntilDone() : JY5322A.JY5322AAITask, JY5322A.JY5322ACOTask, JY5322A.JY5322ADOTask
  • Window : JY5322A.AIAnalogMultichannelComparator, JY5322A.AIAnalogTrigger
  • WriteData() : JY5322A.JY5322ACOTask, JY5322A.JY5322ADOTask
  • WriteSinglePoint() : JY5322A.JY5322ACOTask, JY5322A.JY5322ADOTask


5322A C# API Manual: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- z -

  • ZInputTerminal : JY5322A.QuadEncoder
  • ZReloadEnabled : JY5322A.QuadEncoder
  • ZSignalReversed : JY5322A.QuadEncoder


5322A C# API Manual: Main Page

5322A C# API Manual Documentation


5322A C# API Manual: Package Members

  • Package List
  • Package Members
  • All
  • Enumerations
  • a
  • c
  • d
  • e
  • f
  • i
  • l
  • o
  • q
  • r
  • s
  • v
Here is a list of all namespace members with links to the namespace documentation for each member:

- a -

  • AIAnalogComparatorLogic : JY5322A
  • AIAnalogTriggerComparator : JY5322A
  • AIAnalogTriggerEdge : JY5322A
  • AIAnalogTriggerSource : JY5322A
  • AIAnalogWindowCondition : JY5322A
  • AIBandWidth : JY5322A
  • AIDigitalTriggerEdge : JY5322A
  • AIDigitalTriggerSource : JY5322A
  • AIMode : JY5322A
  • AIRawDataWidth : JY5322A
  • AISampleClockSource : JY5322A
  • AISignalExportSource : JY5322A
  • AITerminalBoard : JY5322A
  • AITriggerMode : JY5322A
  • AITriggerType : JY5322A

- c -

  • CIDigitalTriggerEdge : JY5322A
  • CIDigitalTriggerSource : JY5322A
  • CIMode : JY5322A
  • CISampleClockSource : JY5322A
  • CISignalExportSource : JY5322A
  • CITimebaseSource : JY5322A
  • CITriggerType : JY5322A
  • CIType : JY5322A
  • ClockTerminal : JY5322A
  • CODigitalTriggerEdge : JY5322A
  • CODigitalTriggerSource : JY5322A
  • COIdleState : JY5322A
  • COMode : JY5322A
  • COPulseType : JY5322A
  • COSignalExportSource : JY5322A
  • COTimebaseSource : JY5322A
  • COTriggerType : JY5322A
  • CountDirection : JY5322A

- d -

  • DIDigitalTriggerEdge : JY5322A
  • DIDigitalTriggerSource : JY5322A
  • DIMode : JY5322A
  • DISampleClockSource : JY5322A
  • DISignalExportSource : JY5322A
  • DITriggerMode : JY5322A
  • DITriggerType : JY5322A
  • DODigitalTriggerEdge : JY5322A
  • DODigitalTriggerSource : JY5322A
  • DOMode : JY5322A
  • DOSampleClockSource : JY5322A
  • DOSignalExportSource : JY5322A
  • DOTriggerType : JY5322A

- e -

  • EdgeCntOunEvtIdleState : JY5322A
  • EdgeType : JY5322A

- f -

  • FileFormat : JY5322A

- i -

  • InputTerminal : JY5322A
  • IOTerminal : JY5322A

- l -

  • LevelPolarity : JY5322A

- o -

  • OutputCompleteState : JY5322A
  • OutputState : JY5322A

- q -

  • QuadEncodingType : JY5322A

- r -

  • RecordMode : JY5322A

- s -

  • SignalExportDestination : JY5322A
  • SignalExportOutputType : JY5322A

- v -

  • ValueReturnMode : JY5322A


5322A C# API Manual: Package Members

  • Package List
  • Package Members
  • All
  • Enumerations
  • a
  • c
  • d
  • e
  • f
  • i
  • l
  • o
  • q
  • r
  • s
  • v
Here is a list of all namespace enums with links to the namespace documentation for each enum:

- a -

  • AIAnalogComparatorLogic : JY5322A
  • AIAnalogTriggerComparator : JY5322A
  • AIAnalogTriggerEdge : JY5322A
  • AIAnalogTriggerSource : JY5322A
  • AIAnalogWindowCondition : JY5322A
  • AIBandWidth : JY5322A
  • AIDigitalTriggerEdge : JY5322A
  • AIDigitalTriggerSource : JY5322A
  • AIMode : JY5322A
  • AIRawDataWidth : JY5322A
  • AISampleClockSource : JY5322A
  • AISignalExportSource : JY5322A
  • AITerminalBoard : JY5322A
  • AITriggerMode : JY5322A
  • AITriggerType : JY5322A

- c -

  • CIDigitalTriggerEdge : JY5322A
  • CIDigitalTriggerSource : JY5322A
  • CIMode : JY5322A
  • CISampleClockSource : JY5322A
  • CISignalExportSource : JY5322A
  • CITimebaseSource : JY5322A
  • CITriggerType : JY5322A
  • CIType : JY5322A
  • ClockTerminal : JY5322A
  • CODigitalTriggerEdge : JY5322A
  • CODigitalTriggerSource : JY5322A
  • COIdleState : JY5322A
  • COMode : JY5322A
  • COPulseType : JY5322A
  • COSignalExportSource : JY5322A
  • COTimebaseSource : JY5322A
  • COTriggerType : JY5322A
  • CountDirection : JY5322A

- d -

  • DIDigitalTriggerEdge : JY5322A
  • DIDigitalTriggerSource : JY5322A
  • DIMode : JY5322A
  • DISampleClockSource : JY5322A
  • DISignalExportSource : JY5322A
  • DITriggerMode : JY5322A
  • DITriggerType : JY5322A
  • DODigitalTriggerEdge : JY5322A
  • DODigitalTriggerSource : JY5322A
  • DOMode : JY5322A
  • DOSampleClockSource : JY5322A
  • DOSignalExportSource : JY5322A
  • DOTriggerType : JY5322A

- e -

  • EdgeCntOunEvtIdleState : JY5322A
  • EdgeType : JY5322A

- f -

  • FileFormat : JY5322A

- i -

  • InputTerminal : JY5322A
  • IOTerminal : JY5322A

- l -

  • LevelPolarity : JY5322A

- o -

  • OutputCompleteState : JY5322A
  • OutputState : JY5322A

- q -

  • QuadEncodingType : JY5322A

- r -

  • RecordMode : JY5322A

- s -

  • SignalExportDestination : JY5322A
  • SignalExportOutputType : JY5322A

- v -

  • ValueReturnMode : JY5322A


5322A C# API Manual: Package List

  • Package List
  • Package Members
Package List
Here are the packages with brief descriptions (if available):
N JY5322A